Bug 441908 - syntax error in /etc/rc.d/init.d/firstboot
syntax error in /etc/rc.d/init.d/firstboot
Status: CLOSED DUPLICATE of bug 441016
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-10 14:06 EDT by archimerged Ark submedes
Modified: 2008-04-11 01:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-11 01:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description archimerged Ark submedes 2008-04-10 14:06:28 EDT
+++ This bug was initially created as a clone of Bug #441511 +++

Splitting out the minor problem so it can be marked closed.

Description of problem:
Syntax error in /etc/rc.d/init.d/firstboot

Version-Release number of selected component (if applicable):
rawhide 20080409

How reproducible:

-- Additional comment from archimerged@gmail.com on 2008-04-09 19:25 EST --
Created an attachment (id=301907)
Patch /etc/rc.d/init.d/firstboot

Fix syntax error and update comments in /etc/rc.d/init.d/firstboot.  Correct
the description in both chkconfig and INIT INFO sections.

grep -qs returns 0 (true) if the file exists and the string is present.
It returns 1 (false) if the string is absent.
It returns 2 (false) if the file is absent.

[beta@beta firstboot]$ cat /etc/sysconfig/firstboot 
[beta@beta firstboot]$ if grep -qs 'RUN_FIRSTBOOT=NO'
/etc/sysconfig/nonexistant-file; then echo true; else echo false; fi
[beta@beta firstboot]$ if grep -qs 'RUN_FIRSTBOOT=NO' /etc/sysconfig/firstboot;
then echo true; else echo false; fi
[beta@beta firstboot]$ if grep -qs 'string not present'
/etc/sysconfig/firstboot; then echo true; else echo false; fi
Comment 1 Chris Lumens 2008-04-11 01:53:33 EDT

*** This bug has been marked as a duplicate of 441016 ***

Note You need to log in before you can comment on or make changes to this bug.