Bug 442010 - anaconda fails to proceed to stage2 when using >= 20th NIC with Xen
anaconda fails to proceed to stage2 when using >= 20th NIC with Xen
Status: CLOSED DUPLICATE of bug 444919
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 04:50 EDT by Alexander Todorov
Modified: 2009-02-20 23:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 23:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script used to start the virtual guest (449 bytes, text/plain)
2008-04-11 04:52 EDT, Alexander Todorov
no flags Details
output from tty3 when eth19 is selected (30.98 KB, image/png)
2008-04-18 09:19 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-04-11 04:50:43 EDT
Description of problem:
When doing a Xen guest installation I assign multiple NICs to the guest.
Anaconda will see the devices as eth0...ethN. I'm able to choose any of the
devices, assign DHCP lease to it and proceed to stage2 to perform the
installation. However when I select devices with number eth19 and above (the
20th device) anaconda shows the TCP/IP settings screen in loader and stays
there. I can not proceed.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.112-1
RHEL5.2-Server-snap#5

How reproducible:
100%

Steps to Reproduce:
1. Start a PV Xen guest with 20 or more nics
2. Anaconda sees the devices as ethN - Xen Virtual network
3. Select eth19 or above and click next (F12)
4. Do not change anything on the TCP/IP settings screen (default is DHCP).
5. Press F12 or click the OK button.

  
Actual results:
Anaconda does not proceed. Stays at the network settings screen.

Expected results:
Anaconda proceeds with obtaining a DHCP lease for the selected device and
transitions to stage2.

Additional info:
Doesn't matter if you bridge to xenbr0 or virbr0 on dom0.
Comment 1 Alexander Todorov 2008-04-11 04:52:30 EDT
Created attachment 302097 [details]
script used to start the virtual guest

* execute as root
* script is appendign -m $MAC -b $bridge parameters to emulate higher number of

NICs
* MAC addresses do not conflict with other on the network or other Xen guests
Comment 2 Alexander Todorov 2008-04-11 04:53:24 EDT
Note: If you are using an earlier tree you may hit bug #433755 - a crash
Comment 4 Alexander Todorov 2008-04-18 09:19:08 EDT
Created attachment 302881 [details]
output from tty3 when eth19 is selected
Comment 7 RHEL Product and Program Management 2008-06-09 15:12:55 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 9 David Cantrell 2009-02-20 23:37:55 EST

*** This bug has been marked as a duplicate of bug 444919 ***

Note You need to log in before you can comment on or make changes to this bug.