Bug 444919 - Anaconda stage 1 installer does NOT work with network installs on ports above eth85
Anaconda stage 1 installer does NOT work with network installs on ports above...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libdhcp (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: David Cantrell
:
: 442010 (view as bug list)
Depends On: 500775
Blocks: 5.4/TechnicalNotes
  Show dependency treegraph
 
Reported: 2008-05-01 16:50 EDT by Bill Hayes
Modified: 2010-03-14 17:29 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
previously, the method used by libdhcp to build a list of network interfaces available on a system could accommodate a maximum of 86 interfaces. As a consequence, attempts to perform network-based installations through interfaces eth86 and higher would fail. libdhcp now uses libnl to build a list of valid interfaces and therefore is no longer limited to the first 86 that it finds. Network-based installations are therefore possible on a wider range of hardware and network configurations.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/anaconda.log file (326.50 KB, application/octet-stream)
2008-05-01 16:53 EDT, Bill Hayes
no flags Details
manynics.c (4.15 KB, text/plain)
2008-11-03 19:58 EST, David Cantrell
no flags Details
Requested manynics output with nl_cache_free() replaced with nl_cache_destroy_and_free() (19.51 KB, text/plain)
2008-11-19 16:30 EST, Bryan Stillwell
no flags Details
libdhcp-1.20-use-libnl.patch (31.83 KB, patch)
2009-05-01 21:35 EDT, David Cantrell
no flags Details | Diff
/var/log/anaconda.log (385.45 KB, text/plain)
2009-07-19 23:30 EDT, Jiayin Shao
no flags Details

  None (edit)
Description Bill Hayes 2008-05-01 16:50:41 EDT
This is a follow-on to Bug 429968.  Bug 429968 was fixed in RHEL 5.2 and enabled
network installs up to about 25 Ethernet ports.  

We have new systems coming out that will have a minimum number of Ethernet ports
in them of 128.  128 Ethernet ports is the base configuration for our largest
server configuration.  The customer can add additional Ethernet ports up to
almost 300 Ethernet ports.

I put together a configuration with 104 Ethernet ports to simulate this new
server.  Once Linux is installed and running I can get 98 of the 102 ports to
work.  A driver problem is preventing 4 of the ports from working and
cabling/defective cards prevents the other 2 ports from working.

Anaconda Stage1 installer is able to bring up the Ethernet ports eth0 to eth85.
 The Anaconda Stage1 installer is unable to bring up ports eth86 to eth103.  The
problem is that you can't bring up ports above eth85 on the "Configure TCP/IP"
within the stage 1 installer.

This is not a kernel/driver problem because most of the ports that Anaconda
can't bring up the installed/running kernel can bring up.  The ports that won't
come up are both Intel and Broadcom ports, so it is not a specific Ethernet
driver problem either.

I need this fixed in RHEL 5.3 and RHEL 6.  It does need to be fixed in RHEL 5.2
even thought that was what I used for my test (RHEL 5.2 Snapshot 7).

How reproducible:

This failure was generated on a HP rx8640 with a I/O chassis.  The system has 32
I/O PCI-X and PCI-e slots.  Many of the slots are populated with 4 port Ethernet
cards.

The system that generated the failure has the following Ethernet configuration:

 eth0 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        ^ 
 eth1 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        # 
 eth2 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        : 
 eth3 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        : 
 eth4 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        : 
 eth5 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        v 
 eth6 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        ^ 
 eth7 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        # 
 eth8 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        : 
 eth9 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)        : 
 eth10 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       : 
 eth11 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       v 
 eth12 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       ^ 
 eth13 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       # 
 eth14 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       : 
 eth15 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       : 
 eth16 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       : 
 eth17 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       v 
 eth18 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       ^ 
 eth19 - Intel Corporation 82571EB Gigabit Ethernet Controller (Copper)       # 
 eth20 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth21 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth22 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth23 - Intel Corporation 82571EB Gigabit Ethernet Controller                v 
 eth24 - Intel Corporation 82571EB Gigabit Ethernet Controller                ^ 
 eth25 - Intel Corporation 82571EB Gigabit Ethernet Controller                # 
 eth26 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth27 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth28 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth29 - Intel Corporation 82571EB Gigabit Ethernet Controller                v 
 eth30 - Intel Corporation 82571EB Gigabit Ethernet Controller                ^ 
 eth31 - Intel Corporation 82571EB Gigabit Ethernet Controller                : 
 eth32 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth33 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth34 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth35 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth36 - Digital Equipment Corporation DECchip 21142/43                       ^ 
 eth37 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth38 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth39 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth40 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth41 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth42 - Digital Equipment Corporation DECchip 21142/43                       ^ 
 eth43 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth44 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth45 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth46 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth47 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth48 - Digital Equipment Corporation DECchip 21142/43                       ^ 
 eth49 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth50 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth51 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth52 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth53 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth54 - Digital Equipment Corporation DECchip 21142/43                       ^ 
 eth55 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth56 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth57 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth58 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth59 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth60 - Digital Equipment Corporation DECchip 21142/43                       ^ 
 eth61 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth62 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth63 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth64 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth65 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth66 - Digital Equipment Corporation DECchip 21142/43                       ^ 
 eth67 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth68 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth69 - Digital Equipment Corporation DECchip 21142/43                       # 
 eth70 - Digital Equipment Corporation DECchip 21142/43                       : 
 eth71 - Digital Equipment Corporation DECchip 21142/43                       v 
 eth72 - Intel Corporation 82546GB Gigabit Ethernet Controller                ^ 
 eth73 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth74 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth75 - Intel Corporation 82546GB Gigabit Ethernet Controller                # 
 eth76 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth77 - Intel Corporation 82546GB Gigabit Ethernet Controller                v 
 eth78 - Intel Corporation 82546GB Gigabit Ethernet Controller                ^ 
 eth79 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth80 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth81 - Intel Corporation 82546GB Gigabit Ethernet Controller                # 
 eth82 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth83 - Intel Corporation 82546GB Gigabit Ethernet Controller                v 
 eth84 - Intel Corporation 82546GB Gigabit Ethernet Controller                ^ 
 eth85 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth86 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth87 - Intel Corporation 82546GB Gigabit Ethernet Controller                # 
 eth88 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth89 - Intel Corporation 82546GB Gigabit Ethernet Controller                v 
 eth90 - Intel Corporation 82546GB Gigabit Ethernet Controller                ^ 
 eth91 - Intel Corporation 82546GB Gigabit Ethernet Controller                : 
 eth92 - Broadcom Corporation NetXtreme II BCM57710 10Gigabit PCIe [Everest]  : 
 eth93 - Broadcom Corporation NetXtreme II BCM57710 10Gigabit PCIe [Everest]  # 
 eth94 - Broadcom Corporation NetXtreme II BCM57710 10Gigabit PCIe [Everest]  : 
 eth95 - Broadcom Corporation NetXtreme II BCM57710 10Gigabit PCIe [Everest]  v 
 eth96 - Broadcom Corporation NetXtreme BCM5703 Gigabit Ethernet              ^ 
 eth97 - Broadcom Corporation NetXtreme BCM5703 Gigabit Ethernet              : 
 eth98 - Broadcom Corporation NetXtreme BCM5703 Gigabit Ethernet              : 
 eth99 - Broadcom Corporation NetXtreme BCM5703 Gigabit Ethernet              # 
 eth100 - Intel Corporation 82575EB Gigabit Network Connection                : 
 eth101 - Intel Corporation 82575EB Gigabit Network Connection                v 
 eth102 - Intel Corporation 82575EB Gigabit Network Connection                # 
 eth103 - Intel Corporation 82575EB Gigabit Network Connection                v 

In general eth0 thru eth86 would come up fine.  Ports eth86 thru eth103 would
not come up at all.

Version-Release number of selected component (if applicable):

This test was done on RHEL 5.2 Snapshot 7.

Steps to Reproduce:
1.  Configure a system with 86 or more Ethernet ports
2.  Get into the stage 1 Anaconda installer
3.  Try to bring up each of the Ethernet ports with the "Configure TCP/IP"
screen.  Use 'Back' to go back to select the next Ethernet port.

Actual results:

Not all of the Ethernet ports will work within the stage 1 Anaconda installer.

Expected results:

All of the Ethernet ports will work within the stage 1 Anaconda installer.

Additional info:

I ran the install with 'loglevel=debug' and then saved off the /tmp/anaconda.log
file.  I will attached this file.
Comment 1 Bill Hayes 2008-05-01 16:53:16 EDT
Created attachment 304346 [details]
/tmp/anaconda.log file
Comment 2 rick bieber 2008-08-07 12:32:54 EDT
Hi, we are looking to get this bug resolved with RHEL 5.3.  Bill Hayes opened the bug and provided a log file back in May and there have been no comments from Redhat since then.  Can someone from Redhat provide a status on this bug.

Thanks, Rick Bieber
Comment 3 David Cantrell 2008-08-07 15:34:01 EDT
In the log file, I see this:

17:42:26 ERROR   : nic_by_name: no interface named eth12 found
17:42:34 ERROR   : nic_by_name: no interface named eth12 found
17:43:34 ERROR   : nic_by_name: no interface named eth12 found
18:01:00 ERROR   : nic_by_name: no interface named eth86 found
18:01:04 ERROR   : nic_by_name: no interface named eth86 found
18:01:53 ERROR   : nic_by_name: no interface named eth86 found
18:01:57 ERROR   : nic_by_name: no interface named eth86 found
18:03:15 ERROR   : nic_by_name: no interface named eth87 found
18:03:18 ERROR   : nic_by_name: no interface named eth87 found
18:04:59 ERROR   : nic_by_name: no interface named eth88 found
18:05:02 ERROR   : nic_by_name: no interface named eth88 found
18:07:45 ERROR   : nic_by_name: no interface named eth90 found
18:07:49 ERROR   : nic_by_name: no interface named eth90 found
18:08:01 ERROR   : nic_by_name: no interface named eth90 found
18:08:04 ERROR   : nic_by_name: no interface named eth90 found
18:08:54 ERROR   : nic_by_name: no interface named eth96 found
18:09:05 ERROR   : nic_by_name: no interface named eth96 found
18:09:22 ERROR   : nic_by_name: no interface named eth96 found
18:15:46 ERROR   : nic_by_name: no interface named eth102 found
18:15:52 ERROR   : nic_by_name: no interface named eth102 found
18:16:33 ERROR   : nic_by_name: no interface named eth103 found
18:16:37 ERROR   : nic_by_name: no interface named eth103 found

Which is a libdhcp (sigh) failure.  Reassigning component.
Comment 4 David Cantrell 2008-11-03 19:58:28 EST
Created attachment 322382 [details]
manynics.c
Comment 5 David Cantrell 2008-11-03 20:01:14 EST
Can someone at HP run the manynics.c program on a system with more than 85 NICs?  This is just a test program that should dump out some info about all NICs in the system.

Make sure you have installed libnl-devel.

To compile:
CFLAGS="-Wall -O2 $(pkg-config libnl-1 --cflags)"
LIBS=$(pkg-config libnl-1 --libs)
gcc $CFLAGS -o manynics manynics.c $LIBS

To run:
./manynics 2>&1 | tee manynics.log

Please attach the resulting manynics.log file to this bug report.  If more than 85 are seen, I have an idea of how to patch libdhcp to fix this problem.

Thanks.
Comment 6 Bryan Stillwell 2008-11-19 13:15:51 EST
David,

I'm trying to test this bug with rhel5.3s3 and couldn't get manynics to compile as you wrote it:

# gcc $CFLAGS -o manynics manynics.c $LIBS
manynics.c: In function ‘main’:
manynics.c:122: warning: implicit declaration of function ‘nl_cache_free’
/tmp/ccsWJxku.o: In function `main':
manynics.c:(.text+0x3f2): undefined reference to `nl_cache_free'
manynics.c:(.text+0x562): undefined reference to `nl_cache_free'
collect2: ld returned 1 exit status


I took a look at the code and it looked like nl_cache_destroy_and_free() might be a valid replacement for nl_cache_free().  Would this be correct?

Also, do you need every nic to be connected to the network when I run this?  

Right now I just have one nic connected and when I run my modified manynics it doesn't report a link on that port:

Name: eth72
Index: 41
Address: 00:15:60:04:38:9c
Txqlen: 1000d
MTU: 1500d
Broadcast: ff:ff:ff:ff:ff:ff
Link: -1
Weight: 64d
Master: -1
Qdisc: pfifo_fast


OTOH, ethtool does report a link:

# ethtool eth72
Settings for eth72:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: umbg
        Wake-on: d
        Current message level: 0x00000007 (7)
        Link detected: yes


Thanks,
Bryan
Comment 7 Bryan Stillwell 2008-11-19 16:30:56 EST
Created attachment 324095 [details]
Requested manynics output with nl_cache_free() replaced with nl_cache_destroy_and_free()

I did an install of rhel5.3s3 with eth72 (since eth127 returned right away without getting a dhcp address).  During the network config part of the install I disabled eth72 and enabled eth127.  When booting into the installed system it came up with eth127 just fine.

As requested, I've attached the manynics.log file.  Only ports eth72, eth73, eth126, and eth127 had cables attached.
Comment 8 Bryan Stillwell 2009-02-05 14:23:59 EST
Still a problem in the released version of rhel5.3
Comment 9 David Cantrell 2009-02-05 19:57:01 EST
(In reply to comment #8)
> Still a problem in the released version of rhel5.3

Right.  Targeting 5.4 for the fix for this issue.
Comment 10 David Cantrell 2009-02-20 23:37:55 EST
*** Bug 442010 has been marked as a duplicate of this bug. ***
Comment 12 David Cantrell 2009-05-01 21:35:59 EDT
Created attachment 342160 [details]
libdhcp-1.20-use-libnl.patch
Comment 13 David Cantrell 2009-05-08 17:27:55 EDT
Fix will be in libdhcp-1.20-9.el5 and later.
Comment 15 David Cantrell 2009-05-22 18:27:50 EDT
libdhcp-1.20-10.el5 fixes the issues we've been seeing with this fix.  See bug #500775 for more details.
Comment 17 Alexander Todorov 2009-07-01 08:36:56 EDT
HP,
do you have access to the latest bits for testing? Please provide feedback if possible.
Comment 18 Bill Hayes 2009-07-01 17:43:30 EDT
We will try to test the RHEL 5.4 bits once we get a setup with that many NICs setup again.  Not sure how long that will take.
Comment 19 Chris Ward 2009-07-03 14:02:36 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 20 Brock Organ 2009-07-13 15:50:34 EDT
Hi Bill,

We're hoping that (due to time and schedule constraints) you might be able to provide testing feedback in the next week ... if such feedback isn't in your scope and there are any other problems with this particular issue, the concern is that we may unfortunately have to defer the fix to another update ...

Regards,

Brock
Comment 21 Jiayin Shao 2009-07-17 04:02:54 EDT
Hi,
I have done this testing. The bug has been fixed.

There are 148 ethernet ports in server. Not every ethernet port is connected on it, but I can find all the eths when stage 1 installing.
Comment 22 Alexander Todorov 2009-07-17 04:32:17 EDT
Hi Jiayin,
what do you mean by:

<quote>
Not every ethernet port is connected on it, but I can find all the eths when stage 1 installing.
</quote>

From the steps to reproduce:
1.  Configure a system with 86 or more Ethernet ports

Done.

2.  Get into the stage 1 Anaconda installer

Done. 

3.  Try to bring up each of the Ethernet ports with the "Configure TCP/IP"
screen.  Use 'Back' to go back to select the next Ethernet port.

What's the result from this step? Try bringing up eth100 and use it to perform an install for example.

Also see comment #3. Can you attach your anaconda.log or inspect it for error messages like:
17:42:26 ERROR   : nic_by_name: no interface named eth12 found


Thanks,
Alexander.
Comment 23 Jiayin Shao 2009-07-19 23:22:48 EDT
Hi Alexander,

3.  Try to bring up each of the Ethernet ports with the "Configure TCP/IP"
screen.  Use 'Back' to go back to select the next Ethernet port.

What's the result from this step? Try bringing up eth100 and use it to perform
an install for example.

Also see comment #3. Can you attach your anaconda.log or inspect it for error
messages like:
17:42:26 ERROR   : nic_by_name: no interface named eth12 found


I'm doing a remoting testing with a server with 148 ports ethernets configured. There are about 12 ports connected, not all 148 ports. However, some ports above eth133 are connected. 

I believed it is ok if installer is able to bring up the port above eth85. So I booted and installed os via eth133, I tried bringing up eth133 with the "Configure TCP/IP" screen. Use 'Back' to go back to select eth134 port. Not for others.

Is that not enough, is it? Must try each port of all? Now I'm not sure if that meet the bug's requirement.

If need I will ask my colleague in America server room to connect all the port and retry it. 

Below is the ethernet list in which you can see which port are connected.
eth0 (A5506B)   00:30:6e:5e:fe:b4 <p0> tulip  [down]
eth1 (A5506B)   00:30:6e:5e:fe:b5 <p0> tulip  [down]
eth2 (A5506B)   00:30:6e:5e:fe:b6 <p0> tulip  [down]
eth3 (A5506B)   00:30:6e:5e:fe:b7 <p0> tulip  [down]
eth4 (A5506B)   00:11:85:c7:1c:90 <p0> tulip  [down]
eth5 (A5506B)   00:11:85:c7:1c:91 <p0> tulip  [down]
eth6 (A5506B)   00:11:85:c7:1c:92 <p0> tulip  [down]
eth7 (A5506B)   00:11:85:c7:1c:93 <p0> tulip  [down]
eth8 (A5506B)   00:30:6e:5e:fe:d8 <p0> tulip  [down]
eth9 (A5506B)   00:30:6e:5e:fe:d9 <p0> tulip  [down]
eth10 (A5506B)  00:30:6e:5e:fe:da <p0> tulip  [down]
eth11 (A5506B)  00:30:6e:5e:fe:db <p0> tulip  [down]
eth12 (A5506B)  00:30:6e:46:de:6c <p0> tulip  [down]
eth13 (A5506B)  00:30:6e:46:de:6d <p0> tulip  [down]
eth14 (A5506B)  00:30:6e:46:de:6e <p0> tulip  [down]
eth15 (A5506B)  00:30:6e:46:de:6f <p0> tulip  [down]
eth16 (A5506B)  00:0e:7f:4e:4d:e4 <p0> tulip  [down]
eth17 (A5506B)  00:0e:7f:4e:4d:e5 <p0> tulip  [down]
eth18 (A5506B)  00:0e:7f:4e:4d:e6 <p0> tulip  [down]
eth19 (A5506B)  00:0e:7f:4e:4d:e7 <p0> tulip  [down]
eth20 (A5506B)  00:0e:7f:4e:4d:3c <p0> tulip  [down]
eth21 (A5506B)  00:0e:7f:4e:4d:3d <p0> tulip  [down]
eth22 (A5506B)  00:0e:7f:4e:4d:3e <p0> tulip  [down]
eth23 (A5506B)  00:0e:7f:4e:4d:3f <p0> tulip  [down]
eth24 (A5506B)  00:30:6e:46:1b:88 <p0> tulip  [down]
eth25 (A5506B)  00:30:6e:46:1b:89 <p0> tulip  [down]
eth26 (A5506B)  00:30:6e:46:1b:8a <p0> tulip  [down]
eth27 (A5506B)  00:30:6e:46:1b:8b <p0> tulip  [down]
eth28 (A5506B)  00:30:6e:5e:fe:cc <p0> tulip  [down]
eth29 (A5506B)  00:30:6e:5e:fe:cd <p0> tulip  [down]
eth30 (A5506B)  00:30:6e:5e:fe:ce <p0> tulip  [down]
eth31 (A5506B)  00:30:6e:5e:fe:cf <p0> tulip  [down]
eth32 (A5506B)  00:0e:7f:4e:4d:40 <p0> tulip  [down]
eth33 (A5506B)  00:0e:7f:4e:4d:41 <p0> tulip  [down]
eth34 (A5506B)  00:0e:7f:4e:4d:42 <p0> tulip  [down]
eth35 (A5506B)  00:0e:7f:4e:4d:43 <p0> tulip  [down]
eth36 (A5506B)  00:30:6e:5f:01:78 <p0> tulip  [down]
eth37 (A5506B)  00:30:6e:5f:01:79 <p0> tulip  [down]
eth38 (A5506B)  00:30:6e:5f:01:7a <p0> tulip  [down]
eth39 (A5506B)  00:30:6e:5f:01:7b <p0> tulip  [down]
eth40 (A5506B)  00:30:6e:5e:fe:dc <p0> tulip  [down]
eth41 (A5506B)  00:30:6e:5e:fe:dd <p0> tulip  [down]
eth42 (A5506B)  00:30:6e:5e:fe:de <p0> tulip  [down]
eth43 (A5506B)  00:30:6e:5e:fe:df <p0> tulip  [down]
eth44 (A5506B)  00:30:6e:5e:fe:f0 <p0> tulip  [down]
eth45 (A5506B)  00:30:6e:5e:fe:f1 <p0> tulip  [down]
eth46 (A5506B)  00:30:6e:5e:fe:f2 <p0> tulip  [down]
eth47 (A5506B)  00:30:6e:5e:fe:f3 <p0> tulip  [down]
eth48 (A5506B)  00:30:6e:46:c5:64 <p0> tulip  [down]
eth49 (A5506B)  00:30:6e:46:c5:65 <p0> tulip  [down]
eth50 (A5506B)  00:30:6e:46:c5:66 <p0> tulip  [down]
eth51 (A5506B)  00:30:6e:46:c5:67 <p0> tulip  [down]
eth52 (A5506B)  00:30:6e:5e:fd:04 <p0> tulip  [down]
eth53 (A5506B)  00:30:6e:5e:fd:05 <p0> tulip  [down]
eth54 (A5506B)  00:30:6e:5e:fd:06 <p0> tulip  [down]
eth55 (A5506B)  00:30:6e:5e:fd:07 <p0> tulip  [down]
eth56 (A5506B)  00:30:6e:5e:fe:fc <p0> tulip  [down]
eth57 (A5506B)  00:30:6e:5e:fe:fd <p0> tulip  [down]
eth58 (A5506B)  00:30:6e:5e:fe:fe <p0> tulip  [down]
eth59 (A5506B)  00:30:6e:5e:fe:ff <p0> tulip  [down]
eth60 (A5506B)  00:30:6e:5e:3d:2c <p0> tulip  [down]
eth61 (A5506B)  00:30:6e:5e:3d:2d <p0> tulip  [down]
eth62 (A5506B)  00:30:6e:5e:3d:2e <p0> tulip  [down]
eth63 (A5506B)  00:30:6e:5e:3d:2f <p0> tulip  [down]
eth64 (A5506B)  00:30:6e:5f:01:88 <p0> tulip  [down]
eth65 (A5506B)  00:30:6e:5f:01:89 <p0> tulip  [down]
eth66 (A5506B)  00:30:6e:5f:01:8a <p0> tulip  [down]
eth67 (A5506B)  00:30:6e:5f:01:8b <p0> tulip  [down]
eth68 (A9900A)  00:30:6e:5d:9f:3a <p0> e1000  [down]
eth69 (A9900A)  00:30:6e:5d:9f:3b <p1> e1000  [down]
eth70 (A9899A)  00:12:79:9e:b8:12 <p0> e1000  [1000Mb/s]
eth71 (A9899A)  00:12:79:9e:b8:13 <p1> e1000  [down]
eth72 (A9900A)  00:15:60:04:38:9c <p0> e1000  [down]
eth73 (A9900A)  00:15:60:04:38:9d <p1> e1000  [down]
eth74 (A9900A)  00:30:6e:5d:bd:8e <p0> e1000  [down]
eth75 (A9900A)  00:30:6e:5d:bd:8f <p1> e1000  [down]
eth76 (A9899A)  00:12:79:9e:b7:ba <p0> e1000  [down]
eth77 (A9899A)  00:12:79:9e:b7:bb <p1> e1000  [down]
eth78 (A9899A)  00:30:6e:5d:2f:8a <p0> e1000  [down]
eth79 (A9899A)  00:30:6e:5d:2f:8b <p1> e1000  [down]
eth80 (A9899A)  00:12:79:9e:b9:64 <p0> e1000  [down]
eth81 (A9899A)  00:12:79:9e:b9:65 <p1> e1000  [down]
eth82 (A9899A)  00:30:6e:5d:31:64 <p0> e1000  [down]
eth83 (A9899A)  00:30:6e:5d:31:65 <p1> e1000  [down]
eth84 (A9899A)  00:30:6e:10:02:4c <p0> e1000  [1000Mb/s]
eth85 (A9899A)  00:30:6e:10:02:4d <p1> e1000  [down]
eth86 (A9899A)  00:15:60:04:0f:a0 <p0> e1000  [down]
eth87 (A9899A)  00:15:60:04:0f:a1 <p1> e1000  [down]
eth88 (A9899A)  00:15:60:04:14:c6 <p0> e1000  [down]
eth89 (A9899A)  00:15:60:04:14:c7 <p1> e1000  [down]
eth90 (A9899A)  00:30:6e:5d:5a:1e <p0> e1000  [down]
eth91 (A9899A)  00:30:6e:5d:5a:1f <p1> e1000  [down]
eth92 (A9899A)  00:12:79:9e:b8:46 <p0> e1000  [down]
eth93 (A9899A)  00:12:79:9e:b8:47 <p1> e1000  [down]
eth94 (A9899A)  00:15:60:04:0c:a8 <p0> e1000  [down]
eth95 (A9899A)  00:15:60:04:0c:a9 <p1> e1000  [down]
eth96 (AD145A)  00:12:79:42:fd:0c <p0> e1000  [down]
eth97 (AD145A)  00:12:79:42:fd:0d <p1> e1000  [down]
eth98 (AD145A)  00:12:79:42:fd:0e <p0> e1000  [down]
eth99 (AD145A)  00:12:79:42:fd:0f <p1> e1000  [down]
eth100 (AD145A) 00:12:79:42:fe:3c <p0> e1000  [down]
eth101 (AD145A) 00:12:79:42:fe:3d <p1> e1000  [down]
eth102 (AD145A) 00:12:79:42:fe:3e <p0> e1000  [down]
eth103 (AD145A) 00:12:79:42:fe:3f <p1> e1000  [down]
eth104 (A9899A) 00:15:60:04:14:84 <p0> e1000  [down]
eth105 (A9899A) 00:15:60:04:14:85 <p1> e1000  [down]
eth106 (A9899A) 00:12:79:9e:58:b0 <p0> e1000  [down]
eth107 (A9899A) 00:12:79:9e:58:b1 <p1> e1000  [down]
eth108 (A9899A) 00:30:6e:5d:2e:8c <p0> e1000  [down]
eth109 (A9899A) 00:30:6e:5d:2e:8d <p1> e1000  [down]
eth110 (A9899A) 00:12:79:9e:b4:d8 <p0> e1000  [down]
eth111 (A9899A) 00:12:79:9e:b4:d9 <p1> e1000  [down]
eth112 (AD145A) 00:12:79:42:fd:e4 <p0> e1000  [down]
eth113 (AD145A) 00:12:79:42:fd:e5 <p1> e1000  [down]
eth114 (AD145A) 00:12:79:42:fd:e6 <p0> e1000  [down]
eth115 (AD145A) 00:12:79:42:fd:e7 <p1> e1000  [down]
eth116 (A9900A) 00:12:79:9e:43:da <p0> e1000  [down]
eth117 (A9900A) 00:12:79:9e:43:db <p1> e1000  [1000Mb/s]
eth118 (A9899A) 00:30:6e:5d:5a:04 <p0> e1000  [down]
eth119 (A9899A) 00:30:6e:5d:5a:05 <p1> e1000  [down]
eth120 (A9899A) 00:15:60:04:0c:70 <p0> e1000  [down]
eth121 (A9899A) 00:15:60:04:0c:71 <p1> e1000  [down]
eth122 (A9900A) 00:12:79:9e:89:f8 <p0> e1000  [down]
eth123 (A9900A) 00:12:79:9e:89:f9 <p1> e1000  [down]
eth124 (A9900A) 00:12:79:9e:89:dc <p0> e1000  [down]
eth125 (A9900A) 00:12:79:9e:89:dd <p1> e1000  [down]
eth126 (A9899A) 00:12:79:9e:56:88 <p0> e1000  [down]
eth127 (A9899A) 00:12:79:9e:56:89 <p1> e1000  [down]
eth128 (A9899A) 00:30:6e:5d:5a:30 <p0> e1000  [down]
eth129 (A9899A) 00:30:6e:5d:5a:31 <p1> e1000  [down]
eth130 (A9899A) 00:12:79:9e:5a:ca <p0> e1000  [down]
eth131 (A9899A) 00:12:79:9e:5a:cb <p1> e1000  [down]
eth132 (A9899A) 00:12:79:9e:58:ea <p0> e1000  [down]
eth133 (A9899A) 00:12:79:9e:58:eb <p1> e1000  [1000Mb/s]
eth134 (AD337A) 00:1a:4b:f3:02:10 <p0> e1000e [1000Mb/s]
eth135 (AD337A) 00:1a:4b:f3:02:11 <p1> e1000e [1000Mb/s]
eth136 (AD338A) 00:1a:4b:f3:01:9e <p0> e1000e [1000Mb/s]
eth137 (AD338A) 00:1a:4b:f3:01:9f <p1> e1000e [1000Mb/s]
eth138 (AD337A) 00:1a:4b:f3:02:18 <p0> e1000e [down]
eth139 (AD337A) 00:1a:4b:f3:02:19 <p1> e1000e [down]
eth140 (AD337A) 00:1a:4b:f3:02:24 <p0> e1000e [1000Mb/s]
eth141 (AD337A) 00:1a:4b:f3:02:25 <p1> e1000e [1000Mb/s]
eth142 (AD338A) 00:1a:4b:f3:00:92 <p0> e1000e [down]
eth143 (AD338A) 00:1a:4b:f3:00:93 <p1> e1000e [down]
eth144 (AD337A) 00:1a:4b:f3:01:e0 <p0> e1000e [down]
eth145 (AD337A) 00:1a:4b:f3:01:e1 <p1> e1000e [down]
eth146 (AD398A) 00:0c:fc:00:26:50 <p0> S2IO   [10000Mb/s]
eth147 (AD144A) 00:0c:fc:00:0a:1d <p0> S2IO   [10000Mb/s]
Comment 24 Jiayin Shao 2009-07-19 23:30:44 EDT
Created attachment 354299 [details]
/var/log/anaconda.log
Comment 25 Alexander Todorov 2009-07-20 03:15:28 EDT
(In reply to comment #23)
> Is that not enough, is it? Must try each port of all? Now I'm not sure if that
> meet the bug's requirement.
> 
> If need I will ask my colleague in America server room to connect all the port
> and retry it. 
> 

Hi Jiayin,
thank you for your testing. So far it seems good and anaconda.log which you've provided doesn't show the nic_by_name error message.

However steps to reproduce read:
3.  Try to bring up each of the Ethernet ports with the "Configure TCP/IP"
screen.  Use 'Back' to go back to select the next Ethernet port.

Reading comment #0 I take this to mean that all Ethernet ports have been activated through the "Configure TCP/IP" screen but some of them failed. The bug is about Anaconda (the installer) not being able to activate all ethX ports on the system when there are many of them. 

You have 12 ports which are active and RHEL5.2 supports up to 25. To fully test this issue I'd ask you to connect all ports on the system to the network and try to bring up all of them using Anaconda's "Configure TCP/IP" screen and then post the resulting anaconda.log.
Comment 26 Bryan Stillwell 2009-07-20 17:23:38 EDT
Alexander,

I discussed this with the original reporter (Bill Hayes), and we both believe that this bug can be closed without having to verify that every port works.  The reason Bill went port-by-port before was to figure out where anaconda stopped letting the install proceed.  He knew eth103 didn't work, so he worked backwards until he found the last port that did work (eth85).  Since Jiayin reported that she was able to complete an install using eth133, and I've personally booted the install to stage2 with eth147, there's no reason to believe any of the other ports will cause a problem.

Bryan
Comment 28 Ruediger Landmann 2009-08-18 01:02:05 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
previously, the method used by libdhcp to build a list of network interfaces available on a system could accommodate a maximum of 86 interfaces. As a consequence, attempts to perform network-based installations through interfaces eth86 and higher would fail. libdhcp now uses libnl to build a list of valid interfaces and therefore is no longer limited to the first 86 that it finds. Network-based installations are therefore possible on a wider range of hardware and network configurations.
Comment 29 errata-xmlrpc 2009-09-02 06:55:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1333.html

Note You need to log in before you can comment on or make changes to this bug.