Bug 442020 - NameError: global name 'anaconda' is not defined
Summary: NameError: global name 'anaconda' is not defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.2
Hardware: i386
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact: Alexander Todorov
URL:
Whiteboard:
: 442093 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-11 10:38 UTC by Nicole Dai
Modified: 2008-05-21 15:33 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 15:33:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0397 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2008-05-19 23:11:23 UTC

Description Nicole Dai 2008-04-11 10:38:46 UTC
Description of problem:
Bug occurred after partition setting in GUI installation, pls refer to traceback
CRITICAL: Traceback (most recent call first):
 File "/usr/lib/anaconda/iw/network_gui.py", line 120, in setHostOptionsSensiti 
    if network.anyUsingDHCP(self.devices, anaconda):
 File "/usr/lib/anaconda/iw/network_gui.py", line 486, in getScreen
    self.setHostOptionsSensitivity()
 File "/usr/lib/anaconda/gui.py", line 1106, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
 File "/usr/lib/anaconda/gui.py", line 1019, in nextClicked
    self.setScreen ()
NameError: global name 'anaconda' is not defined

Version-Release number of selected component (if applicable):
RHEL5.2 server 20080409 tree

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lumens 2008-04-11 11:26:09 UTC
Does adding updates=http://people.redhat.com/clumens/442020.img to your boot
arguments fix this problems?

Comment 2 Nicole Dai 2008-04-14 02:20:22 UTC
Hi Chris, I couldn't get the img you attached. Appreciate if you will take a
look at it. Thanks.

Comment 3 Chris Lumens 2008-04-14 08:48:31 UTC
Sorry, try it now.  I uploaded the file under the wrong name.

Comment 4 Nicole Dai 2008-04-14 09:57:49 UTC
Tried using updates=http://people.redhat.com/clumens/442020.img to boot
arguments but crash still occurred at the same position with the following
traceback:
CRITICAL: Traceback (most recent call first):
 File "/usr/lib/anaconda/network.py", line 81, in anyUsingDHCP 
    if anaconda.rescue:
 File "/tmp/updates/network_gui.py", line 534, in getScreen
    self.hostnameUseDHCP.set_sensitive(network.anyUsingDHCP(self.devices,networ
 File "/usr/lib/anaconda/gui.py", line 1106, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
 File "/usr/lib/anaconda/gui.py", line 1019, in nextClicked
    self.setScreen ()
AttributError:'module' object has no attribut 'rescue'

Comment 5 Chris Lumens 2008-04-14 12:27:53 UTC
Please give it another try.  I've fixed up that traceback as well.

Comment 6 Brock Organ 2008-04-14 18:23:19 UTC
I'm seeing this traceback on all VNC(GUI) installations for s390x using 0409.0
tree as well ...  will test with updates= images from comment #4 ...


Comment 7 Brock Organ 2008-04-14 18:46:12 UTC
updates= image from comment #4 works; no traceback occurs and the install
completes successfully on s390x using 0409.0 tree ...


Comment 8 Chris Lumens 2008-04-14 18:55:32 UTC
This is caused by the fix for 435978 so we'd better fix it.

Comment 9 Denise Dumas 2008-04-14 19:00:00 UTC
Is this a dup of 442093? If so, Peter just commited a change for it ...

Comment 11 Brock Organ 2008-04-14 19:15:31 UTC
*** Bug 442093 has been marked as a duplicate of this bug. ***

Comment 12 Chris Lumens 2008-04-15 09:27:42 UTC
This will be fixed in anaconda-11.1.2.113.

Comment 17 errata-xmlrpc 2008-05-21 15:33:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html



Note You need to log in before you can comment on or make changes to this bug.