Bug 442122 - nouveau goes bang
nouveau goes bang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 442082 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 16:38 EDT by Bill Nottingham
Modified: 2014-03-16 23:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 10:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (144.11 KB, text/plain)
2008-04-11 16:38 EDT, Bill Nottingham
no flags Details
kernel messages (35.22 KB, text/plain)
2008-04-11 16:39 EDT, Bill Nottingham
no flags Details
X log (144.11 KB, text/plain)
2008-04-16 10:28 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2008-04-11 16:38:42 EDT
Description of problem:

[drm] Allocating FIFO number 0
[drm] nouveau_fifo_alloc: initialised FIFO 0
[drm] Allocating FIFO number 1
[drm] nouveau_fifo_alloc: initialised FIFO 1
[drm] PFIFO_DMA_PUSHER - Ch 1
[drm] nouveau_fifo_free: freeing fifo 1
[drm:nouveau_fifo_free] *ERROR* Failed to idle channel 1 before destroy.Prepare
for stra
ngeness..
[drm] nouveau_fifo_free: freeing fifo 0
BUG: unable to handle kernel paging request at ffffc20001082500
IP: [<ffffffff88351fb8>] :nouveau:nouveau_fifo_free+0x3b/0x21c
PGD 11fc0c067 PUD 11fc0d067 PMD 11eac3067 PTE 0
Oops: 0002 [1] SMP 
CPU 0 

Version-Release number of selected component (if applicable):

xorg-x11-drv-nouveau-0.0.10-2.20080408git0991281.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-21.20080407.fc9.x86_64
mesa-libGL-7.1-0.23.fc9.x86_64
kernel-2.6.25-0.218.rc8.git7.fc9.x86_64
Comment 1 Bill Nottingham 2008-04-11 16:38:42 EDT
Created attachment 302168 [details]
X log
Comment 2 Bill Nottingham 2008-04-11 16:39:25 EDT
Created attachment 302169 [details]
kernel messages
Comment 3 Bill Nottingham 2008-04-16 10:27:48 EDT
Doesn't crash any more with 2.6.25-0.234.rc9.git1.fc9.x86_64, but still does not
work.

Kernel messages:
[drm] Allocating FIFO number 0
[drm] nouveau_fifo_alloc: initialised FIFO 0
[drm] Allocating FIFO number 1
[drm] nouveau_fifo_alloc: initialised FIFO 1
[drm] PFIFO_DMA_PUSHER - Ch 1
[drm] nouveau_fifo_free: freeing fifo 1
[drm:nouveau_fifo_free] *ERROR* Failed to idle channel 1 before destroy.Prepare
for strangeness..

xorg-x11-drv-nouveau-0.0.10-2.20080408git0991281.fc9.x86_64
mesa-libGL-7.1-0.23.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-21.20080407.fc9.x86_64

Comment 4 Bill Nottingham 2008-04-16 10:28:59 EDT
Created attachment 302611 [details]
X log

New X log
Comment 5 Bill Nottingham 2008-04-16 10:29:50 EDT
To be fair, this box hasn't worked with nouveau for a while. See:

https://bugs.freedesktop.org/show_bug.cgi?id=11240
Comment 6 Scott Turnberg 2008-04-17 12:57:34 EDT
*** Bug 442082 has been marked as a duplicate of this bug. ***
Comment 7 Bug Zapper 2008-05-14 05:20:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Ben Skeggs 2009-04-09 02:25:41 EDT
Can I assume this works OK now in current releases?  The upstream bug is closed (and looks like the same one as another rh bug I just marked as closed!) :)
Comment 10 Bill Nottingham 2009-04-09 10:21:00 EDT
Yeah, it works pretty well now.

Note You need to log in before you can comment on or make changes to this bug.