Bug 442224 - system-config-display does not create a backup for /etc/X11/xorg.conf
Summary: system-config-display does not create a backup for /etc/X11/xorg.conf
Status: CLOSED DUPLICATE of bug 355461
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display   
(Show other bugs)
Version: 8
Hardware: noarch
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-12 23:35 UTC by Varol Kaptan
Modified: 2018-04-11 14:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 15:07:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Varol Kaptan 2008-04-12 23:35:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
when you change the configuration system-config-display tells you that it saved a copy in /etc/X11/xorg.conf.backup but it actually does not.

The problem seems to be in /usr/share/system-config-display/xconf.py, line 408. os.copy does not exist and throws an exception. Works when replaced with os.rename.


Version-Release number of selected component (if applicable):
system-config-display-1.0.51-4.fc8.noarch

How reproducible:
Always


Steps to Reproduce:
1.run system-config-display and change configuration
2.hit "OK and see notification that backup is saved in /etc/X11/xorg.conf.backup


Actual Results:
old copy of /etc/X11/xorg.conf was not saved as /etc/X11/xorg.conf.backup

Expected Results:
old copy of /etc/X11/xorg.conf should have been saved as /etc/X11/xorg.conf.backup

Additional info:

Comment 1 Matěj Cepl 2008-04-17 15:07:22 UTC

*** This bug has been marked as a duplicate of 355461 ***


Note You need to log in before you can comment on or make changes to this bug.