Bug 442224 - system-config-display does not create a backup for /etc/X11/xorg.conf
system-config-display does not create a backup for /etc/X11/xorg.conf
Status: CLOSED DUPLICATE of bug 355461
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
noarch Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-12 19:35 EDT by Varol Kaptan
Modified: 2008-04-17 11:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-17 11:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Varol Kaptan 2008-04-12 19:35:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20080325 Fedora/ Firefox/

Description of problem:
when you change the configuration system-config-display tells you that it saved a copy in /etc/X11/xorg.conf.backup but it actually does not.

The problem seems to be in /usr/share/system-config-display/xconf.py, line 408. os.copy does not exist and throws an exception. Works when replaced with os.rename.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run system-config-display and change configuration
2.hit "OK and see notification that backup is saved in /etc/X11/xorg.conf.backup

Actual Results:
old copy of /etc/X11/xorg.conf was not saved as /etc/X11/xorg.conf.backup

Expected Results:
old copy of /etc/X11/xorg.conf should have been saved as /etc/X11/xorg.conf.backup

Additional info:
Comment 1 Matěj Cepl 2008-04-17 11:07:22 EDT

*** This bug has been marked as a duplicate of 355461 ***

Note You need to log in before you can comment on or make changes to this bug.