Bug 442250 - Left-Hand Mouse
Left-Hand Mouse
Status: CLOSED DUPLICATE of bug 324721
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 447693 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-13 08:00 EDT by Frank Murphy
Modified: 2008-08-10 21:48 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-10 21:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.conf (383 bytes, text/plain)
2008-04-19 04:34 EDT, Frank Murphy
no flags Details
Xorg.log (39.37 KB, text/plain)
2008-04-19 04:36 EDT, Frank Murphy
no flags Details
Xorg.log NEW (41.77 KB, text/plain)
2008-04-19 04:47 EDT, Frank Murphy
no flags Details
dmesg (7th May 2008) (34.91 KB, text/plain)
2008-05-07 11:27 EDT, Frank Murphy
no flags Details
lsusb - result (745 bytes, text/plain)
2008-05-09 04:12 EDT, Frank Murphy
no flags Details
/var/log/messages - excerpt (692 bytes, text/plain)
2008-05-10 04:12 EDT, Frank Murphy
no flags Details
/var/log/Xorg.0.log - excerpt (320 bytes, text/plain)
2008-05-10 04:13 EDT, Frank Murphy
no flags Details
F8 - excerpts for comparison (754 bytes, text/plain)
2008-05-10 04:32 EDT, Frank Murphy
no flags Details
syslog-snip (2.54 KB, text/plain)
2008-07-08 02:45 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2008-04-13 08:00:24 EDT
Description of problem:

Having set Left-Hand mouse buttons

Using a kvm switch, if I switch PC's and come back to F9-Beta+ Updates.
The mouse buttons are right-handed again.
Even thought the "mouse preferences" gui says left-handed.

If I just re-boot without changing the with kvm, it holds the mouse settings.

KVM does not affect the F8 boxes, CentOS5 left-handed setup
Comment 1 Kevin Fenzi 2008-04-14 11:31:32 EDT
This would seem to be a bug in the xorg mouse driver, and/or the mouse prefs
applet, not the mousepad editor. ;) 

I am switching it over to that component to get looked at. 
Thanks for the bug report!
Comment 2 Matěj Cepl 2008-04-15 11:53:43 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Frank Murphy 2008-04-19 04:34:21 EDT
Created attachment 302977 [details]
Xorg.conf
Comment 4 Frank Murphy 2008-04-19 04:36:04 EDT
Created attachment 302978 [details]
Xorg.log

Xorg.log before deleting xorg.conf
Comment 5 Frank Murphy 2008-04-19 04:47:05 EDT
Created attachment 302983 [details]
Xorg.log NEW

No xorg.conf recreated!, but am typing into this, so have some sort of display.

Have attached new xorg.0.log
Comment 6 Mike Chambers 2008-05-07 11:08:34 EDT
You might also supply what brand/model your mouse is, how it's connected
(usb?),and maybe what brand/model kvm switch your using?  I don't know how to
fix it myself, but that might help diagnose the problem.
Comment 7 Frank Murphy 2008-05-07 11:27:01 EDT
Created attachment 304772 [details]
dmesg (7th May 2008)
Comment 8 Frank Murphy 2008-05-07 11:29:04 EDT
Mouse: Dell Optical Scroll (no model number)
KVM: Aten Dual-VGA Masteview USB  CS-1744
Comment 9 Frank Murphy 2008-05-09 04:12:33 EDT
Created attachment 304928 [details]
lsusb - result
Comment 10 Frank Murphy 2008-05-10 04:12:00 EDT
Created attachment 305007 [details]
/var/log/messages - excerpt

After switching back anf forth using KVM, noticed the following patterns
in messages and Xorg.log
Comment 11 Frank Murphy 2008-05-10 04:13:17 EDT
Created attachment 305008 [details]
/var/log/Xorg.0.log - excerpt
Comment 12 Frank Murphy 2008-05-10 04:17:46 EDT
May 10 09:08:21 frank-02 kernel: input: USB Optical Mouse as
/devices/pci0000:00/0000:00:1d.1/usb6/6-2/6-2.4/6-2.4:1.0/input/input8 

Have noticed /input/input* goes up by a digit 6,7,8,9,10
Comment 13 Frank Murphy 2008-05-10 04:32:58 EDT
Created attachment 305009 [details]
F8 - excerpts for comparison

When KVM used on F8 box, only /var/log/messages change, no change to
/Xorg.0.log

input line still goes up by digit:
May 10 09:30:18 frank-01 kernel: input: USB Optical Mouse as
/class/input/input18
Comment 14 Frank Murphy 2008-05-11 05:57:49 EDT
Using lshw found this:

Generic USB device
/0/100/1d.1/1/2/4
product: USB Optical Mouse
vendor: Primax Electronics, Ltd
bus info: usb@6:2.4
version: 2.00
capabilities:
	USB 2.0
configuration:
	maxpower: 100mA
	speed: 1.5MB/s
this device hasn't been claimed
Comment 15 Bug Zapper 2008-05-14 05:22:33 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Susi Lehtola 2008-05-15 09:38:25 EDT
I also have this problem. It seems to be caused by USB disconnect - one can
reproduce the problem by just unplugging and reconnecting the mouse cable. Older
versions of Fedora are unaffected.
Comment 17 Andrea 2008-05-21 02:51:42 EDT
(In reply to comment #16)
> I also have this problem. It seems to be caused by USB disconnect - one can
> reproduce the problem by just unplugging and reconnecting the mouse cable. Older
> versions of Fedora are unaffected.

I can confirm this.
Mouse attached via USB, running Fedora 9, KDE 4.

After disconnect/reconnect OR suspend/resume the mouse goes back to right-handed.
One needs to switch to right handed, and back to left handed.

I am sure in Fedora 7 the disconnect/reconnect did not affect the
left-handedness. Never tried to suspend in F7.

Andrea
Comment 18 Matěj Cepl 2008-05-21 07:25:05 EDT
*** Bug 447693 has been marked as a duplicate of this bug. ***
Comment 19 Kenneth MacKenzie 2008-05-28 17:26:21 EDT
Another confirmation.  I'm using a USB mouse attached to a laptop.  After
suspend/resume it changes from left-handed to right-handed.  This behaviour
started immediately after an upgrade from Fedora 8 to Fedora 9 (Gnome)
Comment 20 Frank Murphy 2008-06-17 08:59:02 EDT
am doing afull F8 re-install to test this,
updates to f9 one by one a-z
Comment 21 Frank Murphy 2008-06-28 07:06:35 EDT
Tried as per comment #20, system got trashed whn came to yum update x\* X\*
BUT yum update \*usb\* or \*mouse\* had no effect on leftness.

Then this came up in fedoa-list:
https://www.redhat.com/archives/fedora-list/2008-June/msg02521.html

Goin by that maybe it's a power\resume thing. But the script didn't work here.
Where would the usb connect\disconnect\re-connect stuff be found?
Maybe a script there?

Comment 22 Carl Roth 2008-07-04 17:07:53 EDT
I tried "fixing" this with a pm-suspend script in /etc/pm-utils/sleep.d that
would save and restore the pointer settings with xmodmap -pp, but that didn't
work.  pm-utils did run xmodmap with the correct arguments but it had no effect
on the X desktop upon resume.

The mailing list post above also anecdotally suggests running xmodmap twice;
that appears to be unnecessary for my system.

Given how long USB mice have been around, and given how long left-handed
computer users have been around, I think this bug should have a higher priority.
 Submitter?

Comment 23 Frank Murphy 2008-07-04 18:38:07 EDT
How's that.
Comment 24 Frank Murphy 2008-07-08 02:45:49 EDT
Created attachment 311234 [details]
syslog-snip

Could it be the kernel,
Thats losing the usb
Comment 25 Frank Murphy 2008-07-14 08:20:43 EDT
did a yum install gnome-volume-manager.

Theres a bit on that that goes:
program to run when usb mouse is found\connected.

I tried it with the little xmodemap thigk from:
https://www.redhat.com/archives/fedora-list/2008-June/msg02521.html
Didn't work, could someone come up with something?
the only code I know being the "safe cross one"
Comment 26 Peter Hutterer 2008-07-15 03:21:01 EDT
This a problem with gnome-mouse-properties, changing component.

The X server's behaviour is that a core SetPointerMapping request applies not
only to the core device but also to all extension devices. So when you set the
mouse to left-handed in gnome-mouse-properties, all connected devices are set to
left-handed.
A newly plugged in mouse however comes with the defaults - right handed, hence
why the mapping changes after the KVM switch or the unplugging of the device.

gnome-mouse-properties should listen to DevicePresenceNotifyEvents and re-apply
the left-handed setting for new devices using the DeviceSetButtonMapping request.
Comment 27 dann 2008-07-15 09:20:00 EDT
(In reply to comment #26)
> A newly plugged in mouse however comes with the defaults - right handed, hence
> why the mapping changes after the KVM switch or the unplugging of the device.
> 
> gnome-mouse-properties should listen to DevicePresenceNotifyEvents and re-apply
> the left-handed setting for new devices using the DeviceSetButtonMapping request.

Wouldn't a fix along these line just work on Gnome?
Not everyone uses Gnome.  And in my case the properties were set with xmodmap,
not with gnome-mouse-properties.
Again, this used to work on F8 when it came out, it broke after one of the updates.
Comment 28 Carl Roth 2008-07-15 11:35:56 EDT
Yeah, I'm using KDE, and I'd like to see the issue fixed there too.
Comment 29 Bastien Nocera 2008-07-15 11:55:54 EDT
(In reply to comment #28)
> Yeah, I'm using KDE, and I'd like to see the issue fixed there too.

File a new bug against the KDE control center as well then. It's very possible
XFCE or any other mouse config tool has the problem.
Comment 30 dann 2008-07-15 12:33:08 EDT
(In reply to comment #29)
> (In reply to comment #28)
> > Yeah, I'm using KDE, and I'd like to see the issue fixed there too.
> 
> File a new bug against the KDE control center as well then. It's very possible
> XFCE or any other mouse config tool has the problem.

IMHO going that way is misguided.

This used to work when not using any control center, just xmodmap -e "pointer =
3 2 1", and it worked on all version of RH and on all versions of FC, on F7 and
F8 at the time it came out.. 
Comment 31 Peter Hutterer 2008-07-15 19:48:44 EDT
(In reply to comment #27)
> Wouldn't a fix along these line just work on Gnome?
> Not everyone uses Gnome.  And in my case the properties were set with xmodmap,
> not with gnome-mouse-properties.

yeah, I assumed the original reporter used the g-m-p.
There is the xinput tool that enables you to set the button map on each device
separately.
xinput set-button-map "device name" 3 2 1
Not in fedora yet, get it from
ftp://ftp.x.org/pub/individual/app/xinput-1.3.0.tar.bz2

> Again, this used to work on F8 when it came out, it broke after one of the
updates.

It's an upstream issue, change of behaviour introduced last August. Before the
following commit, all devices would use the core pointer's button mapping. 
http://cgit.freedesktop.org/xorg/xserver/commit/?id=6b055e5d9751e3679ff98065e43225ec8a960053

Since this commit, each device uses its own button mapping.


(In reply to comment #30)
> (In reply to comment #29)
> > File a new bug against the KDE control center as well then. It's very possible
> > XFCE or any other mouse config tool has the problem.
> 
> IMHO going that way is misguided.
> 
> This used to work when not using any control center, just xmodmap -e "pointer =
> 3 2 1", and it worked on all version of RH and on all versions of FC, on F7 and
> F8 at the time it came out.. 
 
I disagree with the notion of it being misguided. Upstream X.Org goes more and
more towards per-device configuration and will eventually ditch the core pointer
concept for all but corner cases. With the upcoming X Input Extension 2, many
tools such as xmodmap will lose much of their meaning.
The sooner we can get the config tools to update, the less painful the future
will be.
Comment 32 Ray Strode [halfline] 2008-07-15 21:29:44 EDT
Yea, Peter is right.  gnome-settings-daemon currently loops through every device
and applies the button remapping on startup.  It doesn't listen for new devices,
however.  We need to fix that.
Comment 33 Frank Murphy 2008-08-09 12:48:40 EDT
Still borked F10-Alpha
Comment 34 Peter Hutterer 2008-08-10 21:48:50 EDT

*** This bug has been marked as a duplicate of bug 324721 ***

Note You need to log in before you can comment on or make changes to this bug.