Bug 442274 - install-info is noisy.
install-info is noisy.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
: 391141 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-13 14:48 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 08:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-04-13 14:48:28 EDT
I have a small machine with a limited amount of flash space, so choose not to
install documentation on it.   I achieve this by doing the following post-install..

echo "%_excludedocs 1" >> /etc/rpm/macros
and then removing everything underneath /usr/share/info

On yum updates, the right thing happens (the new docs don't get installed) but
every time a package tries to install an info package, it spits out something to
the effect of..

 install-info: No such file or directory for /usr/share/info/libc.info.gz

Can this (fairly pointless) message be silenced ?
Comment 1 Patrice Dumas 2008-04-13 17:15:06 EDT
I don't really understand what you mean. install-info is certainly doing the
right thing by complaining that the file doesn't exist. The scriptlet can be
silenced, though, but it should be done at the package level and
Packaging/ScriptletSnippets should be changed.
Comment 2 Vitezslav Crhonek 2008-04-23 08:53:53 EDT
As Patrice said before: if package contains info files, it calls install-info in
%post, i. e.

/sbin/install-info %{_infodir}/libc.info.gz %{_infodir}/dir || :

If libc.info.gz doesn't exist, it's obvious that install-info will complain. Of
course, we can add --silent option to install-info at the package level, but
it's IMHO not good idea...

Resume: I don't think this is texinfo bug (I don't think this is bug at all), so
closig it. Please discuss changes to

http://fedoraproject.org/wiki/Packaging/ScriptletSnippets

at fedora-devel mailing list, if you wish.
Comment 3 Patrice Dumas 2008-04-23 09:01:55 EDT
I have found some discussion about it on some list (don't remember which one,
though) and the reporter said that 'he could live with these error messages'.
Comment 4 Vitezslav Crhonek 2008-04-24 03:47:52 EDT
*** Bug 391141 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.