Bug 442373 - mono-addins not being pulled in.....
mono-addins not being pulled in.....
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
: 442709 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
Reported: 2008-04-14 12:07 EDT by Tom London
Modified: 2009-01-13 00:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-17 03:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-04-14 12:07:45 EDT
Description of problem:
tomboy-0.10.1-2.fc9.i386 seems to need mono-addins (or mono-addins-devel ?), but
yum does not pull it in.

starting tomboy:
Unhandled Exception: System.IO.FileNotFoundException: Could not load file or
assembly 'Mono.Addins, Version=, Culture=neutral,
PublicKeyToken=0738eb9f132ed756' or one of its dependencies.
File name: 'Mono.Addins, Version=, Culture=neutral,
  at Tomboy.AddinManager..ctor (System.String tomboy_conf_dir) [0x00000] 
  at Tomboy.NoteManager.CreateAddinManager () [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory, System.String
backup_directory) [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory) [0x00000] 
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000] 

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Warren Togami 2008-04-14 22:49:42 EDT
tomboy is busted without this dep, while it works with the dep installed. 
Perhaps this is a consequence of spot's de-blobification?
Comment 2 Ray Strode [halfline] 2008-04-15 09:53:39 EDT
Not sure what's going on here...

$ rpm -q --provides mono-addins
mono(Mono.Addins) =

$ rpm -q --requires tomboy
mono(Mono.Addins) =

Comment 3 Ray Strode [halfline] 2008-04-15 09:55:26 EDT

$ sudo yum whatprovides 'mono(Mono.Addins)'
dist-f9                                                  | 2.4 kB     00:00    
mono-addins.x86_64 : Addins for mono
f-spot.x86_64 : Photo management application

Reassigning to f-spot, it's got bogus provides apparently.
Comment 4 Ray Strode [halfline] 2008-04-15 10:43:50 EDT
looks like this will get fixed by the bug fix going into bug 442343.
Comment 5 Ray Strode [halfline] 2008-04-16 10:11:52 EDT
*** Bug 442709 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2008-04-17 03:10:37 EDT
New f-spot has been built and tagged and the update I did earlier brought in
mono-addins, so this looks fixed to me.
Comment 7 Justin Dick 2009-01-13 00:57:13 EST
This issue has returned in Fedora 10 x86_64

Please reopen.

Note You need to log in before you can comment on or make changes to this bug.