This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442419 - make dist complains of missing Mercurial repository
make dist complains of missing Mercurial repository
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: build (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
: 442412 (view as bug list)
Depends On:
Blocks: 429034
  Show dependency treegraph
 
Reported: 2008-04-14 14:21 EDT by Michael Gregg
Modified: 2015-01-04 18:31 EST (History)
1 user (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix 'make dist' (1.05 KB, patch)
2008-04-21 18:25 EDT, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Michael Gregg 2008-04-14 14:21:33 EDT
Description of problem:
We switched to git, so this problem is understandable.

Version-Release number of selected component (if applicable):
code checked out on 4-14-08

How reproducible:
always

Steps to Reproduce:
1. run "make dist" on source
  
Actual results:
mkdir -p dist
hg archive -t files dist/ipa
abort: There is no Mercurial repository here (.hg not found)!
make: *** [archive] Error 255

Additional:
Replaces bug 442412
Comment 1 Michael Gregg 2008-04-14 14:22:48 EDT
*** Bug 442412 has been marked as a duplicate of this bug. ***
Comment 2 Rob Crittenden 2008-04-21 10:42:59 EDT
Use the local-dist target for a workaround.

The 'dist' target just makes sure you aren't building against any local changes.
Comment 3 Rob Crittenden 2008-04-21 18:25:50 EDT
Created attachment 303223 [details]
fix 'make dist'

Added optional argument TARGET so you can specify the branch to pull from. It
defaults to master.
Comment 4 Rob Crittenden 2008-05-09 11:11:14 EDT
ipa-1-0: 6b3bb4337fa06f25afeca9c1560546e6c651de2b
master: 9fe649b804fda3e5d49674f8597b8321df03cdbb
Comment 5 Michael Gregg 2008-11-19 19:28:58 EST
builds have been working with make dist since May some time. 

Closing as verified.

Note You need to log in before you can comment on or make changes to this bug.