Bug 442539 - Evolution ignore russian spellcheck
Evolution ignore russian spellcheck
Status: CLOSED DUPLICATE of bug 426347
Product: Fedora
Classification: Fedora
Component: gnome-spell (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 09:43 EDT by Arkady L. Shane
Modified: 2008-05-19 09:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 09:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arkady L. Shane 2008-04-15 09:43:15 EDT
Description of problem:
I have installed hunspell-ru (and aspell-ru), but there is not any russian
dictionary in Spell Cheking tab in Composer preferenses. This problem is present
for many languages, for bg, lt, he, and I think etc.

Gajim, for example, has the same problem. Both of them use gtkspell for spell
checking.
Comment 1 Matthew Barnes 2008-04-15 10:31:02 EDT
Evolution uses GnomeSpell which, if I recall correctly, uses a fixed list of
language codes that it tries to match against installed dictionaries.  I notice,
however, the language codes are tailored for aspell and we've since standardized
on hunspell.  It may be that hunspell is reporting slightly different language
codes that GnomeSpell doesn't recognize.
Comment 2 Matthew Barnes 2008-04-15 10:33:39 EDT
Note: In Post-F9 Rawhide, Evolution no longer uses GnomeSpell at all.  Instead,
it talks to Enchant directly.  So I imagine this bug only applies to Fedora 9.
Comment 3 Piotr Krawiec 2008-04-22 18:03:41 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=426347
https://bugzilla.redhat.com/show_bug.cgi?id=245888

According to above bugs status, both gnome-spell and gtkspell are supposed to
use enchant->hunspell, but I still can't see polish (hunspell-pl) on evolution's
spell checking list.
Comment 4 Matěj Cepl 2008-04-23 07:22:52 EDT
me too -- Czech language is not available as well.
Comment 5 Arkady L. Shane 2008-05-18 15:16:10 EDT
I saw, that gnome-spell-1.0.8-5.fc9 from updates-testing fixes this problem!
Comment 6 Piotr Krawiec 2008-05-19 08:43:38 EDT
Yes, it does, have a look at bug #426347.
Comment 7 Matthew Barnes 2008-05-19 09:56:43 EDT

*** This bug has been marked as a duplicate of 426347 ***

Note You need to log in before you can comment on or make changes to this bug.