Bug 426347 - Unify Dictionaries: point gnome-spell to enchant instead of aspell
Unify Dictionaries: point gnome-spell to enchant instead of aspell
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-spell (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
: 442539 447464 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 05:43 EST by Caolan McNamara
Modified: 2008-05-21 07:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.0.8-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 07:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to use enchant (18.53 KB, patch)
2007-12-20 05:43 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Caolan McNamara 2007-12-20 05:43:45 EST
Description of problem:
Trying to unify our set of dictionaries, so that all desktop components agree on
spell suggestions. http://fedoraproject.org/wiki/Releases/FeatureDictionary

So OOo uses hunspell, firefox3 also uses hunspell now so we can share those
dictionaries. gedit and libsexy (as used by xchat) uses enchant, which defaults
to using hunspell dictionaries if it can find them so they can share too. 

gnome-spell (as used by evolution) uses aspell, but attached is the same patch
as used by JDS etc to point gnome-spell at enchant which will then use hunspell
dictionaries if available or aspell if not.
Comment 1 Caolan McNamara 2007-12-20 05:43:45 EST
Created attachment 290143 [details]
patch to use enchant
Comment 2 Matthew Barnes 2007-12-20 08:07:58 EST
Looks good to me.

Fixed in gnome-spell-1.0.8-2.fc9.

(btw, I'm hoping to move GtkHTML over to enchant in the near future.)
Comment 3 Piotr Krawiec 2008-04-22 18:22:55 EDT
I consider this bug only partially solved. Remaining problem is that not all
dictionaries are recognized due to hardcoded list of languages available. E.g.
this leads to https://bugzilla.redhat.com/show_bug.cgi?id=442539

There is a patch on http://bugzilla.abisource.com/show_bug.cgi?id=11001 to have
languages list got from enchant. Maybe it can be incorporated as a more proper
solution?
Comment 4 Matthew Barnes 2008-04-22 19:12:02 EDT
GnomeSpell will likely be dropped from Fedora 10.  The latest development
releases of GtkHtml and Evolution no longer use it.
Comment 5 Piotr Krawiec 2008-04-23 04:31:29 EDT
So that's about Fedora 10 and latest GtkHTML and Evolution. What about Fedora 9?
Can someone possibly review the patch referenced above? 'FeatureDictionary' is
marked complete in 100% - and that's not actually true according to GnomeSpell
not using hunspell for all languages supported. So IMHO this bug should be
reopened (or better fixed properly).
Comment 6 Piotr Krawiec 2008-04-30 12:50:53 EDT
Any response? It's really annoying to have everything underlined in red, and I
guess "The latest development
releases of GtkHtml and Evolution no longer use it." is no explanation for
Fedora 9 potential users.
Comment 7 Matthew Barnes 2008-04-30 13:25:25 EDT
The GnomeSpell patch looks very similar to what I did in GtkHtml.  Uses
iso-codes to match Enchant's language codes against standard translated language
names.

It's too late to get this in prior to Fedora 9, but I can push an update to the
Testing repo if you're willing it test it.

Reopening in the meantime.
Comment 8 Piotr Krawiec 2008-04-30 13:35:51 EDT
I'd be glad to.
Comment 9 Matthew Barnes 2008-04-30 14:19:37 EDT
Patch applied to gnome-spell-1.0.8-5.fc9.

Piotr, can you please test this package?  You can grab it from here:
http://koji.fedoraproject.org/packages/gnome-spell/1.0.8/5.fc9/
Comment 10 Piotr Krawiec 2008-04-30 14:46:17 EDT
Works great for me, thanks!
Comment 11 Fedora Update System 2008-05-07 12:13:27 EDT
gnome-spell-1.0.8-5.fc9 has been submitted as an update for Fedora 9
Comment 12 Fedora Update System 2008-05-13 11:20:35 EDT
gnome-spell-1.0.8-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-spell'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3773
Comment 13 Matthew Barnes 2008-05-19 09:56:45 EDT
*** Bug 442539 has been marked as a duplicate of this bug. ***
Comment 14 Matthew Barnes 2008-05-19 20:12:49 EDT
*** Bug 447464 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2008-05-21 07:11:15 EDT
gnome-spell-1.0.8-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.