Bug 442548 - Needs rebuild for perl 5.10.0
Needs rebuild for perl 5.10.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: po4a (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-04-15 10:36 EDT by Arkady L. Shane
Modified: 2008-07-07 06:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: po4a-0.32-7*
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-01 01:30:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arkady L. Shane 2008-04-15 10:36:34 EDT
Description of problem:
Po4a build for perl 5.8.8
Comment 1 Bug Zapper 2008-05-14 05:28:59 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Ralf Corsepius 2008-05-22 01:15:21 EDT
The cause for this bug having made it into FC9 is the *.spec file 
lacking this line:

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Comment 3 Ralf Corsepius 2008-05-22 02:30:31 EDT
Axel, I tried to fix this issue in CVS. Local mockbuilds work out fine,
but building fails in koji:
http://koji.fedoraproject.org/koji/getfile?taskID=624049&name=build.log

Seems to me as if mock or rpm is f***ed up for FC10/rawhide :/
Comment 4 Axel Thimm 2008-05-22 04:47:55 EDT
(In reply to comment #3)
> Seems to me as if mock or rpm is f***ed up for FC10/rawhide :/

If rpm has indeed changed that way there will be tons of packages affected. So
it will probably be reverted or if not there will be some fedora-devel-announcement.
Comment 5 Fedora Update System 2008-05-22 13:13:07 EDT
po4a-0.32-7.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-05-28 22:46:22 EDT
po4a-0.32-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.