Bug 442593 - Fedora 9 beta problem - upgrade from Fedora 8 fails to install boot loader
Fedora 9 beta problem - upgrade from Fedora 8 fails to install boot loader
Status: CLOSED DUPLICATE of bug 438830
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 14:16 EDT by Jussi Eloranta
Modified: 2008-04-15 17:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 17:10:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Eloranta 2008-04-15 14:16:47 EDT
Description of problem:

I tried to upgrade from Fedora 8 to Fedora 9 beta. Installation of all rpms went
fine but anaconda crashed when installing the bootloader (grub). I clicked on
the debug option and the console screen shows:

TypeError: coercing to Unicode: need string or buffer, instance found

before this I see bunch of messages - apparently a traceback:

progress_gui.pu 80
gui.py 1267

Version-Release number of selected component (if applicable):

Fedora 9 beta.
How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2008-04-15 14:36:28 EDT
Can you attach the actual traceback you received?
Comment 2 Jussi Eloranta 2008-04-15 17:07:33 EDT
Well, since this was during the installation, I could not print etc.

I wrote down some more info. For gui.py the line was something like (I don't
have more info on the previous lines - sorry):

gui.py line 1267, in handleRenderCallback
self.currentWindow.renderCallback()

and after that appeared the TypeError:...

below that was:

/usr/lib/python2.5/posixpath.py(173)exists()
-> return false
and after this I got the "debugger prompt"

By the way, the boot loader worked after this - although it was installed there
before since this was an upgrade.
Comment 3 Jeremy Katz 2008-04-15 17:10:47 EDT

*** This bug has been marked as a duplicate of 438830 ***

Note You need to log in before you can comment on or make changes to this bug.