Bug 442834 - Gnome's File Manager - Super User mode isn't super user mode.
Gnome's File Manager - Super User mode isn't super user mode.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 01:25 EDT by Oral Deckard
Modified: 2008-05-21 06:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.0.4-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 06:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oral Deckard 2008-04-17 01:25:18 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Application/System Tools/File Manager - Super User mode
2.
3.
  
Actual results:
It does not ask for the root password, and root level operations are not
permitted.  The Super User mode just isn't.  We don't want F9 released looking
embarrassing.


Expected results:


Additional info:
Comment 1 Tomáš Bžatek 2008-04-17 09:29:35 EDT
Assigning to kdebase folks since we don't have menu icon for root mode Nautilus.
Comment 2 Rex Dieter 2008-04-17 11:10:30 EDT
kde (v4 on f9/rawhide) doesn't have any "File Manager - Super User mode" 
either, just "File Manager (dolphin)".

Oral, what desktop and fedora release are you using?
Comment 3 Ngo Than 2008-04-17 12:32:53 EDT
konqueror doesn't run in root modus because nautilus doesn't support 
X-KDE-SubstituteUID=true that is used in desktop file. There's a workaround 
for this issue if kdesu is used, IMO that tool shouldn't be showed in Gnome.

it's fixed in kdebase-4.0.3-8
Comment 4 Kevin Kofler 2008-05-11 05:06:46 EDT
Reopening, the fix doesn't work, see:
https://bugzilla.redhat.com/show_bug.cgi?id=445989#c2

Semicolons must be escaped in shell commands.
Comment 5 Kevin Kofler 2008-05-11 05:19:33 EDT
Fixed in 4.0.4-2.fc9 and 4.0.72-2.fc10.
Comment 6 Fedora Update System 2008-05-13 11:22:56 EDT
kdebase-4.0.4-2.fc9, kdeaccessibility-4.0.4-1.fc9, kde-l10n-4.0.4-1.fc9, kdetoys-4.0.4-1.fc9, kdebindings-4.0.4-1.fc9, kdenetwork-4.0.4-2.fc9, kdegraphics-4.0.4-1.fc9, kdeartwork-4.0.4-1.fc9, kdesdk-4.0.4-1.fc9, kdegames-4.0.4-1.fc9, kdebase-workspace-4.0.4-4.fc9, kdeutils-4.0.4-1.fc9, kdeedu-4.0.4-2.fc9, kdebase-runtime-4.0.4-1.fc9, kdemultimedia-4.0.4-1.fc9, kdelibs-4.0.4-1.fc9, kdeadmin-4.0.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdeaccessibility kde-l10n kdetoys kdebindings kdenetwork kdegraphics kdeartwork kdesdk kdegames kdebase-workspace kdeutils kdeedu kdebase-runtime kdemultimedia kdelibs kdeadmin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3664
Comment 7 Kevin Kofler 2008-05-13 11:42:15 EDT
For anyone wondering what the exact problem was and how we fixed it: the 
problem was that KDE's "File manager - super user mode" menu entry was visible 
in GNOME, but GNOME doesn't support the switch to super user mode. We changed 
the menu entry to only be visible in KDE.
Comment 8 Bug Zapper 2008-05-14 05:34:12 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2008-05-21 06:58:13 EDT
kdebase-workspace-4.0.4-4.fc9, kdebase-4.0.4-2.fc9, kde-l10n-4.0.4-1.fc9, kdesdk-4.0.4-2.fc9, kdemultimedia-4.0.4-2.fc9, kdelibs-4.0.4-4.fc9, kdeedu-4.0.4-2.fc9, kdebase-runtime-4.0.4-1.fc9, kdepimlibs-4.0.4-1.fc9, kdenetwork-4.0.4-2.fc9, kdegraphics-4.0.4-1.fc9, kdeaccessibility-4.0.4-1.fc9, kdeartwork-4.0.4-1.fc9, kdeutils-4.0.4-1.fc9, kdebindings-4.0.4-1.fc9, kdetoys-4.0.4-1.fc9, kdegames-4.0.4-2.fc9, kdeadmin-4.0.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.