Bug 442909 - RFE: enhancements to mock plugin API
RFE: enhancements to mock plugin API
Status: CLOSED DUPLICATE of bug 634224
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2008-04-17 11:17 EDT by Carl Roth
Modified: 2013-01-09 20:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-09-16 00:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2008-04-17 11:17:52 EDT
Description of problem:

Currently the mock plugin api isn't really a plugin api.  That is, the explicit
list of plugins is spelled out in the mock sources, meaning it's not easily
extendible with new plugins.  It would be better if mock trolled its plugin
directory and loaded all plugins that were available.

The current workaround I'm using (sort of a hack) is to manipulate the plugin
list and plugin configuration dictionaries from the site-defaults.cfg file. 
That's a short-term solution, since the newly-added plugins aren't visible from
the command-line enable/disable options.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Michael E Brown 2008-04-17 16:22:09 EDT
Agreed. I originally started working on the plugin API, but my intent was to
ensure that I didnt over-engineer it and write a bunch of code that would not be

If you have specific enhancements to the plugin API, go ahead and post them to
fedora-buildsys-list for discussion, and I would more than happy to add any
reasonable extensions to the plugin API to the codebase.
Comment 2 Masatake YAMATO 2010-09-16 00:13:32 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=634224

*** This bug has been marked as a duplicate of bug 634224 ***

Note You need to log in before you can comment on or make changes to this bug.