Bug 634224 - [patch] adding runtime plugin support
Summary: [patch] adding runtime plugin support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Clark Williams
URL:
Whiteboard:
: 442909 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-15 14:44 UTC by Masatake YAMATO
Modified: 2013-01-10 06:13 UTC (History)
4 users (show)

Fixed In Version: mock-1.1.10-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-13 16:58:04 UTC


Attachments (Terms of Use)
Proposed patch (2.07 KB, patch)
2010-09-15 14:44 UTC, Masatake YAMATO
no flags Details | Diff

Description Masatake YAMATO 2010-09-15 14:44:33 UTC
Created attachment 447492 [details]
Proposed patch

Description of problem:

Mock has plug-in mechanism but source code modification is needed to add a plug-in.
For writing an experimental plug-in or a plug-in for private purpose, it is nice
if one can add a plug-in without modifying the source code of mock itself.

With the attached patch, python script files at $PKGPYTHONDIR/plugins are added
as plugins to mock automatically.

Comment 1 Clark Williams 2010-09-15 15:42:02 UTC
Yeah, I like this. I'll queue it up for the next release.

Comment 2 Masatake YAMATO 2010-09-16 04:13:32 UTC
*** Bug 442909 has been marked as a duplicate of this bug. ***

Comment 3 Masatake YAMATO 2010-09-16 04:15:12 UTC
Thank you for queuing.
Will the patch be installed to the git repository?

Comment 4 Clark Williams 2010-09-16 15:04:46 UTC
Yes, but it won't get there very much before I release.

Comment 5 Masatake YAMATO 2010-12-14 07:08:37 UTC
Can I expect this patch will be included in f15?

Comment 6 Clark Williams 2010-12-14 16:38:31 UTC
I'm putting it into 1.1.8 right now. Should be available in F{13,14,15} and EL{5,6} in the near future.

Comment 7 Masatake YAMATO 2010-12-15 05:36:22 UTC
Thanks.

(In reply to comment #6)
> I'm putting it into 1.1.8 right now. Should be available in F{13,14,15} and
> EL{5,6} in the near future.

Comment 8 Fedora Admin XMLRPC Client 2011-03-11 18:09:21 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 9 Fedora Update System 2011-05-13 20:32:19 UTC
mock-1.1.10-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc15

Comment 10 Fedora Update System 2011-05-13 20:37:23 UTC
mock-1.1.10-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc14

Comment 11 Fedora Update System 2011-05-13 20:41:37 UTC
mock-1.0.17-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.17-1.el5

Comment 12 Fedora Update System 2011-05-13 20:45:51 UTC
mock-1.1.10-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc13

Comment 13 Fedora Update System 2011-05-13 20:50:03 UTC
mock-1.1.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.el6

Comment 14 Fedora Update System 2011-05-19 04:33:49 UTC
mock-1.1.10-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-05-25 02:41:09 UTC
mock-1.1.10-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-05-25 03:15:37 UTC
mock-1.1.10-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-06-02 19:05:17 UTC
mock-1.0.17-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-06-02 19:15:20 UTC
mock-1.1.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.