Bug 442910 - system-config-lvm desktop file incorrect
system-config-lvm desktop file incorrect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jim Parsons
Fedora Extras Quality Assurance
:
: 446774 458546 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 11:19 EDT by Kevin Fenzi
Modified: 2009-07-05 10:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 12:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Properly install the .desktop file (1.18 KB, patch)
2008-10-09 10:16 EDT, Deji Akingunola
no flags Details | Diff

  None (edit)
Description Kevin Fenzi 2008-04-17 11:19:37 EDT
The system-config-lvm desktop file has: 
Categories=Application;SystemSetup;X-Red-Hat-Base;

See: 
http://standards.freedesktop.org/menu-spec/latest/apa.html

Both Application and SystemSetup are not valid. 

Perhaps it should be: 

System;Settings;X-Red-Hat-Base; ?

This issue makes system-config-lvm show up in the 'Other' menu item under Xfce.
Comment 1 Jim Parsons 2008-04-17 13:45:58 EDT
Yikes - Will respin today after i find out what the settings need to be.
Comment 2 Matthias Clasen 2008-04-17 13:58:17 EDT
If it is supposed to show up in the System > Administration menu (as I assume it
is), then System;Settings; is right. Nonbody cares about X-Red-Hat-Base anymore...
Comment 3 Deji Akingunola 2008-05-01 19:58:49 EDT
This bug is not fixed yet. It doesn't show up at all in a Gome-based fresh
installation. Matthias already responded on what the settings need to be.
Comment 4 David Timms 2008-05-05 10:00:32 EDT
Confirmed that for 2x machines upgraded from F8>F9beta>rawhide, that the LVM
configure icon does not show up anywhere in the gnome menus.

This diff shows that the desktop file install has been removed from the spec...
http://cvs.fedoraproject.org/viewcvs/rpms/system-config-lvm/F-9/system-config-lvm.spec?r1=1.27&r2=1.29

Is that because it is now inside the {unreachable} Source0: ?
Don't you still have to do either desktop-file-install {or verify} according to
the packaging guidelines ?
Comment 5 Bug Zapper 2008-05-14 05:35:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Deji Akingunola 2008-08-06 23:41:56 EDT
*** Bug 446774 has been marked as a duplicate of this bug. ***
Comment 7 john5342 2008-08-09 14:00:52 EDT
*** Bug 458546 has been marked as a duplicate of this bug. ***
Comment 8 Deji Akingunola 2008-10-09 10:16:09 EDT
Created attachment 319861 [details]
Properly install the .desktop file

The attached patch fix this issue, please apply.

Matthias, I noticed you have a commit right to this package, would you please apply it, just in case the owner is too busy to do it.
Comment 9 Matthias Clasen 2008-10-09 12:27:03 EDT
built in rawhide
Comment 10 Deji Akingunola 2008-10-10 00:07:59 EDT
Thanks Matthias. Unfortunately it failed to build, missing a BuildRequires on desktop-file-utils .
Comment 11 David Timms 2009-07-05 10:56:19 EDT
Confirmed fixed in:
- F10 (system-config-lvm-1.1.4-3.1.fc10.noarch)
- F11 (system-config-lvm-1.1.4-5.1.fc11.noarch). Both releases now show the LVM icon under System|Administration as expected.

Note You need to log in before you can comment on or make changes to this bug.