This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442958 - add preupgrade notification
add preupgrade notification
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: MoveUpstream
: 442645 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 17:01 EDT by Colin Walters
Modified: 2008-10-14 08:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 08:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
check for preupgrades (3.95 KB, patch)
2008-04-17 17:01 EDT, Colin Walters
no flags Details | Diff

  None (edit)
Description Colin Walters 2008-04-17 17:01:34 EDT
Hi, this patch makes Pirut depend on preupgrade.  It will ask preupgrade whether
or not there are new supported major version upgrades.  If so, it will prompt
the user one every two weeks to upgrade.
Comment 1 Colin Walters 2008-04-17 17:01:34 EDT
Created attachment 302810 [details]
check for preupgrades
Comment 2 Jeremy Katz 2008-04-17 17:07:06 EDT
pirut is dead in rawhide
Comment 3 Richard Hughes 2008-04-18 07:55:04 EDT
*** Bug 442645 has been marked as a duplicate of this bug. ***
Comment 4 Richard Hughes 2008-04-18 08:08:46 EDT
Okay, in the PackageKit world this has to be an abstract method with a
client/server split. I think this is perfectly in the scope of PackageKit, and
we can just execute a call to the pre-upgrade stuff as the session when this is
detected and the libnotify window is clicked.

Colin, could you join the PackageKit mailing list, and we can discuss this
functionality there with the other distro guys.

Thanks.
Comment 5 Colin Walters 2008-04-18 12:37:43 EDT
Right, this patch is to help F8 users upgrade to F9.  

I'm definitely aware that packagekit has replaced pirut post-F8, and am
interested in seeing/helping with similar functionality in PackageKit.  It
shouldn't be hard to add there.   We have a bit of time though before we need it
for the F9->F10 upgrades.
Comment 6 Bug Zapper 2008-05-14 05:36:07 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Richard Hughes 2008-10-14 08:55:28 EDT
Done in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.