Bug 443047 - Does not display content of an samba connected folder on an old samba server..
Does not display content of an samba connected folder on an old samba server..
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
: 450708 (view as bug list)
Depends On: 446657
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 08:23 EDT by Jóhann B. Guðmundsson
Modified: 2009-02-12 15:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 14:11:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gvfsd-smb debug output (41.67 KB, text/plain)
2008-05-12 11:04 EDT, Tomáš Bžatek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 5826 None None None Never

  None (edit)
Description Jóhann B. Guðmundsson 2008-04-18 08:23:45 EDT
Description of problem:

It does not display contents of samba connected share/folder,
but you can copy to the share ( drag/drop copy/paste )

This has to do with connecting to an share on an old samba servers, 
atleast with version 2.2.8 tested opening shares on servers running

samba-3.0.25b-1.el5_1.4

and 

samba3-3.0.24-30

and 2.2.8

And the contents of the share folder on samba servers 
3.0.24 and 3.0.25 get displayed flawlessly.

But on the ancient one the content does not get displayed.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Created new samba connection and open the connected folder.
2..
3.
  
Actual results:

Contents of samba share is not displayed.

Expected results:

Contents being displayed.

Additional info:
Comment 1 Tomáš Bžatek 2008-05-12 11:04:09 EDT
Created attachment 305136 [details]
gvfsd-smb debug output

OK, this is a problem with smbclient > 3.2.0 when connected to a 2.2.x server.
Server: 2.2.12-1.21as.1 (RHEL 2.1)
Client: 3.2.0pre2-GIT-38eab68-test, 3.2.0-1.pre3.9.fc9.i386

When using client 3.0.xx (Fedora 8), smbclient output is fine.

Reassigning to samba team.

Attached you can find debug output from gvfsd-smb with raw communication dump.
smbc_getdents() returns already truncated filenames.
---------------


$ smbclient -V
Version 3.2.0pre2-GIT-38eab68-test
$ smbclient //10.34.34.152/tomas -U tomas
Domain=[MYGROUP] OS=[Unix] Server=[Samba 2.2.12]
smb: \> ls
				      D        0  Mon May 12 16:06:07 2008
  .				      D        0  Mon May 12 15:29:03 2008
  .bash_logou			      H       24  Mon May 12 15:29:03 2008
  .bash_profil			      H      191  Mon May 12 15:29:03 2008
  .bashr			      H      124  Mon May 12 15:29:03 2008
  .gtkr 			      H      118  Mon May 12 15:29:03 2008
  .gnom 			     DH        0  Mon May 12 15:30:32 2008
  .xsession-error		      H     1034  Mon May 12 16:05:54 2008
  .gnome_privat 		     DH        0  Mon May 12 15:29:20 2008
  .Xauthorit			      H      115  Mon May 12 15:29:19 2008
  .sawfis			     DH        0  Mon May 12 15:29:22 2008
  .gconf			     DH        0  Mon May 12 15:44:22 2008
  .gcon 			     DH        0  Mon May 12 15:29:23 2008
  .ICEauthorit			      H      189  Mon May 12 15:29:20 2008
  .nautilu			     DH        0  Mon May 12 15:29:23 2008
  .gnome-deskto 		     DH        0  Mon May 12 15:29:24 2008
  sfstreets.ti				  214378  Mon May 12 15:32:36 2008
  .m				     DH        0  Mon May 12 15:43:35 2008
  .xscreensave			      H     7873  Mon May 12 16:06:07 2008

		60100 blocks of size 131072. 49903 blocks available
smb: \> 




$ smbclient -V
Version 3.0.28a-0.fc8
$ smbclient //10.34.34.152/tomas -U tomas
Password: 
Domain=[MYGROUP] OS=[Unix] Server=[Samba 2.2.12]
smb: \> ls
  .				      D        0  Mon May 12 16:06:07 2008
  ..				      D        0  Mon May 12 15:29:03 2008
  .bash_logout			      H       24  Mon May 12 15:29:03 2008
  .bash_profile 		      H      191  Mon May 12 15:29:03 2008
  .bashrc			      H      124  Mon May 12 15:29:03 2008
  .gtkrc			      H      118  Mon May 12 15:29:03 2008
  .gnome			     DH        0  Mon May 12 15:30:32 2008
  .xsession-errors		      H     1034  Mon May 12 16:05:54 2008
  .gnome_private		     DH        0  Mon May 12 15:29:20 2008
  .Xauthority			      H      115  Mon May 12 15:29:19 2008
  .sawfish			     DH        0  Mon May 12 15:29:22 2008
  .gconfd			     DH        0  Mon May 12 15:44:22 2008
  .gconf			     DH        0  Mon May 12 15:29:23 2008
  .ICEauthority 		      H      189  Mon May 12 15:29:20 2008
  .nautilus			     DH        0  Mon May 12 15:29:23 2008
  .gnome-desktop		     DH        0  Mon May 12 15:29:24 2008
  sfstreets.tif 			  214378  Mon May 12 15:32:36 2008
  .mc				     DH        0  Mon May 12 15:43:35 2008
  .xscreensaver 		      H     7873  Mon May 12 16:06:07 2008

		60100 blocks of size 131072. 49903 blocks available
smb: \>
Comment 2 Bug Zapper 2008-05-14 05:37:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Adam Huffman 2008-06-12 13:19:52 EDT
*** Bug 450708 has been marked as a duplicate of this bug. ***
Comment 4 Jóhann B. Guðmundsson 2008-06-13 02:13:51 EDT
After noticing the movement on the bug I remembered one discovery I made
if you create a file and another file with same name and ~ ending it displays in 
nautilus.. as in "touch samba-test.txt samba-test.txt~" Interesting indeed :)
Comment 5 Jóhann B. Guðmundsson 2008-06-13 02:38:43 EDT
To duplicate just ssh into the server and do 

touch samba-test.txt samba-test.txt~        #for an txt file 
mkdir samba-test-folder samba-test-folder~  #for an folder

Connect to the samba share ( nautilus )and see if it displays 
or just connect to the share ( nautilus ) in and right click create 2
folder/file one with name and another one with the same name~ and click refresh
and the folder stays this time :)

It would be good if some one could confirm this and I hope this help in
narrowing down the cause.. 
Comment 6 Adam Huffman 2008-10-11 11:07:03 EDT
Has there been any progress on this?

I can connect using smbclient, but the last character in all directory and filenames is truncated.  That said, if I give the correct filename to smbclient, transfers are possible.

This is with version:

samba-client-3.2.4-0.22.fc10.x86_64
Comment 7 Mike Perrin 2008-10-26 14:16:15 EDT
Nautilus file browsing with Places -> Network is still broken in my case.

Configuration:
Rawhide 9.92, samba-client and samba-common 3.2.4-0.22.fc10.i386
Trendnet TS-U200 file server running samba 2.2.8a

Observations:
I can browse to the file server and connect to both public and user/password protected shares, but the contents of the shares are not displayed. A file dropped into the browser window will be written to the share. If the file is deleted via the browser window, it is deleted from the share. If the file is deleted from the share via another machine, it will be deleted from the browser window when View -> Reload is requested.

I confirmed the oddity reported by johannbg in comment #4. If I create somefile and somefile~ on the share via another machine, the non-tilde file appears in the browser window when View -> Reload is requested. If I delete the file using the browser window, only the non-tilde file is removed from the share. 

File share browsing works fine to shares on a W2000 SP4 machine.

It is quite annoying that 3.2.x still refuses to work with 2.2.x servers but 3.0.x (on Fedora 8 and Ubuntu 8.04) works perfectly. I can't upgrade the server since Trendnet's last firmware update was 3/1/2006. Does anyone know if the samba folks even care about this?
Comment 8 Tomáš Bžatek 2008-10-27 06:41:47 EDT
Increasing severity/priority as many people repeatedly report this issue, even upstream. Looks like various NAS boxes and other black boxes with minimal distros are running old Samba 2.2.x series and this issue is a major blocker for some users.
Comment 9 Jóhann B. Guðmundsson 2008-10-27 07:46:47 EDT
Confirmed still being an issue with latest rawhide updates...

If I create a file or folder with the same name
as a file or folder that does not get displayed
with an added ~ it gets displayed.

As in if I create a file called test.txt it does 
not show up in "nautilus" but if I then create 
another file called test.txt~ then the test.txt 
gets shows...
Comment 10 Jóhann B. Guðmundsson 2008-11-05 05:24:57 EST
Still an issue in an fresh F10preview installation 

Increased the severity to high.. 

Is this even being worked on???
Comment 11 Mike Perrin 2008-11-28 21:26:42 EST
This bug has been fixed, at least for me, in Ubuntu 8.10 with samba-common/smbclient 2:3.2.3-1ubuntu3.3.

Network browsing in F10 with samba-common/smbclient 3.2.4-0.22.fc10.i386 is badly broken. I cannot even discover the share servers with the network browser.
Comment 12 Jóhann B. Guðmundsson 2008-11-29 04:11:23 EST
You tested connecting to an older samba server as in 
the 2.x not the 3.x ? 

Do you know if the fix got pushed upstream there seems to be little 
no responses to bugs filed against samba in Fedora.

Did you try discovering with the firewall off ?
( to rule out it blocking it )
Comment 13 Mike Perrin 2008-11-29 12:05:49 EST
Johann,

My stupid. I forgot to disable the firewall after installing F10. With the firewall disabled I am able to browse to the share servers. The contents of the shares on the 2.2.8a server are still not displayed. The behavior remains as I documented in comment #7 above.

Mike
Comment 14 Tomáš Bžatek 2008-12-08 08:20:14 EST
There's an upstream patch available: https://bugzilla.samba.org/show_bug.cgi?id=5826
which is the same as in our bug 446657
Comment 15 Mike Perrin 2009-02-06 21:21:30 EST
The display of contents bug is fixed in samba-*-3.2.8-0.26.fc10.i386, at least on a public samba 2.2.8a share.

Now I am again having problems connecting to a user/password share on the same file server, with either the firewall disabled or with it enabled and eth0 designated as a trusted device. I can mount the share using mount.cifs after granting superuser execution (chmod +s) to that program, but using the network browser fails with "Unable to mount location" after entering my username and password.

Software updates giveth, and they taketh away...

My thanks to everyone who is working on this issue.
Comment 16 Mike Perrin 2009-02-11 13:44:21 EST
My problem connecting to the user/password share was fixed by adding the following line to smb.conf
     client lanman auth = yes
My understanding is that this provides weaker security but is the only way to get authenticated to a samba 2.x server.

Apparently this addition was required by a change in the default behavior of the updated samba client package.
Comment 17 Simo Sorce 2009-02-11 14:11:58 EST
Mike,
thanks for sharing your findings.

Upstream did indeed change the defaults in recent releases so that insecure methods are not used by default.

I think we can close the bug.

Before anyone asks, we will *not* make lanman auth the default in Fedora packages, so I will close this bug as WONTFIX to reflect that although technically this is not a bug but intended behavior.
Comment 18 Jóhann B. Guðmundsson 2009-02-12 05:43:18 EST
Just putting it for the record here. 

When I filed this bug it was never against any kind of authentication problem
( I never experience any kind of authentication problem.. then again the lanman auth = Yes is on set by default )

It was about contents of a samba share on a 2.2x version of samba
server failed to display. 

I'm going to ask reporter no to hijack bug reports and the maintainer
read and check what this bug was originally filed against.

This has been FIXED the contents do get shown now.
Comment 19 Adam Williamson 2009-02-12 12:11:54 EST
Johann: as mentioned on IRC, Mike Perrin does in fact say in comment #15 that the initial bug which you reported is fixed:

"The display of contents bug is fixed in samba-*-3.2.8-0.26.fc10.i386, at least
on a public samba 2.2.8a share."

So that's why the report was closed. The other issue was just incidental.
Comment 20 Adam Williamson 2009-02-12 12:14:13 EST
Oh, however - I would agree with you in the sense that the resolution is wrong. The bug has been resolved as if the issue was the authentication problem. The bug here is the folder contents display issue, so it should be resolved as fixed, since the bug has in fact been fixed. :)
Comment 21 Simo Sorce 2009-02-12 15:02:59 EST
Ok, marked as fixed, thanks for verifying :)

Note You need to log in before you can comment on or make changes to this bug.