Bug 443087 - sndrv_pcm_hw_params: Assertion `err >= 0' failed.
sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
https://bugtrack.alsa-project.org/als...
:
: 445106 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 11:55 EDT by Ben Popatopalous
Modified: 2008-10-24 16:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
ALSA Project 2601 None None None Never

  None (edit)
Description Ben Popatopalous 2008-04-18 11:55:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
1.$ realplay

(realplay.bin:3473): Gtk-WARNING **: Unable to locate theme engine in module_path: "nodoka",
Opening ALSA PCM device default
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.

2. $ speaker-test

speaker-test 1.0.15

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 1 to 2097152
Period size range from 0 to 206158431
Using max buffer size 2097152
Periods = 4
was set period_size = 0
was set buffer_size = 2097152
speaker-test: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Aborted

3. When I play music videos with MPlayer I get the error:

Error!
[AO_ALSA] Unable to find simple control 'PCM', 0.


Version-Release number of selected component (if applicable):
RealPlayer-11.0.0.4028-20080225

How reproducible:
Always


Steps to Reproduce:
1.Try to play music videos with mplayer
2.Try to listen to streaming audio with RealPlayer 11
3.From cli run speaker-test

Actual Results:
All result in some form of error 'pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0'' or '[AO_ALSA] Unable to find simple control 'PCM', 0.'.
RealPlayer crashes. Mplayer plays video but the error message keeps repeating in a flashing manner in middle of video screen. speaker-test simply does not play.

Expected Results:
RealPlayer should play streaming audio.
MPlayer should play music videos without constant error message.
speaker-test should play pink noise through speakers.

Additional info:
https://bugs.helixcommunity.org/show_bug.cgi?id=7375

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601

http://forums.fedoraforum.org/showthread.php?t=186200

Some have reported that this may be result of a bug in alsa-libs. The alsa-bug report # 2601 reports possible fixes for this which may not hove gotten through in Fedora 8. leigh123@linux reports in Fedora Forum that RealPlayer was crashing in Fedora 9 but is now working.
Comment 1 Ben Popatopalous 2008-04-19 09:38:47 EDT
I found a fix here:

http://forums.fedoraforum.org/showthread.php?t=174298&goto=newpost

Here's what I did.

# rpm -e RealPlayer
# yum install kernel-devel mercurial
# yum groupinstall 'Development Tools'
$ hg clone http://hg-mirror.alsa-project.org/alsa-driver alsa-driver
$ hg clone http://hg-mirror.alsa-project.org/alsa-kernel alsa-driver/alsa-kernel
$ cd alsa-driver
$ make ALSAKERNELDIR=alsa-kernel all-deps
$ aclocal; autoconf
$ /configure --with-cards=hda-intel
$ make || make
# make install

Then reboot to make sure you're using the newly compiled module.

Then simply:

Answer for 1. cd to where you downloaded RealPlayer 11 and

# rpm -ihv RealPlayer11GOLD.rpm

and it just works. Right out of the box. Default settings. In Firefox RealPlayer
plugins play streaming audio fine streaming video seems buggy but this report is
for audio issue and that's working fine.

Answer for 2. $ speaker-test

speaker-test 1.0.15

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
 0 - Front Left
Time per period = 2.659716
 0 - Front Left

3. Now MPlayer plays music videos just fine. This with
MPlayer>Preferences>Audio> set to  and >Video set to xv. 

Credit for this fix goes to poster nikosapi at this link:

http://forums.fedoraforum.org/showthread.php?t=174298&page=3&pp=15
Comment 2 Ben Popatopalous 2008-04-19 09:51:52 EDT
Whoops. I left one thing out. I also had to uncomment the line
"/etc/alsa/pulse-default.conf" in '/etc/alsa/alsa.conf':


#
#  ALSA library configuration file
#

# pre-load the configuration files

@hooks [
        {
                func load
                files [
                        # "/etc/alsa/pulse-default.conf"
                        "/etc/asound.conf"
                        "~/.asoundrc"
                ]
                errors false
        }
]

# load card-specific configuration files (on request)

cards.@hooks [
        {
                func load
Comment 3 Martin Stransky 2008-04-24 08:29:06 EDT
Can you please check if is it present in Fedora9? There are some audio config
changes there.
Comment 4 Martin Stransky 2008-05-06 02:45:39 EDT
Moving to pulseaudio...
Comment 5 Daniel Yek 2008-05-08 04:26:32 EDT
This is being fixed in RealPlayer. 

There could be a problem with alsa-lib too; see comment in this bug report:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601

But this is not a PulseAudio problem though.
Comment 6 Lennart Poettering 2008-06-13 19:52:02 EDT
*** Bug 445106 has been marked as a duplicate of this bug. ***
Comment 7 Lennart Poettering 2008-10-24 16:53:02 EDT
I am pretty sure this was fixed a while back in alsa-lib. Closing.

If the problem persists, please reopen.

Note You need to log in before you can comment on or make changes to this bug.