Bug 445106 - speakter-test is not working: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
speakter-test is not working: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Status: CLOSED DUPLICATE of bug 443087
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
https://bugtrack.alsa-project.org/als...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-03 16:18 EDT by Christian Nolte
Modified: 2008-06-13 19:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 19:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
ALSA Project 2601 None None None Never

  None (edit)
Description Christian Nolte 2008-05-03 16:18:16 EDT
speaker-test fails with the following messages:

---
speaker-test 1.0.15

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 1 to 2097152
Period size range from 0 to 206158431
Using max buffer size 2097152
Periods = 4
was set period_size = 0
was set buffer_size = 2097152
speaker-test: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Aborted
---

Further information:

[root@ravine pulse]# cat /proc/asound/cards 
 0 [Audigy         ]: Audigy - Audigy 1 [SB0090]
                      Audigy 1 [SB0090] (rev.3, serial:0x511102) at 0x9c00, irq 5
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe020000 irq 11
[root@ravine pulse]# cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42
2007 UTC).
[root@ravine pulse]# rpm -q alsa-utils
alsa-utils-1.0.15-1.fc8
[root@ravine pulse]# rpm -q pulseaudio
pulseaudio-0.9.8-5.fc8

The message 'sndrv_pcm_hw_params: Assertion `err >= 0' failed.' also comes when
doom3 is started, which is using SDL sound.
Comment 1 Christian Nolte 2008-05-03 16:29:00 EDT
Seems to be a duplicate of bug #443087
Comment 2 Martin Stransky 2008-05-05 04:51:34 EDT
Does the change from https://bugzilla.redhat.com/show_bug.cgi?id=443087#c2 fix
the problem for you?
Comment 3 Christian Nolte 2008-05-06 02:12:19 EDT
Yes, it does. But AFAICS this is effectively the same as disabling pulseaudio
for alsa (i.e. the same as 'yum remove alsa-plugins-pulseaudio'.
Comment 4 Martin Stransky 2008-05-06 02:44:48 EDT
Yes. But it's a pulseaudio but then....
Comment 5 Lubomir Rintel 2008-05-06 02:59:06 EDT
This is being tracked upstream:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601
Comment 6 Lennart Poettering 2008-06-13 19:52:01 EDT

*** This bug has been marked as a duplicate of 443087 ***

Note You need to log in before you can comment on or make changes to this bug.