Bug 443218 - Avahi is useless for remote filesystems
Avahi is useless for remote filesystems
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 07:46 EDT by Avi Alkalay
Modified: 2008-12-11 14:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 14:20:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 267281 None None None Never

  None (edit)
Description Avi Alkalay 2008-04-19 07:46:09 EDT
My fstab has na entry like this:
floripa.local:/media/media      /mnt/floripa    nfs     defaults        0 0

But this is not getting mounted at boot time because avahi-daemon is one of the
last daemons being run but "floripa.local" needs Avahi to get resolved.

avahi-daemon is 96 while netfs is 25 in /etc/init.d

Is there any reason to not put avahi-daemon to run right before network (init
sequence 10) ?

By the way, this kind of mount just works in an Ubuntu boot.

Version-Release number of selected component (if applicable):
On an updated Fedora Beta 9:
$ rpm -q avahi initscripts
avahi-0.6.22-10.fc9.i386
initscripts-8.70-1.i386
Comment 1 Bug Zapper 2008-05-14 05:43:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Lennart Poettering 2008-12-11 14:20:06 EST
The upstream init script has now been moved to prio 24. This will shortly hit rawhide.
Comment 3 Lennart Poettering 2008-12-11 14:20:31 EST
The upstream init script has now been moved to prio 24. This will shortly hit rawhide.

Note You need to log in before you can comment on or make changes to this bug.