Bug 443219 - startup notification bounces after Firefox3 is opened
startup notification bounces after Firefox3 is opened
Status: CLOSED DUPLICATE of bug 445543
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 07:52 EDT by Mary Ellen Foster
Modified: 2008-05-08 21:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 21:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 161109 None None None Never

  None (edit)
Description Mary Ellen Foster 2008-04-19 07:52:05 EDT
Description of problem:
If you start Firefox from the KDE menu, the window comes up fairly quickly, but
the startup notification keeps bouncing until it times out (about 30 seconds).

Version-Release number of selected component (if applicable):
firefox-3.0-0.54.beta5.fc9.i386

How reproducible:
Every time


Steps to Reproduce:
1. Start Firefox from the KDE menu
  
Actual results:
Bouncing firefox icon on cursor for about 30 seconds

Expected results:
Bouncing firefox should go away after window opens
Comment 1 Matěj Cepl 2008-04-19 16:47:46 EDT
This is unfortunately problem with KDE -- there is not enough feedback between
the non-KDE application being started and KDE notification system.
Comment 2 Kevin Kofler 2008-04-19 17:01:06 EDT
But what can we do in KDE about that?
Comment 3 Steven M. Parrish 2008-04-19 17:04:35 EDT
Did a search of bugs.kde.org could not find a similar report.  Please file an
upstream report for this issue and update this report with upstream info.

Thanks

Steven
Comment 4 Rex Dieter 2008-04-19 17:36:57 EDT
Does firefox not use startup-notification?
Comment 5 Rex Dieter 2008-04-19 17:41:43 EDT
Apparently not.  If missing startup-notification is not considered a bug, it
should at least be considered a feature request.

Nothing kde can do here (afaict) -> firefox.  firefox folks are welcome to close
wontfix.
Comment 6 Matěj Cepl 2008-04-20 05:06:23 EDT
According to https://bugzilla.mozilla.org/show_bug.cgi?id=223492
startup-notification should have been fixed in the November last year.
Comment 7 Christopher Aillon 2008-04-20 10:07:44 EDT
Yeah, what makes you think it doesn't have startup notification support?  It
does, we've already uncovered (and fixed) bugs in metacity because of it.
Comment 8 Rex Dieter 2008-04-20 12:35:55 EDT
*shrug*, I naively figured no (direct) deps on startup-notification implied no
support.  My bad.

At this point all we have is finger pointing, both kde4 and firefox claim to
support startup-notification.  So, now we've gotta figure out how to debug it
sufficiently to determine where things are going wrong.

Fwiw, this only happens with firefox, thunderbird seems fine.  For giggles I may
try firefox2 and/or some other xulrunner-based apps.

Regardless, I'll help take the torch on the kde-side of things (and reassign
accordingly).  Any input from "the other side" would be appreciated.

Mary, could you report this to upstream bugs.kde.org?  We'll see what they have
to say.  (Otherwise, I'll do when I have banked enough round-tuits).
Comment 9 Christopher Aillon 2008-04-20 13:11:10 EDT
The no deps thing is fallout from bug 443015 (see also bug 443112).  But it is
properly built and linked and everything.  I'd imagine since KDE supports
notification, something else on the spin would bring it in.  If not, then this
could potentially be the cause of the bug?
Comment 10 Rex Dieter 2008-04-20 13:29:29 EDT
Maybe?  What I'm using currently is
$ rpm -q xulrunner firefox
xulrunner-1.9-0.54.beta5.fc9.x86_64
firefox-3.0-0.54.beta5.fc9.x86_64
Comment 11 Mary Ellen Foster 2008-04-21 06:34:36 EDT
So should I file this upstream or not?
Comment 12 Rex Dieter 2008-04-21 08:11:56 EDT
Re: comment #11 Mary, 
yes, please.
Comment 13 Mary Ellen Foster 2008-04-21 08:22:50 EDT
Done.
Comment 14 Steven M. Parrish 2008-04-21 17:50:39 EDT
Mary,

Can you update this report with the info from your upstream bug report.

Thanks,
Steven
Comment 15 Mary Ellen Foster 2008-04-21 17:53:49 EDT
It's included in this bug's metadata, but okay, here is the direct link to the
upstream bug:

http://bugs.kde.org/show_bug.cgi?id=161109

No upstream activity yet ...
Comment 16 Steven M. Parrish 2008-04-21 18:05:21 EDT
D'oh my bad, missed it when I looked over the bug.
Comment 17 Kevin Kofler 2008-05-08 21:09:21 EDT

*** This bug has been marked as a duplicate of 445543 ***

Note You need to log in before you can comment on or make changes to this bug.