This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 443015 - rpm-find-requires prints no dependencies
rpm-find-requires prints no dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
: Reopened
: 458527 (view as bug list)
Depends On:
Blocks: F9Blocker F10Blocker/F10FinalBlocker 443114 443118
  Show dependency treegraph
 
Reported: 2008-04-18 03:21 EDT by Richard W.M. Jones
Modified: 2008-08-11 03:34 EDT (History)
5 users (show)

See Also:
Fixed In Version: redhat-rpm-config-9.0.3-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 03:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch! (579 bytes, patch)
2008-04-18 12:16 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2008-04-18 03:21:12 EDT
Description of problem:

rpm-find-requires prints nothing on a fully up to date Fedora 9.

Version-Release number of selected component (if applicable):

rpm-build-4.4.2.3-1.fc9.i386

How reproducible:

100%

Steps to Reproduce:
1. echo /bin/ls | /usr/lib/rpm/find-requires
  
Actual results:

Nothing.

Expected results:

On F-8:

$ echo /bin/ls | /usr/lib/rpm/find-requires
libacl.so.1()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
librt.so.1()(64bit)
librt.so.1(GLIBC_2.2.5)(64bit)
libselinux.so.1()(64bit)

Additional info:

This breaks rpmbuild's dependency checking badly.
Comment 1 Bill Nottingham 2008-04-18 12:16:58 EDT
Created attachment 302902 [details]
patch!

An earlier patch (436770) broke this. Try the attached.
Comment 2 Bill Nottingham 2008-04-18 12:21:20 EDT
Alternatively, your package's find-requires call could call
/usr/lib/rpm/redhat/find-requires...
Comment 3 Richard W.M. Jones 2008-04-18 12:37:46 EDT
I could change the base OCaml package to call
/usr/lib/rpm/redhat/find-requires instead of
/usr/lib/rpm/rpm-find-requires.  I would like to understand
what the difference is between these two scripts though.

Your patch in comment 2 works for me however!

$ echo /bin/ls | /usr/lib/rpm/find-requires
libacl.so.1
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.3)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
librt.so.1
librt.so.1(GLIBC_2.2)
libselinux.so.1

and with rpmbuild on an OCaml package:

$ rpm -q --requires -p
/home/rjones/rpmbuild/RPMS/i386/virt-ctrl-1.0.0-1.fc9.i386.rpm
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
libatk-1.0.so.0  
libcairo.so.2  
libc.so.6  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.2)  
libc.so.6(GLIBC_2.2)  
libc.so.6(GLIBC_2.3)  
libc.so.6(GLIBC_2.3.4)  
libc.so.6(GLIBC_2.4)  
libdbus-1.so.3  
libdl.so.2  
libdl.so.2(GLIBC_2.0)  
libdl.so.2(GLIBC_2.1)  
libgdk_pixbuf-2.0.so.0  
libgdk-x11-2.0.so.0  
libglib-2.0.so.0  
libgmodule-2.0.so.0  
libgobject-2.0.so.0  
libgtk-x11-2.0.so.0  
libm.so.6  
libm.so.6(GLIBC_2.0)  
libpango-1.0.so.0  
libpangocairo-1.0.so.0  
libvirt.so.0  
Comment 4 Bill Nottingham 2008-04-18 12:42:28 EDT
The difference is that /usr/lib/rpm/redhat/find-requires doesn't have the
offending line...

In any case, building as 4.4.2.3-2.fc9.
Comment 5 Jindrich Novy 2008-04-18 13:51:59 EDT
Applied upstream. Thanks for the patch.
Comment 6 Bill Nottingham 2008-04-22 13:42:42 EDT
Verified, builds are correct now.
Comment 7 Kevin Kofler 2008-06-06 07:54:40 EDT
It looks like there's still (or "again"?) some variant of this bug in F10 
Rawhide, see:
https://bugzilla.redhat.com/show_bug.cgi?id=450271

The offending xchat build was built on May 22:
https://koji.fedoraproject.org/koji/buildinfo?buildID=50211

The F9 build from the same specfile has working deps.

xchat uses %define _use_internal_dependency_generator 0 because it has to 
filter autoprovides, this may be relevant.
Comment 8 Kevin Kofler 2008-06-15 09:04:53 EDT
xchat-2.8.6-1.fc10.i386.rpm, which I just built, still exhibits this bug. :-(
Comment 9 Kevin Kofler 2008-08-06 18:55:00 EDT
Ping? xchat-2.8.6-2.fc10 is still missing its dependencies. This makes xchat not start on a default installation, because it ends up installed without libntlm.
Comment 10 Panu Matilainen 2008-08-11 03:19:10 EDT
The dependency-eating bug ended up in redhat-rpm-config too...
Comment 11 Panu Matilainen 2008-08-11 03:20:24 EDT
*** Bug 458527 has been marked as a duplicate of this bug. ***
Comment 12 Panu Matilainen 2008-08-11 03:34:14 EDT
Fixed in redhat-rpm-config-9.0.3-2.fc10 (too)

Note You need to log in before you can comment on or make changes to this bug.