Bug 443242 - Hard drive not detected with non-existant partition table
Hard drive not detected with non-existant partition table
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 13:14 EDT by Ryan Bair
Modified: 2008-05-04 18:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 18:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 438985 None None None Never

  None (edit)
Description Ryan Bair 2008-04-19 13:14:37 EDT
Description of problem:
The installer cannot start partitioning because it claims that no hard drives
are installed. The drive is visible outside of the installer however.

Version-Release number of selected component (if applicable):
Fedora 9-Beta

How reproducible:
100%

Steps to Reproduce:
1.Install a hard drive without a valid partition table. dd works for this task.
2.Load up the installer and proceed to the partitioning section.
  
Actual results:
Anaconda will not continue because it can't see the drive.

Expected results:
Offer to initialize and partition the disk.

Additional info:
By dropping to a console, I was able to create the partition table using parted.
Only after rebooting the system, anaconda could properly detect the drive and
proceed with the installation. I blanked the drive again using dd and was able
to reproduce the error.

This is possibly related to bug 438985, but I didn't want to hijack the bug.
Comment 1 Jeremy Katz 2008-04-21 19:38:37 EDT
If you switch to a tty and run lshal, do you see the drive in the output?
Comment 2 Ryan Bair 2008-05-04 18:23:20 EDT
Yes, the drive does show up. I am able to manually partition it, then Anaconda
likes it. 

Fortunately, I was not able to reproduce this behaviour on the preview release.
I was given the option to initialize the disk as expected. 

Note You need to log in before you can comment on or make changes to this bug.