Bug 443244 - no dns entry in /etc/resolv.conf
no dns entry in /etc/resolv.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 444501 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-19 13:40 EDT by Steve
Modified: 2008-04-28 18:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 18:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve 2008-04-19 13:40:03 EDT
Description of problem:
installing fedora preview, anaconda and/or network-manager does not make the
dns-entry given by the installation. this was also by the alpha and beta version
of fedora 9.

Version-Release number of selected component (if applicable):


How reproducible:
install fedora preview and make the dns-entry by the installation and/or by the
network-manager after the installation. The dns-entry will not be written to
/etc/resolv.conf.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The dns-entry will not be written to /etc/resolv.conf.

Expected results:
It should be written to /etc/resolf.conf.

Additional info:
I'm sorry if this is an network-manager bug.
Comment 1 Craig Kelley 2008-04-23 10:54:37 EDT
This is a network-manager bug;  No matter what I enter in the GUI, even after
installation, /etc/resolv.conf only has the following:

# generated by NetworkManager, do not edit!


So I have to manually enter my nameserver and search domains after each network
restart.
Comment 2 Steve 2008-04-23 11:10:59 EDT
Of course, it is also a network-manager bug. But when i enter the dns-server by
the installation of fedora, it also should be in the resolv.conf. Does
network-manager make the entry by the installation?
Comment 3 David Cantrell 2008-04-25 20:23:59 EDT
anaconda writes out an /etc/resolv.conf file just fine.  If you manually set your nameservers, we write 
those to /etc/resolv.conf.  If you are using DHCP to set the DNS information, we don't do anything to 
resolv.conf.

This is a NetworkManager bug, but it may just be that we [anaconda] are not writing out a control file for 
NetworkManager correctly.  Reassigning to NM.
Comment 4 Dan Williams 2008-04-27 23:01:21 EDT
Dave: the problem with just writing /etc/resolv.conf is that it's not stable...
 the DNS information is realy _per connection_, not global to the machine.  So
we need to store DNS stuff in the ifcfg files these days, just like PPP does
with PEERDNS and DNS1, DNS2, DNS3.  NM reads DNS1, DNS2, and DNS3, as well as
SEARCHES (or something like that) and will populate resolv.conf from these.
Comment 5 David Cantrell 2008-04-28 15:29:07 EDT
Dan,

Well, actually the settings would be global, it's just that they depend on the active link at the time.  I will 
modify anaconda to write the DNS information out to the ifcfg-* file for now as well.  Need to rework the 
network configuration screen in anaconda anyway to account for some of the NM-related changes too.

Should this be reassigned to anaconda then?
Comment 6 Dan Williams 2008-04-28 16:30:36 EDT
*** Bug 444501 has been marked as a duplicate of this bug. ***
Comment 7 Dan Williams 2008-04-28 16:37:28 EDT
Yeah; let me know if you have any questions.  Bill and I also settled on
"SEARCH=xxxxxxx" as the list of space-delimited search domains.

So something like:

DNS1=4.2.2.1
DNS2=4.2.2.2
SEARCH=lab.foo.com foo.com

The ifup-ppp stuff already uses DNS1/DNS2 so there's precedent at least.  Thanks
for poking at this.
Comment 8 David Cantrell 2008-04-28 18:13:09 EDT
Fixed in rawhide.  Each ifcfg-* file gets DNS#= lines, a SEARCH line if applicable, and NM_CONTROLLED= 
written to it.

Note You need to log in before you can comment on or make changes to this bug.