This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 444501 - NetworkManager clobbers static DNS settings
NetworkManager clobbers static DNS settings
Status: CLOSED DUPLICATE of bug 443244
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 14:47 EDT by Josh Lange
Modified: 2008-04-28 16:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 16:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Lange 2008-04-28 14:47:33 EDT
Description of problem:
When installing fedora 9 through anaconda, a user get the opportunity to assign
a static IP/dns settings.

Upon first boot, NetworkManager clobbers these settings

How reproducible:
Always

  
Actual results:
/etc/resolv.conf is replaced with the line:
# generated by NetworkManager, do not edit!


Expected results:
NetworkManager either be
 1. disabled if someone enters a static IP
 2. be smart enough not to remove dns settings created by anaconda (ignore the
resolv.conf all together, if there are settings that it didn't create in there).

It seems kind of silly to assign the system dns settings, when NW manager is
just going to delete them.

Workaround:
create a %post anaconda directive, or switch to vt2 before restarting, and run:
chkconfig NetworkManager --level 35 off
chkconfig NetworkManagerDispatcher --level 35 off
Comment 1 Dan Williams 2008-04-28 16:28:26 EDT
You'll want to put the DNS settings into the ifcfg file directly, as:

DNS1=xxx.xxx.xxx.xxx
DNS2=xxx.xxx.xxx.xxx

for the moment, the GUI config tools don't do this though fixes are planned...
Comment 2 Dan Williams 2008-04-28 16:30:35 EDT

*** This bug has been marked as a duplicate of 443244 ***

Note You need to log in before you can comment on or make changes to this bug.