This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 443318 - Installer hangs with blank screen Nvidia Geforce 8800GTS
Installer hangs with blank screen Nvidia Geforce 8800GTS
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-20 12:05 EDT by Richard West
Modified: 2009-07-14 13:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log of successful start (46.63 KB, text/plain)
2008-04-24 15:02 EDT, Richard West
no flags Details
Setup log where problem seems to be displayed (795 bytes, text/plain)
2008-04-24 15:03 EDT, Richard West
no flags Details

  None (edit)
Description Richard West 2008-04-20 12:05:06 EDT
Description of problem:

When installing Fedora 9 preview, after the disk checking stage, and after
displaying "Loading Anaconda/probing for video card/waiting for X to start" (or
words to that effect), the installer hangs with a blank screen. This occurs with
the x64 version (I haven't downloaded i386 to see whether it suffers the same
issue).

The system in question has an ABIT IP-35 pro motherboard with an Nvidia Geforce
8800GTS graphics card, and is using a Dell widescreen LCD monitor with 1920x1200
native resolution.

How reproducible:

Begin graphical Fedora install with the setup outlined above.
  
Actual results:

Installer hangs with blank screen.

Expected results:

Fedora 9 proceeds to install.

Further information:

The problem appears to be related to X or the graphics subsystem since I was
able to successfully install F9 without encountering this issue by selecting a
text mode install from the initial menu. After booting to the installed system
in text mode, selecting "configure X" from the configuration tool that loads by
default seemed to cause the same problem. However, oddly, dropping to a command
prompt and then running "startx" manually caused no such issue, and Gnome loaded
up as expected.
Comment 1 Jeremy Katz 2008-04-21 19:34:25 EDT
Does booting the installer with 'xdriver=vesa' help?
Comment 2 Richard West 2008-04-22 00:33:09 EDT
(In reply to comment #1)
> Does booting the installer with 'xdriver=vesa' help?

Yes, the graphical installation proceeds as normal with that option specified,
and I don't encounter the problem.
Comment 3 my_linux 2008-04-22 09:22:37 EDT
I hope it's OK for me to add this info here. I get the same problem on an Acer
laptop (Nvidia 7000m) where the graphics installer does not start, this whilst
using the i686 live cd.

I will try the xdriver=vesa to see if it helps in this case.
Comment 4 my_linux 2008-04-23 01:07:23 EDT
Just to confirm xdriver=vesa also works for i686 live cd.
Comment 5 Matěj Cepl 2008-04-23 12:48:25 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log or /tmp/X* in case of
failure during installation) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Richard West 2008-04-23 13:16:16 EDT
I'm not sure how I can provide such a log, since as mentioned, the installer
hangs with a blank screen upon loading X. It won't respond to attempts to switch
to another terminal.
Comment 7 Matěj Cepl 2008-04-24 13:43:37 EDT
OK, that's bad. Could you install in the text mode and then try startx from the
runlevel 3? /var/log/Xorg.0.log would be very useful for us.
Comment 8 Richard West 2008-04-24 15:01:23 EDT
As I mentioned originally, running "startx" after installing in text mode
doesn't display the problem, and Gnome loads as expected. However, selecting
"configure x" from the setup tool does seem to display the same problem, with a
blank screen resulting, and no response to trying to change terminal.

I'm therefore going to attach Xorg.0.log (the result of running startx, where
things load normally) and Xorg.setup.log (where the problem is exhibited).
Hopefully this will be of some help.
Comment 9 Richard West 2008-04-24 15:02:11 EDT
Created attachment 303673 [details]
Log of successful start
Comment 10 Richard West 2008-04-24 15:03:39 EDT
Created attachment 303674 [details]
Setup log where problem seems to be displayed

This log is only 16 lines long, it seems to stop recording fairly early in the
process, I assume as a result of the issue.
Comment 11 Bug Zapper 2008-05-14 05:47:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 George Gibbs 2008-05-14 16:08:20 EDT
I'm having the same issue with an Asus P5K-Deluxe (Same chipset as creator),
8800GTX and a 24" 1920x1200 Dell monitor.
Comment 13 Richard West 2008-05-14 17:20:38 EDT
I've installed the release version of F9 and the issue still exists for me i.e.
text mode or VESA driver is required to proceed with installer, but Gnome loads
fine after installing in text mode and using the "startx" command.
Comment 14 George Gibbs 2008-05-14 17:26:47 EDT
Can you confirm whether or not it uses the nvidia blob once installed? I'm
trying to decide if it's worth installing as I'm trying some other distros, but
if I have to use VESA to get it to work I think I'll wait on it. I don't mind a
text mode installer but I want nvidia's binary driver once the installation is done.
Comment 15 Richard West 2008-05-14 18:39:41 EDT
It uses the NV driver once installed, it just seems to be an installer issue. I
would expect that it will work fine with the Nvidia binary drivers as well, but
I haven't tried them since there aren't non-testing drivers that are compatible
with F9's version of X yet as far as I know.
Comment 16 c.h. 2008-05-18 20:55:33 EDT
I installed Fedora 9 with no video related problems on a system with
8800GT-512MB card, and an old 15" LCD monitor whose maximum capability is
1024x768 and analog VGA input.

Once the system was installed and updated fully online I relocated it to my desk
with a 24" DELL 2405FPW LCD (which has a native 1900x1200 resolution) connected
via a DVI-to-VGA adapter which is connected to the uppermost DVI/VGA port (near
the card bracket screw) position.

I have been unable to get X started with the nv driver at any resolution I've
tried, including various lower resolutions like 1024x768.  I just get a black
screen when I "init 5".  
e.g. these did not help even when I did a cycle of init 3 / init 5 to restart X.
system-config-display --set-resolution="1280x1024"
system-config-display --set-resolution="1600x1200"


When I did this:
system-config-display  --set-driver=vesa
to switch /etc/X11/xorg.conf to the vesa driver instead of the nv driver, I am
able to "init 5" and use the default gdm + gnome + graphical environment.
I am now posting in 1600x1200xMillions of colors with the Vesa driver selected
on the same 8800GT and with the same DVI -> DVI to VGA -> DELL 2405FPW connected
as fails to work with the nv driver.

There is a known ABI incompatibility with the beta X-Org server used in Fedora 9
and the "full" NVIDIA closed source blob driver:
q.v.
http://www.nvnews.net/vbulletin/showthread.php?s=d6ea2cc9c98b447e3fbecda94f01a139&t=107725

FYI:
...apparently you have to recompile GDM to get it to pass the ignore ABI switch
to get it to work better or revert to the Fedora 8's Xorg which is a supported
version for the most recent LINUX closed source driver.  Although no official
source has suggested this, I suspect within about 10 days we'll see an updated
closed source LINUX driver version release from NVIDIA which is likely to
support Fedora 9's beta Xorg ABI; I base this aspiration on their monthly
history of releasing LINUX blob drivers around the 3rd week of the month, and on
a forum comment by a NVIDIA staff person indicating that they planned to support
the "beta" ABI in an upcoming driver because X-Org has promised that the ABI
will not change between now and the final Xorg release.

That all being said, I'm still surprised / dissapointed / confused that the open
source Fedora 9 default *NV* driver doesn't work better on the G92 8800GTs (and
maybe other cards) since clearly it would likely have been compiled to support
the F9 distribution's Xorg release + API, so I presume this is some new kind of
bug / problem unrelated to NVIDIA's blob driver XORG support issues.

Comment 17 c.h. 2008-05-21 03:58:41 EDT
I'm having comparable problems with the anaconda installer using the Fedora 9
X64 release DVD.  It asks for my language, keyboard layout, whether to test the
install disc media, then proceeds to tell me it is starting X; the following
messages are correctly displayed: 
Running anaconda...
Probing for video card: 8800GTX ... G80 ... it identifies the card correctly.
Waiting for X server to start....

After that I get a blank screen which I'm not able to usefully do anything at
except CTRL-ALT-DELETE to reboot.   As far as I can tell, C-A-Fn doesn't do any
useful console / text mode switching; C-A-BS doesn't do anything useful; C-A--
or C-A-+ doesn't do anything useful either.

I have a setup roughly similar to the original bug submitter and Mr. Gibbs in
Comment #12 -- my setup is:

P5K DELUXE,
XFX 8800GTX,
DELL 2405FPW 24" Dell Monitor on DVI #1,
PRO-458 analog 1024x768 15" vga monitor on VGA #2 through the DVI->VGA dongle,
8GB RAM.

Soft-Powering off the Dell LCD (leaving it connected), and powering on the
PRO-458 1024x768 monitor doesn't seem to help the system present a usable video
mode.  I've soft and cold power-cycled the system and the monitors a couple of
times without any difference in the manifestation of the bug.

Yesterday I submitted this bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=447239
concerning a different system (ABIT IP35-E / 8800GT-512) which had occasional
but not perpetual "nv" driver problems with the same Monitors used here.

If I add the kernel boot line agruments:
xdriver=vesa
I am able to get into anaconda / X and see useful video on the DELL 24" DVI monitor.

Comment 18 Richard West 2008-05-21 10:28:48 EDT
I'm also using a Dell 2405FPW monitor, which could be significant since most of
the people reporting this problem seem to have a similar setup (this monitor,
nVidia 8800 series card, similar motherboard chipset).
Comment 19 marian 2008-09-06 06:33:31 EDT
I have same problem preventing upgrade to 9, this is with two different MB's one gigabyte AMD the other asus Intel, both with x86_64. The problem I see is the video driver, I have an 8800gts 640mb used in both trials and always produces a blank screen. I will wait until the drivers are stable and working before trashing my system.
Comment 20 Bug Zapper 2009-06-09 20:18:44 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Bug Zapper 2009-07-14 13:37:03 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.