Bug 447239 - 8800GT / NV driver / 24" LCD panel gives black screen; "vesa" driver works.
8800GT / NV driver / 24" LCD panel gives black screen; "vesa" driver works.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 21:21 EDT by c.h.
Modified: 2008-12-16 15:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 15:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
nv driver selected PRO-458 15" LCD connected Xorg.1.log (24.80 KB, text/plain)
2008-05-18 21:47 EDT, c.h.
no flags Details
Xorg.0.log "vesa" driver with DELL 2405FPW screen (works) (43.50 KB, text/plain)
2008-05-18 21:49 EDT, c.h.
no flags Details
Xorg.0.log for Functional setup NV driver, DELL2405FPW on VGA1 / PRO-458 on VGA2 / 1024x768 on both. (56.69 KB, text/plain)
2008-05-18 22:28 EDT, c.h.
no flags Details
xorg.conf for Functional setup NV driver, DELL2405FPW on VGA1 / PRO-458 on VGA2 / 1024x768 on both. (611 bytes, text/plain)
2008-05-18 22:30 EDT, c.h.
no flags Details
Xorg.0.log for Functional setup NV driver, DELL2405FPW on VGA1 1920x1200 (48.40 KB, text/plain)
2008-05-18 22:47 EDT, c.h.
no flags Details

  None (edit)
Description c.h. 2008-05-18 21:21:20 EDT
Description of problem:

X fails to work with NV driver using an 8800GT-512 card and DELL 2405FPW 24"
1900x1200 native resolution monitor.

Version-Release number of selected component (if applicable):

xorg-x11-drv-nv-2.1.8-1.fc9.x86_64

How reproducible:

100% so far, will keep checking further to see if it depends on the monitor
model, resolution selected, or VGA connection port.

resolution
Steps to Reproduce:
1. Install F9, Install all available online updates as of 2008-05-17.
2. Connect 2405FPW monitor through DVI->VGA dongle.
3. Boot into runmode 3, then try to boot into graphical login run mode 5 with
"nv" driver selected.
  
Actual results:

Black scren under "nv" driver, correct function when "vesa" driver is selected
instead.

Expected results:


Additional info:

I installed Fedora 9 with no video related problems on a system with
8800GT-512MB card, and an old 15" LCD monitor whose maximum capability is
1024x768 and analog VGA input.

Once the system was installed and updated fully online I relocated it to my desk
with a 24" DELL 2405FPW LCD (which has a native 1900x1200 resolution) connected
via a DVI-to-VGA adapter which is connected to the uppermost DVI/VGA port (near
the card bracket screw) position.

I have been unable to get X started with the nv driver at any resolution I've
tried, including various lower resolutions like 1024x768.  I just get a black
screen when I "init 5".  
e.g. these did not help even when I did a cycle of init 3 / init 5 to restart X.
system-config-display --set-resolution="1280x1024"
system-config-display --set-resolution="1600x1200"


When I did this:
system-config-display  --set-driver=vesa
to switch /etc/X11/xorg.conf to the vesa driver instead of the nv driver, I am
able to "init 5" and use the default gdm + gnome + graphical environment.
I am now posting in 1600x1200xMillions of colors with the Vesa driver selected
on the same 8800GT and with the same DVI -> DVI to VGA -> DELL 2405FPW connected
as fails to work with the nv driver.

I don't know why I didn't have rhgb/anaconda/GDM/X/GNOME problems when I
installed using the same system/video card but the 15" 1024x768 monitor; I'll
bring that around and see if I can still use that with the nv driver or not.
If it is monitor / resolution dependent then maybe it relates to some of the
bugs about resolution / mode processing.  On the other hand I did try selecting
1024x768 so it can't be just a problem with the default/probed modes for the
2405FPW.

No (!!) or (EE) or other obviously related errors were seen on first glance
through Xorg log / GDM log / var/log/messages, /var/log/dmesg.

I've been reading other submitted bug reports; I'm not positive as to whether
some others may be tangentially related to this, though if there's a bug in NV I
suppose it is possible they're related to the same root cause even if their
manifestation circumstances / symptoms / hypotheses differ:
https://bugzilla.redhat.com/show_bug.cgi?id=439053
https://bugzilla.redhat.com/show_bug.cgi?id=442296
https://bugzilla.redhat.com/show_bug.cgi?id=443318
https://bugzilla.redhat.com/show_bug.cgi?id=444276
https://bugzilla.redhat.com/show_bug.cgi?id=445556
https://bugzilla.redhat.com/show_bug.cgi?id=446458
https://bugzilla.redhat.com/show_bug.cgi?id=234824
https://bugzilla.redhat.com/show_bug.cgi?id=447101


FYI:
There is a known ABI incompatibility with the beta X-Org server used in Fedora 9
and the "full" NVIDIA closed source blob driver:
q.v.
http://www.nvnews.net/vbulletin/showthread.php?s=d6ea2cc9c98b447e3fbecda94f01a139&t=107725


...apparently you have to recompile GDM to get it to pass the ignore ABI switch
to get it to work better or revert to the Fedora 8's Xorg which is a supported
version for the most recent LINUX closed source driver.  Although no official
source has suggested this, I suspect within about 10 days we'll see an updated
closed source LINUX driver version release from NVIDIA which is likely to
support Fedora 9's beta Xorg ABI; I base this aspiration on their monthly
history of releasing LINUX blob drivers around the 3rd week of the month, and on
a forum comment by a NVIDIA staff person indicating that they planned to support
the "beta" ABI in an upcoming driver because X-Org has promised that the ABI
will not change between now and the final Xorg release.

That all being said, I'm still surprised / dissapointed / confused that the open
source Fedora 9 default *NV* driver doesn't work better on the G92 8800GTs (and
maybe other cards) since clearly it would likely have been compiled to support
the F9 distribution's Xorg release + API, so I presume this is some new kind of
bug / problem unrelated to NVIDIA's blob driver XORG support issues.
Comment 1 c.h. 2008-05-18 21:47:13 EDT
Created attachment 305886 [details]
nv driver selected PRO-458 15" LCD connected Xorg.1.log
Comment 2 c.h. 2008-05-18 21:49:38 EDT
Created attachment 305887 [details]
Xorg.0.log "vesa" driver with DELL 2405FPW screen (works)
Comment 3 c.h. 2008-05-18 22:28:49 EDT
Created attachment 305888 [details]
Xorg.0.log for Functional setup NV driver, DELL2405FPW on VGA1 / PRO-458 on VGA2 / 1024x768 on both.

Xorg.0.log for Functional setup NV driver, DELL2405FPW on VGA1 / PRO-458 on
VGA2 / 1024x768 on both.
Comment 4 c.h. 2008-05-18 22:30:07 EDT
Created attachment 305889 [details]
xorg.conf  for Functional setup NV driver, DELL2405FPW on VGA1 / PRO-458 on VGA2 / 1024x768 on both.

xorg.conf for Functional setup NV driver, DELL2405FPW on VGA1 / PRO-458 on VGA2
/ 1024x768 on both.
Comment 5 c.h. 2008-05-18 22:47:00 EDT
Created attachment 305890 [details]
Xorg.0.log for Functional setup NV driver, DELL2405FPW on VGA1  1920x1200

Xorg.0.log for Functional setup NV driver, DELL2405FPW on VGA1	1920x1200

I unplugged the PRO-458 monitor from VGA2 and the DELL 2405FPW 24" screen
started working at 1920x1200 now.

There is a DVI->VGA connector on the VGA2 port, but no monitor connected.
That's the only hardware difference between the present time and the times when
the VGA1 DELL was giving a black screen starting X with the nv driver but the
vesa driver worked with it correctly.

Perhaps some software state changed between the non-functional and functional
periods, but if so it was nothing that I directly know of.

Here's the current (working) xorg.conf too:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen	    0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver	    "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver	    "nv"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device	   "Videocard0"
	DefaultDepth	 24
	SubSection "Display"
		Viewport   0 0
		Depth	  24
	EndSubSection
EndSection
Comment 6 Adam Jackson 2008-05-19 11:05:44 EDT
It looks like the server's allowing a reduced-blanking mode through that it
shouldn't.  Apparently the RANDR 1.2 mode validation code doesn't check for that
case at all.  Le sigh.
Comment 7 Adam Jackson 2008-12-16 15:55:44 EST
Fixed in Fedora 10.

Note You need to log in before you can comment on or make changes to this bug.