Bug 443355 - Merge Review: gnumeric
Merge Review: gnumeric
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 23:12 EDT by Huzaifa S. Sidhpurwala
Modified: 2008-09-02 23:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 23:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dev: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2008-04-20 23:12:41 EDT
Fedora Merge Review: gnumeric

http://cvs.fedoraproject.org/viewcvs/rpms/gnumeric/
Initial Owner: j.w.r.degoede@hhs.nl
Comment 1 Nigel Jones 2008-04-20 23:54:18 EDT
rpmlint...

[njones@node ~]$ rpmlint gnumeric-*
gnumeric.x86_64: W: non-conffile-in-etc /etc/gconf/schemas/gnumeric-dialogs.schemas
gnumeric.x86_64: W: hidden-file-or-dir /usr/share/gnumeric/1.8.2/autoformat-
templates/Colourful/.category
gnumeric.x86_64: W: hidden-file-or-dir /usr/share/gnumeric/1.8.2/autoformat-
templates/Classical/.category
gnumeric.x86_64: W: hidden-file-or-dir /usr/share/gnumeric/1.8.2/autoformat-
templates/3D/.category
gnumeric.x86_64: W: non-conffile-in-etc /etc/gconf/schemas/gnumeric-plugins.schemas
gnumeric.x86_64: E: script-without-shebang /usr/lib64/gnumeric/1.8.2/plugins/py-func/py_func.py
gnumeric.x86_64: W: hidden-file-or-dir /usr/share/gnumeric/1.8.2/autoformat-
templates/General/.category
gnumeric.x86_64: W: hidden-file-or-dir /usr/share/gnumeric/1.8.2/autoformat-
templates/Financial/.category
gnumeric.x86_64: W: non-conffile-in-etc /etc/gconf/schemas/gnumeric-general.schemas
gnumeric.x86_64: W: hidden-file-or-dir /usr/share/gnumeric/1.8.2/autoformat-
templates/List/.category
gnumeric.x86_64: E: script-without-shebang /usr/lib64/gnumeric/1.8.2/plugins/gnome-
glossary/gnome_glossary.py
gnumeric-devel.x86_64: W: no-documentation
gnumeric-devel.x86_64: E: only-non-binary-in-usr-lib
gnumeric-plugins-extras.x86_64: W: no-documentation

All warnings seem reasonable...
script-without-shebang - these are two plugins, for gnumeric which i'm 99.9% sure are not meant to 
be invoked at CLI (you could put a shebang in there and make it fail on run from console, but I'm not 
concerned about this).
only-non-binary-in-usr-lib - (There are only non binary files in /usr/lib so they should be in 
/usr/share.) there is a .so file in /usr/lib which seems okay. .pc files belong there too but the .h I'm not 
so sure about....

Per https://fedoraproject.org/wiki/Packaging/ReviewGuidelines everything else looks fine I just want to 
check the .h file before I give the a-okay...
Comment 2 Nigel Jones 2008-04-21 00:26:32 EDT
Package Review
==============

Key:
 - = N/A
 x = Check
 ! = Problem
 ? = Not evaluated

=== REQUIRED ITEMS ===
 [x] Package is named according to the Package Naming Guidelines.
 [x] Spec file name must match the base package %{name}, in the format %{name}.spec.
 [x] Package meets the Packaging Guidelines.
 [x] Package successfully compiles and builds into binary rpms on at least one
supported architecture.
     Tested on: devel/* (koji)
 [x] Rpmlint output:
source RPM: empty
binary RPM: see Comment 1
 [x] Package is not relocatable.
 [x] Buildroot is correct
(%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n))
 [x] Package is licensed with an open-source compatible license and meets other
legal requirements as defined in the legal section of Packaging Guidelines.
 [x] License field in the package spec file matches the actual license.
     License type: GPLv2
 [x] If (and only if) the source package includes the text of the license(s) in
its own file, then that file, containing the text of the license(s) for the
package is included in %doc.
 [x] Spec file is legible and written in American English.
 [x] Sources used to build the package matches the upstream source, as provided
in the spec URL.
     SHA1SUM of package: 1708da12f206fea1dda5c5341dfdd3eb2d1913dd gnumeric-1.8.2.tar.bz2
 [x] Package is not known to require ExcludeArch
 [x] All build dependencies are listed in BuildRequires, except for any that are
listed in the exceptions section of Packaging Guidelines.
 [-] The spec file handles locales properly.
 [x] ldconfig called in %post and %postun if required.
 [x] Package must own all directories that it creates.
 [x] Package requires other packages for directories it uses.
 [x] Package does not contain duplicates in %files.
 [x] Permissions on files are set properly.
 [x] Package has a %clean section, which contains rm -rf %{buildroot} (or
$RPM_BUILD_ROOT).
 [x] Package consistently uses macros.
 [x] Package contains code, or permissable content.
 [-] Large documentation files are in a -doc subpackage, if required.
 [x] Package uses nothing in %doc for runtime.
 [x] Header files in -devel subpackage, if present.
 [-] Static libraries in -devel subpackage, if present.
 [x] Package requires pkgconfig, if .pc files are present.
 [x] Development .so files in -devel subpackage, if present.
 [x] Fully versioned dependency in subpackages, if present.
 [x] Package does not contain any libtool archives (.la).
 [x] Package contains a properly installed %{name}.desktop file if it is a GUI
application.
 [x] Package does not own files or directories owned by other packages.


=== Issues ===
Help->Contents doesn't work, mainly due to yelp not been provided somewhere along the lines...  This 
is imo a problem higher up the chain and I'm not going to require you add the dependency... 
Personally, I'd sooner see the discussion reported at http://fedoraproject.org/wiki/FWN/Issue92#head-
c93cd512fdf8e965869b3db1ff4bc7e152ef26ea restarted and yelp provided somewhere around 
gnome-libs or something (think of the poor users who want help playing tetris!)

================
*** APPROVED ***
================
Comment 3 Nigel Jones 2008-06-03 02:35:52 EDT
Do we still need this open (just checking)?
Comment 4 Huzaifa S. Sidhpurwala 2008-09-02 23:55:22 EDT
No, thanx.

Note You need to log in before you can comment on or make changes to this bug.