Bug 443447 - Compiz-Fusion launches White Screen (of death?)
Compiz-Fusion launches White Screen (of death?)
Status: CLOSED DUPLICATE of bug 444977
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 12:19 EDT by Juan Manuel Rodriguez
Modified: 2008-05-12 17:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 05:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
intel Xorg.0.log after starting and then stopping compiz (23.57 KB, text/plain)
2008-05-06 19:59 EDT, Andrew Farris
no flags Details

  None (edit)
Description Juan Manuel Rodriguez 2008-04-21 12:19:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041301 Fedora/3.0-0.54.beta5.fc9 Firefox/3.0b5

Description of problem:
I installed Compiz-Fusion, launching it with compiz-manager creates a white screen. I have to Ctrl-C to get my computer back working. 

It worked fine under Fedora 8 - Werewolf, so I know its not my graphics card (though it might be the driver?). 

Compiz by itself (launched from Desktop Effects) does let my windows wobble, and doesn't send me a white screen. 

Version-Release number of selected component (if applicable):
compiz-fusion-0.7.2-2.fc9.i386 

How reproducible:
Always


Steps to Reproduce:
1. Install compiz-fusion and compiz-manager
2. launch compiz-manager
3. WSOD

Actual Results:
White Screen of Death

Expected Results:
Wobbly Windows, Window Previews, Fire on screen!

Additional info:
Here's the output its showing: 
[John@fedella ~]$ compiz-manager
Checking for Xgl: not present. 
Detected PCI ID for VGA: 00:02.0 0300: 8086:27a2 (rev 03) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present. 
Checking for non power of two support: present. 
Checking for Composite extension: present. 
Failed to initialize TTM buffer manager.  Falling back to classic.
Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present. 
Checking for FBConfig: Failed to initialize TTM buffer manager.  Falling back to classic.
present. 
Checking for Xgl: not present. 
Starting gtk-window-decorator
Failed to initialize TTM buffer manager.  Falling back to classic.
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
^CAttempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Comment 1 Matěj Cepl 2008-05-02 10:45:17 EDT
When you restart Xorg with plain compiz, does it work?
Comment 2 Matěj Cepl 2008-05-02 11:07:00 EDT
Bugs which may be related are bug 444977 and bug 239332.
Comment 3 Andrew Farris 2008-05-06 19:57:01 EDT
$-> compiz --replace
Failed to initialize TTM buffer manager.  Falling back to classic.
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
	^C

Using compiz on intel for the basic wobbly windows results in completely white
screen, the mouse cursor is still movable and changes from text insert bar to
pointer when crossing terminal windows.  X is still working and when compiz is
killed metacity can be started just fine.

This is from my Apple Macbook 2,1 (blackbook core 2 duo).

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA
controller])
	Subsystem: Intel Corporation Unknown device 7270
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at 90380000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at 20e0 [size=8]
	Memory at 80000000 (32-bit, prefetchable) [size=256M]
	Memory at 90400000 (32-bit, non-prefetchable) [size=256K]
	Capabilities: <access denied>
	Kernel modules: intelfb, i915
Comment 4 Andrew Farris 2008-05-06 19:59:44 EDT
Created attachment 304702 [details]
intel Xorg.0.log after starting and then stopping compiz
Comment 5 Andrew Farris 2008-05-06 20:02:31 EDT
This happens with both compiz in rawhide as well as built from upstream compiz
in the fusion repo lordmorgul.net/pub/compiz/fusion/
Comment 6 Matěj Cepl 2008-05-07 05:47:41 EDT

*** This bug has been marked as a duplicate of 239332 ***
Comment 7 Matěj Cepl 2008-05-12 17:28:44 EDT

*** This bug has been marked as a duplicate of 444977 ***

Note You need to log in before you can comment on or make changes to this bug.