Bug 444977 - White screen on restart of Xorg with compiz activate
White screen on restart of Xorg with compiz activate
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
: 443447 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 11:04 EDT by Matěj Cepl
Modified: 2009-10-22 08:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:39:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (138.83 KB, text/plain)
2008-05-02 11:04 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-05-02 11:04:04 EDT
Description of problem:
When having compiz on for some time (hour or so) I get completely white screen.
Restarting Xorg nor even rebooting of the computer helped. I had to blindly run
desktop-effects and switch off compiz.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-23.fc9.i386
xorg-x11-server-Xorg-1.4.99.901-26.20080415.fc9.i386
compiz-0.7.2-3.fc9.i386

How reproducible:
Happened once and then happend even after restart of Xorg, and then happened
again after reboot
Comment 1 Matěj Cepl 2008-05-02 11:04:04 EDT
Created attachment 304390 [details]
/var/log/Xorg.0.log
Comment 2 Matěj Cepl 2008-05-02 11:05:52 EDT
Bugs which may be related are bug 443447 and bug 239332.
Comment 3 Matěj Cepl 2008-05-02 11:07:51 EDT
The attachment in comment 1 contains a register dump and looks suspiciously.
Comment 4 Matěj Cepl 2008-05-07 05:47:31 EDT

*** This bug has been marked as a duplicate of 239332 ***
Comment 5 Matěj Cepl 2008-05-12 17:28:45 EDT
*** Bug 443447 has been marked as a duplicate of this bug. ***
Comment 6 Matěj Cepl 2008-05-12 17:30:49 EDT
This was too eager de-duplication -- bug 239332 is about multi-head, where this
and bug 443447 are single-head.
Comment 7 Bug Zapper 2008-05-14 06:31:12 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jacob Masaki 2008-05-15 19:00:49 EDT
I have the same problem using the "intel" driver instead of the "i810"
driver(that is what the line in xorg.conf says.)  

Compiz 0.7.2 turns everything white.  

However, installing the compiz from Fedora 8 (where compiz worked) fixes the
problem.  

So, something which changed between 0.6.2 and 0.7.2 which breaks compiz on the
Intel GMA 965.  

I have had similar problems with newer versions of WINE (that is, the old
version works, but a newer one does not).  

This leads me to suspect that the problem is not with compiz, but is with the
version of the intel driver (or with mesa) which ships with Fedora.  

https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/120834 There is mention of a
bug in mesa here that was fixed upstream, and this appears to be a bug with the
same root problem.  

For now, though, downgrading to the Fedora 8 compiz *is* a viable workaround.  
Comment 9 Scott Williams 2009-03-10 23:52:14 EDT
I'm seeing the same problem on a radeon 7500.  Worked fine in Fedora 9.  It appears that DRI is broke for it in Fedora 10.  I can add Virtual 1024 768 and it will work.
Comment 10 Bug Zapper 2009-06-09 20:34:09 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-07-14 13:39:05 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.