Bug 443597 - Fontset isn't applied to the face
Fontset isn't applied to the face
Status: CLOSED DUPLICATE of bug 443639
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 09:49 EDT by Akira TAGOH
Modified: 2008-04-22 13:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 13:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2008-04-22 09:49:41 EDT
Description of problem:
creating a fontset by create-fontset-from-fontset-spec and do set-face-font with
it worked fine on 22.x but it doesn't on 23.

Version-Release number of selected component (if applicable):
emacs-23.0.60-2.fc9

How reproducible:
always

Steps to Reproduce:
1.evaluate the following elisp
(create-fontset-from-fontset-spec
  "-default-foobarbaz-medium-r-*--14-*-*-*-*-*-fontset-14,
   ascii:-*-liberation mono-medium-r-*--14-*-*-*-*-*-iso8859-1,
   japanese-jisx0208:-*-vl gothic-medium-r-*--14-*-*-*-*-*-jisx0208.1990-*")
2.see the fontset with describe-fontset if the fontset was created properly
3.evaluate (set-face-font 'default
"-default-foobarbaz-medium-r-*--14-*-*-*-*-*-fontset-14")
  
Actual results:
which font is set to the face really depends on your locale. Family in the
result of (describe-face 'default) should be something what you can see with
fc-match.

Expected results:
-default-foobarbaz-medium-r-*--14-*-*-*-*-*-fontset-14 should be applied to the
face.

Additional info:
Comment 1 Akira TAGOH 2008-04-22 09:54:14 EDT
BTW --disable-font-backend doesn't help. that makes another error, "Invalid font
or fontset name". again, this worked fine on emacs 22.x.
Comment 2 Chip Coldwell 2008-04-22 13:12:32 EDT

*** This bug has been marked as a duplicate of 443639 ***

Note You need to log in before you can comment on or make changes to this bug.