Bug 443639 - emacs-23 is not ready for prime time
emacs-23 is not ready for prime time
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
urgent Severity high
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
: 441233 443542 443550 443597 443849 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-22 13:09 EDT by Chip Coldwell
Modified: 2013-01-09 23:40 EST (History)
12 users (show)

See Also:
Fixed In Version: F9 GA
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 17:25:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chip Coldwell 2008-04-22 13:09:39 EDT
Description of problem:

Emacs-23 is not ready for prime time in F-9, so we're going to back it out in
favor of 22.2.  My bad, and I apologize for the churn.

Chip
Comment 1 Chip Coldwell 2008-04-22 13:10:36 EDT
*** Bug 443550 has been marked as a duplicate of this bug. ***
Comment 2 Chip Coldwell 2008-04-22 13:11:51 EDT
*** Bug 443542 has been marked as a duplicate of this bug. ***
Comment 3 Chip Coldwell 2008-04-22 13:12:14 EDT
*** Bug 443549 has been marked as a duplicate of this bug. ***
Comment 4 Chip Coldwell 2008-04-22 13:12:33 EDT
*** Bug 443597 has been marked as a duplicate of this bug. ***
Comment 5 Chip Coldwell 2008-04-22 13:15:31 EDT
*** Bug 441233 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Underwood 2008-04-22 17:38:13 EDT
Ah, crap. You might wanna mention this on fedora-devel because this is going to
break all add-on packages (that are guideline compliant) built against 23.x, as
they will have automatically have  Requires: emacs(bin) >= 23.0.60, and so
they'll need a rebuild when 22.2 hits F-9.
Comment 7 Pawel Salek 2008-04-22 17:50:35 EDT
I think only #443550 appears to be serious - but I cannot reproduce it myself.
The remaining ones can hopefully be fixed. For example, #443549 has a workaround
present. I am not sure what #443597 is about because I did not get any
surprising behaviour myself.
Comment 8 Chip Coldwell 2008-04-23 15:00:05 EDT
*** Bug 443849 has been marked as a duplicate of this bug. ***
Comment 9 Chip Coldwell 2008-04-23 15:01:28 EDT
(In reply to comment #6)
> Ah, crap. You might wanna mention this on fedora-devel because this is going to
> break all add-on packages (that are guideline compliant) built against 23.x, as
> they will have automatically have  Requires: emacs(bin) >= 23.0.60, and so
> they'll need a rebuild when 22.2 hits F-9.

I'll chat with release engineering and see if we can sort this out.  Thanks for
the heads-up.

Chip
Comment 10 Chip Coldwell 2008-04-23 15:16:53 EDT
(In reply to comment #6)
> Ah, crap. You might wanna mention this on fedora-devel because this is going to
> break all add-on packages (that are guideline compliant) built against 23.x, as
> they will have automatically have  Requires: emacs(bin) >= 23.0.60, and so
> they'll need a rebuild when 22.2 hits F-9.

Bill Nottingham informs me: "I don't see anything with this sort of requires in
the current F9 repo."

Emacs-23 hit the repo very recently (too late to really be fully baked), so
there may not have been any rebuilds of add-on packages yet.

Chip
Comment 11 Jesse Keating 2008-04-23 15:18:59 EDT
I'm pretty sure you're safe.  We'll watch closely but we have a week to catch
anything.
Comment 12 Jonathan Underwood 2008-04-23 17:05:34 EDT
OK, splendid. Sorry for the noise.
Comment 13 Dennis Gilmore 2008-04-24 12:39:39 EDT
You need to add an Epoch to emacs otherwise people wont get  downgraded.
Comment 14 Dennis Gilmore 2008-04-24 12:50:00 EDT
There is also a patch thats not applied.  i have a patch to enable building on
sparc64.  I can fix all the issues at once if you like.
Comment 15 Bill Nottingham 2008-04-24 13:48:21 EDT
The following packages have some sort of versioned emacs dep:
	emacs-a2ps-0:4.13b-71.fc9.x86_64
	emacs-gnuplot-0:4.2.2-10.fc9.x86_64
	emacs-tuareg-0:1.45.6-4.fc9.noarch
	migemo-emacs-0:0.40-9.fc7.noarch
	emacs-lua-0:20071122-5.fc9.noarch
	emacs-ess-0:5.3.6-2.fc9.noarch
	emacs-cdargs-0:1.35-2.fc9.x86_64
	tmda-emacs-0:1.1.12-1.fc8.noarch
	emacs-vm-0:8.0.9.544-1.fc9.x86_64
	emacs-auctex-0:11.85-7.fc9.noarch
	emacs-muse-0:3.12-1.fc9.noarch
	emacs-bbdb-0:2.35-8.fc8.noarch

Theoretically, adding the epoch to the 'Version' field of the emacs-el pkgconfig
file and rebuilding will pick this up, unless the package is hardcoding the
version. Of course, as long as nothing has a requires on emacs 23, they will
'work' in F9 without adding the epoch to their dependency.
Comment 16 Dennis Gilmore 2008-04-24 16:27:24 EDT
FESCo voted today to have normal packaging guidelines put in place.  Which means
that we need to have an Epoch in Emacs.  we release emacs 23,  so we need to
make sure upgrade paths are handled correctly.  Please ensure that the epoch is
added.
Comment 17 Will Woods 2008-04-28 18:51:09 EDT
Epoch has been added to emacs.spec and fixed packages have been built, but not
yet tagged or signed.
Comment 18 Bill Nottingham 2008-04-30 14:33:50 EDT
The packages did not address comment #15.
Comment 19 Adam Goode 2008-04-30 20:46:47 EDT
Also, the packages do not seem to be installable because of

 Requires: emacs-common = %{version}-%{release}

Forgetting %{epoch} !
Comment 20 Jonathan Underwood 2008-05-01 05:43:45 EDT
Yes, actually that's a deficiency in the emacs add-on packaging guidelines (mea
culpa). Ones the build of emacs 22 is in the repos, I think the course of
actions needs to be:

1) File bugs against the uninstallable emacs packages asking for them to be
rebuild, adding something like 
Requires: emacs(bin) = %{epoch}:%{version}-%{release}
to the spec file

2) Emacs add-on package guidelines updating.
Comment 21 Bill Nottingham 2008-05-01 09:36:26 EDT
Jonathan - if the epoch is embedded in the pkg-config file, add-ons shouldn't
need to change their specs.
Comment 22 Bill Nottingham 2008-05-02 10:44:03 EDT
This should be fixed with 22.2-4.fc9
Comment 23 Will Woods 2008-05-09 17:25:00 EDT
I can't seem to find any problems with current emacs packaging. Closing.

Note You need to log in before you can comment on or make changes to this bug.