Bug 443635 - PXE install failing at "Starting VNC..."
PXE install failing at "Starting VNC..."
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: 444430 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
Reported: 2008-04-22 12:30 EDT by eric magaoay
Modified: 2013-04-30 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-25 07:09:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description eric magaoay 2008-04-22 12:30:35 EDT
Description of problem:
The latest build (4/22/08) terminating PXE install after "Starting VNC..." 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Prepare PXE install using following kickstart config. sample (f4d1)
      vnc --password install
      url --url
      network --device eth1 --bootproto dhcp --hostname mazatlan1
      lang en_US
      keyboard us
      rootpw install
      timezone  America/New_York
   Sample command line use:
      label f64d
        kernel /fed/dev/x86_64/os/isolinux/vmlinuz
        append initrd=/fed/dev/x86_64/os/isolinux/initrd.img ksdevice=eth0
Actual results:
Imediately after "Starting VNC..." it output the following error
   install exited abnormally [1/11]
   sending termination signals...done

Expected results:
should proceed without problem.

Additional info:
Using 2 network interface cards (NIC) having separate live network, DHCPs.
Comment 1 Jeremy Katz 2008-04-22 15:40:57 EDT
Does it fail if you don't specify the password?
Comment 2 eric magaoay 2008-04-23 13:05:27 EDT
Yes same problem without a password. It didn't matter whether to place "vnc" on
the command line or kickstart file. I also tried it without relying on kickstart
file and simply invoke "vnc" on command line only. Same problem.
Comment 3 Jeremy Katz 2008-04-23 22:17:55 EDT
Will -- haven't you done some vnc installs?
Comment 4 Will Woods 2008-04-24 12:47:06 EDT
Huh! Yes, a couple of weeks ago I did. But I tried one with today's rawhide and
sure enough:

install exited abnormally [1/1]

syslog sez:
Xvnc[1422]: segfault at 33333333 ip 080a6ab1 sp bf9ca9f0 error 4 in

Comment 5 Ben Williams 2008-04-24 14:58:38 EDT
f9-PR install 
host running vncviewer --listen port 5500 open
boot off DVD, CD1 or boot.iso
at menu press esc
at the prompt linux vnc vncconnect=ip

get the following errors:
Comment 6 Jeremy Katz 2008-04-24 17:15:15 EDT
Xvnc is segfaulting when run from anaconda -- our command line is
  Xvnc :1 -nevershared -depth 16 -geometry 800x600 -br leTimeout=0 -auth
/dev/null  -once DisconnectClients=false desktop=foo SecurityTypes=None

although the simpler 'Xvnc :1' also sigsegvs.

And although I don't _entirely_ trust gdb here...

(gdb) bt
#0  __glXScreenInit (pGlxScreen=0xa20fed0, pScreen=0xa20b090)
    at glxscreens.c:305
#1  0x080a6159 in __glXMesaScreenProbe (pScreen=0xa20b090) at glxglcore.c:426
#2  0x080a58b2 in GlxExtensionInit () at glxext.c:305
#3  0x0832de5d in main (argc=15, argv=0xbfbf6044, envp=0xbfbf6084)
    at main.c:367

Comment 7 Adam Tkac 2008-04-25 07:09:09 EDT
Problem was in mesa package, vnc has to be rebuild against new one. Fixed in
Comment 8 Jeremy Katz 2008-04-28 09:57:08 EDT
*** Bug 444430 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.