Bug 443689 - Nautilus displays blank windows when browsing SMB
Nautilus displays blank windows when browsing SMB
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 17:05 EDT by William Lovaton
Modified: 2015-03-03 17:32 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 522494 None None None Never

  None (edit)
Description William Lovaton 2008-04-22 17:05:25 EDT
Description of problem:
Every time I try to browse an SMB server I get a blank window instead of a list
of shares.  If I know the share beforehand I can type smb://SERVER/SHARE and it
works.  But as a user I'm stuck if I don't know the name of the share.

Version-Release number of selected component (if applicable):
This is a Fedora 9 Preview Live USB system with the following packages:
nautilus-2.22.2-1.fc9.i386
gvfs-fuse-0.2.3-3.fc9.i386
gvfs-0.2.3-3.fc9.i386
gtk2-2.12.9-5.fc9.i386
samba-common-3.2.0-1.pre2.8.fc9.i386
samba-winbind-3.2.0-1.pre2.8.fc9.i386

How reproducible:
Try browsing an SMB server without specifying a share like this: "smb://server".
 You will get a blank window instead of a list of shares.
Comment 1 Bug Zapper 2008-05-14 05:58:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tomáš Bžatek 2008-05-14 08:53:56 EDT
Could you please confirm that firewall is disabled on your system or at least
allows incoming Samba traffic? The SMB protocol is based on sending broadcasts
to get list of available machines in the network and also to connect to them if
not reachable via usual resolver ways (hosts, dns).
Comment 3 William Lovaton 2008-05-15 09:59:20 EDT
I disabled ip6tables, iptables and changed SELinux to permissive mode but
nothing.  It still shows a blank page with "0 elements" in the status bar. 
Going directly to a share still works but I can't get a list of shares.

I don't think this is a firewall thing since Fedora 8 LiveUSB worked fine and I
didn't disabled the firewall back then.

Cheers.
Comment 4 William Lovaton 2008-08-06 09:18:57 EDT
Changing to rawhide since this is happening with a Fedora 10 Alpha LiveCD too.

In fact it is getting worse.  I can't even mount the share even if I specify the right URL: "smb://server/share".  This at least used to work with Fedora 9 but not anymore.

It seems the firewall is disabled and I changed SELinux to permissive mode but yet it didn't work.

Because of this problem I'm stuck with Fedora 8 at work, I can't upgrade to Fedora 9 and it seems I won't be able to upgrade to Fedora 10.

I hope this can be fixed soon.
Comment 5 Matthias Clasen 2008-09-16 21:23:06 EDT
Can you try again with gvfs 0.99.8 ? It has a number of smb-related fixes.
Comment 6 William Lovaton 2008-09-20 14:03:12 EDT
Hi, Unfortunately I don't have a Rawhide machine at work but I'll sure test the next beta version using a LiveCD as soon as it's released.

Thanks.
Comment 7 William Lovaton 2008-09-23 09:49:09 EDT
I decided to upgrade my personal laptop to Rawhide and bring it to my office.  Unfortunately this bug doesn't seem to be fixed.  The only thing that got fixed was http://bugzilla.gnome.org/show_bug.cgi?id=547597 because using Fedora 10 Alpha Live CD it got worse, it wouldn't even browse the known shares.

So, Rawhide is back to where Fedora 9 was: I can browse known shares if I know the name beforehand but I CAN'T get a list of available shares on a server.
Comment 8 Will Woods 2008-10-27 13:38:22 EDT
I can reproduce this on my home network. Firewall is definitely off, and avahi-discover lists the windows shares, so at least *some* form of server announcement is getting through.
Comment 9 Matthias Clasen 2008-10-28 11:21:08 EDT
Taking this off the blocker list. As comment 7 states things work about as well as they did in F9, so we didn't regress. We have another patch in the queue to improve the SMB situation, but it is too invasive to land at this point. It will go into testing after GA.
Comment 10 Charles R. Anderson 2008-11-13 13:38:33 EST
1. LiveCD doesn't have a firewall enabled.
2. The nf_conntrack_netbios_ns module should allow browsing to work even with the firewall enabled.  Make sure /etc/sysconfig/iptables-config has IPTABLES_MODULES="nf_conntrack_netbios_ns" specified.

But I agree that I've not had luck with browsing in Nautilus either.  In my case, though, I had assumed it was because the samba servers on my local LAN were using hidden shares (share$).
Comment 11 Bug Zapper 2008-11-25 21:13:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 oliver cubacub 2008-12-04 13:31:59 EST
(In reply to comment #11)
> This bug appears to have been reported against 'rawhide' during the Fedora 10
> development cycle.
> Changing version to '10'.
> 
> More information and reason for this action is here:
> http://fedoraproject.org/wiki/BugZappers/HouseKeeping

i'm running f10 and i can't still see the shares unlike in 8
if i put smb://host/share/c$ then i'll get the prompt and browse the share
but it'll mount the share
Comment 13 Fedora Update System 2008-12-05 10:03:30 EST
gvfs-1.0.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-2.fc10
Comment 14 Tomáš Bžatek 2008-12-05 10:34:23 EST
Please test the updated packages, read the notes posted in the link above and report any issues.
Comment 15 Adam Huffman 2008-12-05 11:16:50 EST
This doesn't resolve the problem of not seeing the contents of a share, for me.  I can connect, as I have been able to for a while, but the Nautilus window still shows '0 items'.

When I ran with the debug settings, it appears files and directories are being seen but they're still not visible.
Comment 16 oliver cubacub 2008-12-05 19:45:31 EST
updated to both gvfs-1.0.3-2.fc10 and nautilus-2.24.2-2.fc10
same experience
just as to mention it again.

when i click on the network icon i can see all the computers/servers in our domain
if i click one windows computer i don't see the c$ and it does prompt me for username and password
i don't see any and the count is 0
where as in the pass i'll see the c$ then just input my credentials and i'm it
(that's the beauty i love about fedora)
Comment 17 Charles R. Anderson 2008-12-05 19:49:54 EST
Historically, share names that end in $ are supposed to be "hidden".  Windows doesn't show hidden shares (at least it never used to, unless that has changed in recent versions).  Maybe Nautilus is emulating this behavior for hidden shares?

Can you try creating a share that doesn't end in $ and see if that shows up?
Comment 18 Fedora Update System 2008-12-06 23:25:31 EST
gvfs-1.0.3-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gvfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10848
Comment 19 oliver cubacub 2008-12-07 01:32:19 EST
charles,

you are correct, any shares with $ are meant to be hidden in windows
but to my surprise when i started using f8 in our windows network i can see the c$
i just double click on it and a prompt will pop up and i'll input my credentials  and i'll see the whole c$
i think it's the same on f9 but i'll verify that on monday at work on our domain
i'll try creating a share not hidden
thanks

>ruxbo
Comment 20 Adam Huffman 2008-12-07 07:51:02 EST
To clarify, in my case the shares showing blank windows are on a NAS device running Samba 2.x.  This update does not fix that problem.
Comment 21 Tomáš Bžatek 2008-12-08 08:40:24 EST
(In reply to comment #20)
> To clarify, in my case the shares showing blank windows are on a NAS device
> running Samba 2.x.  This update does not fix that problem.
That's a different issue - bug 443047 and the proposed fix is outside gvfs.
Comment 22 Tomáš Bžatek 2008-12-08 09:10:04 EST
(In reply to comment #16)
> if i click one windows computer i don't see the c$ and it does prompt me for
> username and password
> i don't see any and the count is 0
> where as in the pass i'll see the c$ then just input my credentials and i'm it
> (that's the beauty i love about fedora)

I confirm that invisible $-postfix shares should be displayed however access to them might be restricted to super user group at the smb server side.

Ruxbo, your comment is not completely clear to me - does it mean that you can correctly see the list of shares once you authenticate?
Comment 23 oliver cubacub 2008-12-08 13:49:56 EST
tomas,

when i click on a machine on the network, it doesn't prompt me for username and password
previously in f8 it'll promt me for the username and password then i'll see the c$
i just noticed in f9 it's the same as f10 when i click on the machine ont he network it doesn't prompt me for the username and password
hope that helps
thanks

>oliver
Comment 24 Fedora Update System 2008-12-09 15:41:24 EST
gvfs-1.0.3-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-3.fc10
Comment 25 Fedora Update System 2008-12-11 03:03:12 EST
gvfs-1.0.3-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gvfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11176
Comment 26 oliver cubacub 2008-12-11 11:11:53 EST
i've picked up the new update and happy to say that i can get to the c$ and admin$ shares
click on network, it's populated with the machines in the domain
click on a machine, prompt me for credentials hit enter and i see c$ and admin$
click on c$ and i'll be ask for credentials again then i'll see the whole c dir

though in the past versions (f8) i only get to enter my credentials once
click on a machine, prompts for credentials and i'll see c$
click on c$ and i'll see the whole dir

hope that helps
thanks



>oliver
Comment 27 oliver cubacub 2008-12-11 11:36:23 EST
by the way it still mounts the c$ which it shouldn't be
and i can see the c$ under Places menu
can that be fix?
thanks

>oliver
Comment 28 Tomáš Bžatek 2008-12-16 12:09:06 EST
The hidden (C$) shares are displayed by design and I suggest not to hide them as it might make users confused (think of enterprise customers).
Comment 29 Fedora Update System 2008-12-16 12:10:35 EST
gvfs-1.0.3-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-4.fc10
Comment 30 oliver cubacub 2008-12-16 17:06:59 EST
updated to gvfs-1.0.3-4.fc10
still the same
i can get to the shares but it's mounting it, is that by design?

in the past i can get to the share with out mounting them and still i can browse to it's contents
thanks

>oliver
Comment 31 Tomáš Bžatek 2008-12-17 05:06:21 EST
(In reply to comment #30)
> updated to gvfs-1.0.3-4.fc10
> still the same
> i can get to the shares but it's mounting it, is that by design?
> 
> in the past i can get to the share with out mounting them and still i can
> browse to it's contents
> thanks
Yes, that's by design. The philosophy of vfs mounts has changed since gnome-vfs and in order to access the data, you have to mount the share first. The same with "hidden" $ mounts - no decision has been made, we're trying to be consistent with previous versions and existing linux users. But don't expect completely same behaviour like in Windows.

So, from your previous posts I understand the original issue of this bug has been fixed, I'm in favor of closing this bug.
Comment 32 Fedora Update System 2008-12-21 03:18:57 EST
gvfs-1.0.3-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.