Bug 443753 - xen DOMU kernel crashing
xen DOMU kernel crashing
Status: CLOSED DUPLICATE of bug 250427
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
i386 Linux
low Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 01:07 EDT by James Shirley
Modified: 2008-04-23 09:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 09:40:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Shirley 2008-04-23 01:07:30 EDT
Description of problem:

I'm running RHEL5.1 XEN DOM0 + RHEL45 DOMU. And on occasion the user domain
crashes, with kernel errors.

Version-Release number of selected component (if applicable):

DOMU kernel = 2.6.9-67.0.4.ELxenU (RHEL45 x86)
DOM0 kernel = 2.6.18-53.1.4.el5xen (RHEL51 x86_64)

How reproducible:

It seems random, however ususually happens after oracle is shutdown

Actual results:

Apr 23 05:38:01 tcsxap10 kernel: eip: c0150b19
Apr 23 05:38:01 tcsxap10 kernel: ------------[ cut here ]------------
Apr 23 05:38:01 tcsxap10 kernel: kernel BUG at
include/asm/mach-xen/asm/spinlock.h:135!
Apr 23 05:38:01 tcsxap10 kernel: invalid operand: 0000 [#1]
Apr 23 05:38:01 tcsxap10 kernel: SMP
Apr 23 05:38:01 tcsxap10 kernel: Modules linked in: ipt_REDIRECT iptable_nat
ip_conntrack ip_tables nfsd exportfs autofs4 nfs lockd nfs_acl sunrpc md5 ipv6
xennet dm_snapshot dm_zero dm_mirror ext3
jbd dm_mod xenblk sd_mod scsi_mod
Apr 23 05:38:01 tcsxap10 kernel: CPU:    0
Apr 23 05:38:01 tcsxap10 kernel: EIP:    0061:[<c026ada9>]    Not tainted VLI
Apr 23 05:38:01 tcsxap10 kernel: EFLAGS: 00010246   (2.6.9-67.0.4.ELxenU)
Apr 23 05:38:01 tcsxap10 kernel: EIP is at _spin_lock+0x1c/0x34
Apr 23 05:38:01 tcsxap10 kernel: eax: c027603a   ebx: d1eb362c   ecx: c336bde8 
 edx: c0150b19
Apr 23 05:38:01 tcsxap10 kernel: esi: 00000000   edi: c10fcd20   ebp: 00000000 
 esp: c336bdec
Apr 23 05:38:01 tcsxap10 kernel: ds: 007b   es: 007b   ss: 0068
Apr 23 05:38:01 tcsxap10 kernel: Process kswapd0 (pid: 38, threadinfo=c336b000
task=ed4951a0)
Apr 23 05:38:01 tcsxap10 kernel: Stack: d1eb362c c0150b19 c10fcd20 c0150e51
c10fcd20 d1eb362d c10fcd20 00000000
Apr 23 05:38:01 tcsxap10 kernel:        c02a2e80 c336bf50 c0150f88 c10fcd20
00000000 c336beb0 c10fcd20 c01459cf
Apr 23 05:38:01 tcsxap10 kernel:        c10fcd20 00000001 00000000 00000001
00000000 00000015 00000000 c112b1f8
Apr 23 05:38:01 tcsxap10 kernel: Call Trace:
Apr 23 05:38:01 tcsxap10 kernel:  [<c0150b19>] page_lock_anon_vma+0x20/0x24
Apr 23 05:38:01 tcsxap10 kernel:  [<c0150e51>] page_referenced_anon+0x11/0x69
Apr 23 05:38:01 tcsxap10 kernel:  [<c0150f88>] page_referenced+0x3a/0x77
Apr 23 05:38:01 tcsxap10 kernel:  [<c01459cf>] shrink_list+0xf3/0x455
Apr 23 05:38:01 tcsxap10 kernel:  [<c0145f6b>] shrink_cache+0x23a/0x410
Apr 23 05:38:01 tcsxap10 kernel:  [<c0181a80>] mb_cache_shrink_fn+0x54/0x131
Apr 23 05:38:01 tcsxap10 kernel:  [<c014561a>] shrink_slab+0x75/0x194
Apr 23 05:38:01 tcsxap10 kernel:  [<c01467a7>] shrink_zone+0xf0/0x107
Apr 23 05:38:01 tcsxap10 kernel:  [<c0146c81>] balance_pgdat+0x1fb/0x350
Apr 23 05:38:01 tcsxap10 kernel:  [<c0146e8d>] kswapd+0xb7/0xbb
Apr 23 05:38:01 tcsxap10 kernel:  [<c0119fec>] autoremove_wake_function+0x0/0x3a
Apr 23 05:38:01 tcsxap10 kernel:  [<c01072d2>] ret_from_fork+0x6/0x10
Apr 23 05:38:01 tcsxap10 kernel:  [<c0119fec>] autoremove_wake_function+0x0/0x3a
Apr 23 05:38:01 tcsxap10 kernel:  [<c0146dd6>] kswapd+0x0/0xbb
Apr 23 05:38:01 tcsxap10 kernel:  [<c010530d>] kernel_thread_helper+0x5/0xb
Apr 23 05:38:01 tcsxap10 kernel: Code: 00 75 09 f0 81 02 00 00 00 01 30 c9 89 c8
c3 53 89 c3 81 78 04 ad 4e ad de 74 18 ff 74 24 04 68 3a 60 27 c0 e8 ff 16 eb ff
58 5a <0f> 0b 87 00 79 4f 27 c0 f0 f
e 0b 79 09 f3 90 80 3b 00 7e f9 eb
Apr 23 05:38:01 tcsxap10 kernel:  <0>Fatal exception: panic in 5 seconds


Expected results:

Not to crash

Additional info:
I have the same setup on a 32bit DOM0 and havent seen the problem.

I've also seen another problem where the same DOMU hangs and must be destroyed &
started again

Cheers James
Comment 1 Chris Lalancette 2008-04-23 09:40:49 EDT
This is a combination known to crash on 5.1.  This should be fixed in the
upcoming 5.2 release; but note that running 32-bit PV guests on 64-bit dom0 is
not a supported combination on either 5.1 or 5.2.  I'll close this as a dup.

Chris Lalancette

*** This bug has been marked as a duplicate of 250427 ***

Note You need to log in before you can comment on or make changes to this bug.