Bug 443813 - Ctrl toggles caps lock LED when it's swapped with CapsLock
Ctrl toggles caps lock LED when it's swapped with CapsLock
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 445107 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 10:29 EDT by Markus Armbruster
Modified: 2009-01-23 04:42 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.5.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 00:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2008-04-23 10:29:09 EDT
Description of problem:
I select "Swap Ctrl and CapsLock" in Keyboard Preferences / Layouts / Layout
Options / Ctrl key position.  The keys work as expected, except the now ctrl key
(formerly capslock) toggles the caps LED.

Version-Release number of selected component (if applicable):
Fresh install of F-9 preview from live CD + yum update

How reproducible:
Always

Steps to Reproduce:
1. Go to Keyboard Preferences / Layouts / Layout Options / Ctrl key position,
and select "Swap Ctrl and CapsLock".
2. Test the two keys in the "Type to test settings" widget.

Actual results:
New CapsLock works, but doesn't toggle the caps LED.  New Ctrl works, but does
toggle the caps LED.

Expected results:
CapsLock toggles the LED, Ctrl doesn't.
Comment 1 Bill Nottingham 2008-05-07 12:44:29 EDT
*** Bug 445107 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2008-05-14 06:00:55 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Alexander 2008-05-19 04:46:41 EDT
I am hit by this bug too. It's very uncomfortable when you don't know if the
caps lock is switched on.
Comment 4 Peter Hutterer 2008-10-23 00:11:33 EDT
Works fine now with xorg-x11-server-1.5.0-3. Closing as CURRENTRELEASE, please reopen if you can reproduce this issue.

Note You need to log in before you can comment on or make changes to this bug.