Bug 445107 - CapsLock leds lights up even though CapsLock has been remapped through xkbcomp
CapsLock leds lights up even though CapsLock has been remapped through xkbcomp
Status: CLOSED DUPLICATE of bug 443813
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Depends On:
  Show dependency treegraph
Reported: 2008-05-03 16:54 EDT by Dov Grobgeld
Modified: 2008-05-07 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-07 12:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2008-05-03 16:54:59 EDT
I am remapping my keyboard to a variation of Dvorak through xkbcomp through my
own homebuilt .xkbmap file through the command:

    xkbcomp ~/.xkbmap :0

I've used the same file through multiple fedora releases without any perceivable
difference in behavior. Yesterday, after upgrading to Fedora 9-rc1 I noticed
that the keyboard LED for CapsLock is turned on and off when I press the
CapsLock key, even though it has been remapped to Ctrl. Note that the Control
functionality is working as it should. The only percievable problem is that the
LED is turned on and off whenever I press my (remapped) Control key.

The relevant lines in my .xkbmap file are:

    key <CAPS> {        [   Control_L ],
                        [   Control_L ] };
    modifier_map Control { Control_L };
Comment 1 Bill Nottingham 2008-05-07 12:44:28 EDT

*** This bug has been marked as a duplicate of 443813 ***

Note You need to log in before you can comment on or make changes to this bug.