Bug 443815 - NetworkManager do not send hostname to dhcpd server
Summary: NetworkManager do not send hostname to dhcpd server
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-23 14:41 UTC by Alexey Kuznetsov
Modified: 2008-09-28 18:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 09:31:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-Network Connections.png (20.81 KB, image/png)
2008-08-29 15:08 UTC, Alexey Kuznetsov
no flags Details
Screenshot-Editing Auto wifi.tax.local.png (37.80 KB, image/png)
2008-08-29 15:09 UTC, Alexey Kuznetsov
no flags Details

Description Alexey Kuznetsov 2008-04-23 14:41:32 UTC
Description of problem:
Networkmanager should send host fqdn to dhcpd server for correct ddns update.

Comment 1 Alexey Kuznetsov 2008-05-14 13:18:53 UTC
I test it for wifi connections only, look at server log:

May 14 16:49:04 mini dhcpd: DHCPDISCOVER from 00:04:23:91:82:04 via br0
May 14 16:49:05 mini dhcpd: DHCPOFFER on 192.168.54.250 to 00:04:23:91:82:04 via
 br0
May 14 16:49:05 mini dhcpd: DHCPREQUEST for 192.168.54.250 (192.168.54.3) from 0
0:04:23:91:82:04 via br0
May 14 16:49:05 mini dhcpd: DHCPACK on 192.168.54.250 to 00:04:23:91:82:04 via b
r0

Comment 2 Fedora Update System 2008-07-30 19:59:55 UTC
NetworkManager-0.7.0-0.11.svn3846.fc9, NetworkManager-vpnc-0.7.0-0.10.svn3846.fc9, NetworkManager-openvpn-0.7.0-15.svn3846.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-vpnc NetworkManager-openvpn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6761

Comment 3 Alexey Kuznetsov 2008-07-30 20:42:47 UTC
problem still present.


if /etc/dhclient-eth0.conf present with hostname option, everyting work fine. if
file absent networkmanager do not send `hostname` to dhcpd server 

Comment 4 Dan Williams 2008-07-31 13:48:23 UTC
dhcp hostname currently only works if you have a system connection and have put
DHCP_HOSTNAME into your /etc/sysconfig/network-scripts/ifcfg-XXXX file.

Comment 5 Fedora Update System 2008-08-12 02:29:48 UTC
NetworkManager-openvpn-0.7.0-15.svn3930.fc9,NetworkManager-vpnc-0.7.0-0.10.svn3928.fc9,NetworkManager-0.7.0-0.11.svn3930.fc9 has been submitted as an update for Fedora 9

Comment 6 Fedora Update System 2008-08-12 02:34:47 UTC
NetworkManager-openvpn-0.7.0-15.svn3930.fc8,NetworkManager-vpnc-0.7.0-0.10.svn3928.fc8,NetworkManager-0.7.0-0.11.svn3930.fc8 has been submitted as an update for Fedora 8

Comment 7 Fedora Update System 2008-08-29 14:56:22 UTC
NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9

Comment 8 Alexey Kuznetsov 2008-08-29 15:08:45 UTC
Created attachment 315368 [details]
Screenshot-Network Connections.png

Comment 9 Alexey Kuznetsov 2008-08-29 15:09:01 UTC
Created attachment 315369 [details]
Screenshot-Editing Auto wifi.tax.local.png

Comment 10 Alexey Kuznetsov 2008-08-29 15:11:05 UTC
There you can see my configuration. At https://bugzilla.redhat.com/attachment.cgi?id=315369 you can see DHCP Client ID feeld filled with "axet-lapop"

In server logs i see:

Aug 29 19:06:13 mini dhcpd: DHCPDISCOVER from 00:19:e3:d3:7b:51 via br0
Aug 29 19:06:14 mini dhcpd: DHCPOFFER on 192.168.54.6 to 00:19:e3:d3:7b:51 via br0
Aug 29 19:06:14 mini dhcpd: DHCPREQUEST for 192.168.54.6 (192.168.54.3) from 00:19:e3:d3:7b:51 via br0
Aug 29 19:06:14 mini dhcpd: DHCPACK on 192.168.54.6 to 00:19:e3:d3:7b:51 via br0
Aug 29 19:07:00 mini ntpd[2256]: synchronized to 89.108.124.4, stratum 2


And i except to see:

Aug 24 17:33:23 mini dhcpd: Wrote 13 leases to leases file.
Aug 24 17:33:23 mini dhcpd: DHCPREQUEST for 192.168.54.247 from 00:17:f2:d1:4a:84 via br0
Aug 24 17:33:23 mini dhcpd: DHCPACK on 192.168.54.247 to 00:17:f2:d1:4a:84 (axet-laptop) via br0
Aug 24 17:33:28 mini dhcpd: DHCPREQUEST for 192.168.54.248 from 00:19:e3:d3:7b:51 (axet-laptop) via br0
Aug 24 17:33:28 mini dhcpd: DHCPACK on 192.168.54.248 to 00:19:e3:d3:7b:51 (axet-laptop) via br0
Aug 24 17:33:30 mini dhcpd: DHCPREQUEST for 192.168.54.248 from 00:19:e3:d3:7b:51 (axet-laptop) via br0
Aug 24 17:33:30 mini dhcpd: DHCPACK on 192.168.54.248 to 00:19:e3:d3:7b:51 (axet-laptop) via br0
Aug 24 17:33:45 mini dhcpd: DHCPINFORM from 192.168.54.247 via br0

Comment 11 Dan Williams 2008-08-29 16:02:23 UTC
Ah, so here's the problem.  DHCP Client Identifier is actually different than the hostname that gets sent to the DHCP server to update DNS.  They are two different things entirely.  The UI does not support sending a hostname to the DHCP server at this time.  That's supported for system connections on Fedora right now via the DHCP_HOSTNAME variable in the ifcfg file.

Comment 12 Alexey Kuznetsov 2008-08-29 16:11:23 UTC
thx for answer. you told me same things at the begining. i just wana note about this problem more detailed. as everyone fedora users networkmanager must provide easy way to set hostname by settings menu. and now i can see field for that purpose. i expect in near future we all can have great application to solve all network issues... thx again.

ps: i also hope network architecture bug 446338 will be solved, as i told in short description its a defect by design.

Comment 13 Dan Williams 2008-08-29 16:45:48 UTC
In the end, I think we'll end up sending the machine's hostname to the server as you've set in /etc/sysconfig/network if it doesn't contain "localhost".  That way to don't have to enter anything.

Comment 14 Alexey Kuznetsov 2008-08-29 17:06:57 UTC
cool :)

Comment 15 Fedora Update System 2008-09-02 20:41:31 UTC
NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8

Comment 16 Fedora Update System 2008-09-10 06:36:27 UTC
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7375

Comment 17 Fedora Update System 2008-09-10 06:54:09 UTC
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openvpn NetworkManager-vpnc NetworkManager-pptp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7484

Comment 18 Michael Cronenworth 2008-09-27 23:58:51 UTC
This bug was a dupe of bug 385211.

Comment 19 Alexey Kuznetsov 2008-09-28 09:31:42 UTC

*** This bug has been marked as a duplicate of bug 385211 ***

Comment 20 Fedora Update System 2008-09-28 18:42:23 UTC
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2008-09-28 18:45:09 UTC
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.