Bug 443849 - completion in comint shell doesn't work
completion in comint shell doesn't work
Status: CLOSED DUPLICATE of bug 443639
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 13:45 EDT by Jonathan Kamens
Modified: 2008-04-23 15:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 15:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-04-23 13:45:31 EDT
With emacs-23.0.60-2.fc9.i386, when I partially type a directory (e.g., "~/add" 
when the directory "~/addresses" exists) and hit tab, it doesn't complete.

It's trying to complete but none of the completion functions are doing anything.

This, as you might imagine, is exceedingly irritating.
Comment 1 Chip Coldwell 2008-04-23 15:00:04 EDT

*** This bug has been marked as a duplicate of 443639 ***
Comment 2 Pawel Salek 2008-04-23 15:23:14 EDT
Is this occurring for actions like C-x C-f? I cannot reproduce this with
emacs-23.0.60-2.fc9.x86_64. I have tried both the windowed version as well as in
the terminal window (executed as "emacs -nw").
Comment 3 Jonathan Kamens 2008-04-23 15:28:27 EDT
This has nothing to do with C-x C-f.  That's minibuffer completion, which is 
handled within (interactive).  As I explained in the bug, I'm talking about 
completion IN A COMINT SHELL BUFFER.

Note You need to log in before you can comment on or make changes to this bug.