Bug 443931 - konqueror does not go through proxy
Summary: konqueror does not go through proxy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL: http://bugs.kde.org/show_bug.cgi?id=1...
Whiteboard:
: 444991 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-24 07:43 UTC by Ari Tilli
Modified: 2008-05-28 07:52 UTC (History)
6 users (show)

Fixed In Version: 4.0.4-4.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 10:58:21 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 155707 None None None Never

Description Ari Tilli 2008-04-24 07:43:20 UTC
Description of problem:
No matter how I defined proxy, no connection is made with
Konqueror. Local web addresses work ok.

Version-Release number of selected component (if applicable):
kde-settings-4.0-21.fc9.noarch

konqueror --version
Qt: 4.3.4
KDE: 4.0.3 (KDE 4.0.3)
Konqueror: 4.0.3 (KDE 4.0.3)

How reproducible:
Always

Steps to Reproduce:
1. Define proxy
2. Try use konq. to connect web
  
Actual results:
Server are not found

Expected results:
Firefox with same proxy settings works.

Additional info:
Seems to be upstream bug, see URL, though I report it anyway here too.

Comment 1 Kevin Kofler 2008-04-24 07:49:37 UTC
The non-duplicate upstream bug: http://bugs.kde.org/show_bug.cgi?id=155707

Comment 2 Kevin Kofler 2008-05-14 06:53:18 UTC
*** Bug 444991 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Kofler 2008-05-14 06:56:27 UTC
There's a patch in the upstream bug report, I'll try a test build with that 
patch, let's see how it goes.

Comment 4 Kevin Kofler 2008-05-14 07:08:12 UTC
Actually there are (at least) 2 patches:
* a kdelibs patch:
http://bugs.kde.org/attachment.cgi?id=24641&action=view
Several versions of that patch by different authors, this is the latest, not 
sure if it's the best though.
* a kdebase patch to fix the proxy dialog in Konqueror:
http://lists.kde.org/?l=kde-devel&m=119028779303232&w=2

Comment 5 Kevin Kofler 2008-05-14 07:09:24 UTC
We may want some of the changes from this (also against kdelibs) too:
http://bugs.kde.org/attachment.cgi?id=24487&action=view

Comment 6 Kevin Kofler 2008-05-15 01:58:10 UTC
> We may want some of the changes from this (also against kdelibs) too:
> http://bugs.kde.org/attachment.cgi?id=24487&action=view

Actually we don't need this one. The changes to kio_http are superseded by the 
first patch I listed:
http://bugs.kde.org/attachment.cgi?id=24641&action=view
and the other changes have been already applied in KDE 4.0.4.

Comment 7 Kevin Kofler 2008-05-15 02:02:33 UTC
New version of the kdelibs patch by Sergey Saukh:
http://bugs.kde.org/attachment.cgi?id=24758&action=view

> FIX:
> don't drop connection on post requests;
> close connection if request's proxy url differs from state's (previous
> request).

Comment 8 Kevin Kofler 2008-05-15 02:39:01 UTC
> * a kdebase patch to fix the proxy dialog in Konqueror:
> http://lists.kde.org/?l=kde-devel&m=119028779303232&w=2

This one was actually applied months ago (before 4.0 branched):
http://websvn.kde.org/?view=rev&revision=715132
so only the kdelibs patch is relevant.

Comment 9 Kevin Kofler 2008-05-15 03:22:27 UTC
Should be fixed in kdelibs-4.0.4-3.fc9:
https://koji.fedoraproject.org/koji/taskinfo?taskID=609985

Comment 10 Fedora Update System 2008-05-17 22:20:47 UTC
kdepimlibs-4.0.4-1.fc9, kdesdk-4.0.4-2.fc9, kdebase-runtime-4.0.4-1.fc9, kdeartwork-4.0.4-1.fc9, kdeadmin-4.0.4-1.fc9, kdemultimedia-4.0.4-1.fc9, kdegraphics-4.0.4-1.fc9, kde-l10n-4.0.4-1.fc9, kdeedu-4.0.4-2.fc9, kdebase-workspace-4.0.4-4.fc9, kdenetwork-4.0.4-2.fc9, kdeutils-4.0.4-1.fc9, kdetoys-4.0.4-1.fc9, kdelibs-4.0.4-4.fc9, kdegames-4.0.4-2.fc9, kdebindings-4.0.4-1.fc9, kdeaccessibility-4.0.4-1.fc9, kdebase-4.0.4-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepimlibs kdesdk kdebase-runtime kdeartwork kdeadmin kdemultimedia kdegraphics kde-l10n kdeedu kdebase-workspace kdenetwork kdeutils kdetoys kdelibs kdegames kdebindings kdeaccessibility kdebase'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3664

Comment 11 Fedora Update System 2008-05-21 10:58:10 UTC
kdebase-workspace-4.0.4-4.fc9, kdebase-4.0.4-2.fc9, kde-l10n-4.0.4-1.fc9, kdesdk-4.0.4-2.fc9, kdemultimedia-4.0.4-2.fc9, kdelibs-4.0.4-4.fc9, kdeedu-4.0.4-2.fc9, kdebase-runtime-4.0.4-1.fc9, kdepimlibs-4.0.4-1.fc9, kdenetwork-4.0.4-2.fc9, kdegraphics-4.0.4-1.fc9, kdeaccessibility-4.0.4-1.fc9, kdeartwork-4.0.4-1.fc9, kdeutils-4.0.4-1.fc9, kdebindings-4.0.4-1.fc9, kdetoys-4.0.4-1.fc9, kdegames-4.0.4-2.fc9, kdeadmin-4.0.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Norman R. Weathers 2008-05-21 17:40:34 UTC
I have responded to http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3664,
but I thought I would put it here as well.  The fixes do allow my konqueror to
now be able to use the web proxy, but it spins up kded4 process to near 100%
during the request, and it can be painfully slow compared to firefox.  It
actually causes several things within the KDE interface to become unresponsive
while it is processing the proxy request and subsequent download of the
requested data.

Comment 13 Kevin Kofler 2008-05-21 18:10:51 UTC
Thanks for your feedback, I forwarded it to the upstream bug.

While the high CPU use is a problem left to be fixed, this is definitely better 
than proxies not working at all. ;-)

Comment 14 Kevin Kofler 2008-05-22 08:28:26 UTC
Sergey Saukh asks at http://bugs.kde.org/show_bug.cgi?id=155707#c49 :
> Such strange behaviour of kded4 can be caused by two modules - favicons and
> proxyscout. Does he use proxy autoconfiguration? If he does, does manual
> setting of proxy help?

(The best way of communicating is probably to reply upstream directly so I 
don't have to copy&paste messages back and forth. ;-) )

Comment 15 Kevin Kofler 2008-05-28 07:52:31 UTC
Norman R. Weathers: Ping?
We're still waiting for an answer to upstream's question.


Note You need to log in before you can comment on or make changes to this bug.