Bug 444991 - Proxy settings don't seem to work in KDE
Proxy settings don't seem to work in KDE
Status: CLOSED DUPLICATE of bug 443931
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 12:23 EDT by Norman R. Weathers
Modified: 2008-05-14 06:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 02:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 155707 None None None Never

  None (edit)
Description Norman R. Weathers 2008-05-02 12:23:32 EDT
Description of problem:

I have tried to setup proxy settings, either through the environment, or through
a proxy server URL, or even downloading the proxy file and pointing the proxy
setting to the local file URL, or even just specifying the proxy servers in the
proxy settings in the new control panel, but the settings do not seem to be
working.  The same settings set in the shell allow YUM to work, and I can set
them in firefox as well, but nothing under KDE picks them up correctly.


Version-Release number of selected component (if applicable):

kdebase-4.0.3-6.fc9.x86_64 (and all previous versions as well)


How reproducible:

Always


Steps to Reproduce:
1.  Setup proxy information in KDE control shell (or even in your own shell with
http_proxy variable).
2.  Open konqueror, RSS feed, comic strip desktop widget, anything requiring
proxy access to get external connections.
3.  Watch all of them say that they cannot access the network (our proxy doesn't
allow us to access external web hosts without going through the proxy itself).
  
Actual results:

Example konqueror error message when trying to get to google.com and proxy does
not work:

An error occurred while loading http://www.google.com:
Could not connect to host www.google.com: Unknown error.

Expected results:
google.com web page should show up.

Additional info:

Internal web pages (not requiring proxy) work fine.  It only seems to be
affected when it has to go out the proxy.  I cannot tell if it is not contacting
the proxy, or if it just doesn't use the proxy settings now, or what.  This
works on Fedora 8 and before.
Comment 1 Rex Dieter 2008-05-02 12:35:38 EDT
looks like it, see upstream http://bugs.kde.org/155707
Comment 2 Rex Dieter 2008-05-02 12:36:22 EDT
and possibly related: http://bugs.kde.org/152477
Comment 3 Kevin Kofler 2008-05-14 02:53:17 EDT

*** This bug has been marked as a duplicate of 443931 ***
Comment 4 Bug Zapper 2008-05-14 06:31:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.