Bug 443979 - anaconda fails to find new disk partitions
anaconda fails to find new disk partitions
Status: CLOSED DUPLICATE of bug 439633
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-04-24 09:54 EDT by Doug Chapman
Modified: 2008-04-24 10:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file from anaconda (91.09 KB, text/plain)
2008-04-24 09:54 EDT, Doug Chapman
no flags Details
anaconda.log from failed install (41.38 KB, text/plain)
2008-04-24 09:55 EDT, Doug Chapman
no flags Details

  None (edit)
Description Doug Chapman 2008-04-24 09:54:33 EDT
Description of problem:
At this point I don't know if this is a problem in anaconda, parted, or the
kernel.  An install of Fedora failed due to not finding the partition that it
had just created.

I was installing to /dev/cciss/c0d0, it should have created c0d0p0 p1 p3 and p3.
 The install failed that it could not find the partitions.  I dropped to a shell
and confirmed that the /dev/cciss/c0d0 (aka the raw disk) was the only dev file.

After a reboot however I _did_ see that the /dev/cciss/c0d0p* dev files did exist.

So, whatever is supposed to make these devices after parted is run failed.  I
don't know how that works under anaconda, does it use udev?

I will try this on an x86 system but I am guessing that installing to any disk
where the partitions did not exist when the installer booted will fail.

It is difficult to tell when this failed since normally my installs are to a
system that already has the partitions created.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.75-1
kernel-2.6.25-1
parted-1.8.8-5.fc9
pyparted-1.8.9-5.fc9
udev-120-3.fc9


How reproducible:
100%

Steps to Reproduce:
1. make sure you have a disk with no partitions on it
2. install to that disk
3. anaconda fails
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-04-24 09:54:33 EDT
Created attachment 303628 [details]
dump file from anaconda
Comment 2 Doug Chapman 2008-04-24 09:55:45 EDT
Created attachment 303629 [details]
anaconda.log from failed install
Comment 3 Doug Chapman 2008-04-24 10:25:08 EDT
I just did an install (to a disk that had pre-existing partitions) and from the
installed system I partitioned a disk that had no pre-existing partitions with
parted.  The /dev/ entries do get created in this case so I think that rules out
the problem being in the kernel, udev or parted.

My guess is whatever anaconda does to make sure new /dev/ entries get created
isn't working.  This was on ia64, I will do an test on my x86_64 system as soon
as I get in the office to see if this is arch specific.
Comment 4 Jeremy Katz 2008-04-24 10:56:57 EDT

*** This bug has been marked as a duplicate of 439633 ***

Note You need to log in before you can comment on or make changes to this bug.