Bug 444016 - libsane-hpaio IMHO should be installed by default
libsane-hpaio IMHO should be installed by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Jeremy Katz
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-04-24 11:43 EDT by Thorsten Leemhuis
Modified: 2014-03-16 23:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 15:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2008-04-24 11:43:47 EDT
Description of problem:
libsane-hpaio IMHO should be installed by default, as we normally install all
the device drivers by default as long as it doesn't do any harm.

Related Discussion:
https://www.redhat.com/archives/fedora-devel-list/2008-April/msg01814.html

More information:
From reading Bug 430834 I suppose libsane-hpaio was actually installed by
default in F8 due to that dep that was removed earlier this year to reduce
dependency bloat.
Comment 1 Thorsten Leemhuis 2008-04-25 01:22:15 EDT
Related issue I noticed while at it: I'm wondering if the split in hplip and
libsane-hpaio is worth the trouble in any case, as hplip tracks in
sane-backends-libs (which again tracks in sane-backends) while libsane-hpaio
itself is quite small:

$ repoquery hplip  --requires | grep -i sane
libsane.so.1()(64bit)
$ repoquery -qi libsane-hpaio | grep Size
Size        : 58776
Comment 2 Tim Waugh 2008-04-25 04:59:56 EDT
I think we can probably make this a lot better by splitting out the pure library
parts (libhpip and libhpmud) of hplip into, say, hplip-libs.

Then we can add libsane-hpaio as a 'default install' package alongside SANE,
still avoiding an explicit dependency in sane-backends.
Comment 3 Bug Zapper 2008-05-14 06:05:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tim Waugh 2008-08-04 13:17:25 EDT
Sub-package split done; keeping open for libsane-hpaio in default package set alongside sane.
Comment 5 Tim Waugh 2008-09-29 10:26:34 EDT
Changing component and reassigning.
Comment 6 Bill Nottingham 2008-09-29 15:29:47 EDT
Done.

Note You need to log in before you can comment on or make changes to this bug.