Bug 444053 - freeze at logout with xdm/kdm
freeze at logout with xdm/kdm
Status: CLOSED DUPLICATE of bug 443320
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 15:15 EDT by Patrice Dumas
Modified: 2008-04-28 10:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 10:30:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (708 bytes, text/plain)
2008-04-25 12:52 EDT, Patrice Dumas
no flags Details
Xorg.0.log (19.40 KB, text/plain)
2008-04-25 12:53 EDT, Patrice Dumas
no flags Details
Xorg.0.log zithout xorg.conf (24.25 KB, text/plain)
2008-04-25 13:00 EDT, Patrice Dumas
no flags Details
Xorg.0.log with kdm, xorg.conf, and a freeze (25.62 KB, text/plain)
2008-04-25 13:08 EDT, Patrice Dumas
no flags Details

  None (edit)
Description Patrice Dumas 2008-04-24 15:15:11 EDT
Description of problem:

I have tested kdm/fluxbox or gnome, and xdm/fluxbox. The screen is frozen
upon logout. Nothing specific in the logs.

gdm is fine. xdm and kdm have a common codebase (though they 
have diverged a lot).

I searched a bit in bugzilla but didn't managed to find a duplicate, which
seems a bit strange to me.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-04-25 12:30:44 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Patrice Dumas 2008-04-25 12:52:33 EDT
Created attachment 303798 [details]
xorg.conf
Comment 3 Patrice Dumas 2008-04-25 12:53:37 EDT
Created attachment 303799 [details]
Xorg.0.log
Comment 4 Patrice Dumas 2008-04-25 12:54:18 EDT
This Xorg.0.log is with gdm.
Comment 5 Patrice Dumas 2008-04-25 13:00:42 EDT
Created attachment 303800 [details]
Xorg.0.log zithout xorg.conf
Comment 6 Patrice Dumas 2008-04-25 13:08:10 EDT
Created attachment 303801 [details]
Xorg.0.log with kdm, xorg.conf, and a freeze
Comment 7 Patrice Dumas 2008-04-27 07:55:31 EDT
I don't think it is right to set component to xdm. This is also for
kdm, setting it to xdm is likely to have it sit for a long time.

Moreover I had some X random freezes (2 times) in fluxbox and 
also a freeze after coming back from suspend.
Comment 8 Matěj Cepl 2008-04-28 09:50:17 EDT
(In reply to comment #7)
> I don't think it is right to set component to xdm. This is also for
> kdm, setting it to xdm is likely to have it sit for a long time.
> 
> Moreover I had some X random freezes (2 times) in fluxbox and 
> also a freeze after coming back from suspend.

OK, there are two options:

a) after considering that the bug happens in xdm and kdm, and kdm shares a
codebase with xdm, I have assigned a bug to xdm.
b) If you want to let it assign to kdm, you are very welcome, but I am quite
sure, that kdm people will throw back it on us or ignore it completely.

Concerning your fluxbox bug, where I have no idea what happens -- my crystal
ball is out of order currently -- please file a bug against fluxbox.

Reassigning to kdm and let's see what its maintainers will think about it.
Comment 9 Kevin Kofler 2008-04-28 09:57:34 EDT
Is it completely frozen? Or just not responding to keyboard input? And does 
Ctrl-C restart X when that happens? In other words, does it sound like
bug 443320?
Comment 10 Rex Dieter 2008-04-28 09:58:14 EDT
Imo, if the bug exists in both xdm and kdm, clone the bug, one for each.
Comment 11 Patrice Dumas 2008-04-28 10:30:27 EDT
It is indeed a duplicate of bug 443320, ctrl-C restart X when it happens, 
both in xdm and kdm.

> Concerning your fluxbox bug, where I have no idea what happens -- my crystal
> ball is out of order currently -- please file a bug against fluxbox.

Come on, it doesn't look like a fluxbox bug, but an X bug. It may not
be related, though, to the bug triggered by kdm and xdm.
 


*** This bug has been marked as a duplicate of 443320 ***

Note You need to log in before you can comment on or make changes to this bug.