Bug 443320 - Cannot enter keyboard input into kdm after logout
Cannot enter keyboard input into kdm after logout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
https://bugs.freedesktop.org/show_bug...
:
: 444053 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-20 12:38 EDT by Rex Dieter
Modified: 2008-09-16 21:29 EDT (History)
12 users (show)

See Also:
Fixed In Version: 1.5.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 21:29:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "ps auxww" while in KDM when I can't type (9.04 KB, text/plain)
2008-04-23 05:18 EDT, Mary Ellen Foster
no flags Details
Output of "ps auxww" while in KDM after Ctrl-C (X restarted) (8.95 KB, text/plain)
2008-04-23 05:18 EDT, Mary Ellen Foster
no flags Details
diff between the previous two attachments (3.70 KB, patch)
2008-04-23 05:19 EDT, Mary Ellen Foster
no flags Details | Diff
Better "before" ps (8.87 KB, text/plain)
2008-04-23 05:46 EDT, Mary Ellen Foster
no flags Details
Better "after" ps (8.87 KB, text/plain)
2008-04-23 05:46 EDT, Mary Ellen Foster
no flags Details
diff between the previous two attachments (2.33 KB, patch)
2008-04-23 05:47 EDT, Mary Ellen Foster
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 161152 None None None Never
FreeDesktop.org 14418 None None None Never
FreeDesktop.org 15645 None None None Never

  None (edit)
Description Rex Dieter 2008-04-20 12:38:43 EDT
+++ This bug was initially created as a clone of Bug #443307 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008041301
Fedora/3.0-0.54.beta5.fc9 Firefox/3.0b5

Description of problem:
It is not possible to login into kdm again after logging out from kde.
Kdm doesn't accept any keystrokes, while interaction by the mouse is still possible.
Workaround: After restarting X server, I can log in again.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.3-16.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Log into KDE 
2. Log out from KDE
3. Try to login again

Actual Results:
Kdm didn't accept any keystrokes, so I can't enter my password.

Expected Results:
Kdm should accept input from keyboard.

Additional info:

-- Additional comment from rdieter@math.unl.edu on 2008-04-20 12:12 EST --
I've seen this on occasion too, but only after I suspend->resume my laptop. 
Methinks there's an X bugosity going on here.

Session->Restart X server is a quick-n-dirty workaround.

-- Additional comment from rdieter@math.unl.edu on 2008-04-20 12:20 EST --
This almost certainly isn't kdm at fault here.  At least for me, even
CNTL-ALT-BACKSPACE doesn't work.
Comment 1 Kevin Kofler 2008-04-21 08:56:57 EDT
What video driver are you using?
Comment 2 Rex Dieter 2008-04-21 09:08:22 EDT
intel (945) here, dell latitude d620 (but I wouldn't have thought that the video
hardware/driver would affect keyboard input, but hey, you never know)
Comment 3 Kevin Kofler 2008-04-21 09:17:35 EDT
Well, there's at least one report on the mailing list with it happening with 
the evil proprietary nvidia driver:
https://www.redhat.com/archives/fedora-devel-list/2008-April/msg01473.html
but as you can reproduce it with intel it can't be that. And you're probably 
right that the video driver is irrelevant anyway => canceling needinfo.
Comment 4 Mary Ellen Foster 2008-04-21 12:37:11 EDT
I think I've also seen this. I'm using the live image so there's no keyboard
interaction needed to log in -- just double click on passwordless "fedora" user
-- but after I do log in like that, the keyboard doesn't work in KDE proper.

I discovered by accident that if I'm logged in and it's in this state, typing
"ctrl-C" seems to restart X and then KDM, and then everything's fine.
Comment 5 Mike Pope 2008-04-22 08:21:18 EDT
I can reproduce this, but I am guilty of the evil-of-nvidia.
Comment 6 Mary Ellen Foster 2008-04-22 13:22:30 EDT
I've tested a bit more, and yes, it definitely does seem that Ctrl-C restarts X
when it's in this state, both in kdm and from inside kde. Weird ......
Comment 7 Kevin Kofler 2008-04-22 18:30:36 EDT
Shouldn't that be xorg-x11-drv-keyboard, not -mouse? It's the keyboard which 
isn't reacting.
Comment 8 Mary Ellen Foster 2008-04-23 05:17:30 EDT
I've been doing a bit more testing. It's still the case that, at least for me, I
can press ctrl-C and have X restart when things are in this state. Ctrl-Alt-F1
also works ... so I tried getting the output of ps auxww before and after
restarting X. I'll attach the two files and the diff between them shortly.
Nothing jumps out, unfortunately. Am I the only one who's seeing the Ctrl-C thing?

(NB: Intel graphics card, for what it's worth)
Comment 9 Mary Ellen Foster 2008-04-23 05:18:14 EDT
Created attachment 303462 [details]
Output of "ps auxww" while in KDM when I can't type
Comment 10 Mary Ellen Foster 2008-04-23 05:18:43 EDT
Created attachment 303463 [details]
Output of "ps auxww" while in KDM after Ctrl-C (X restarted)
Comment 11 Mary Ellen Foster 2008-04-23 05:19:09 EDT
Created attachment 303464 [details]
diff between the previous two attachments
Comment 12 Mary Ellen Foster 2008-04-23 05:46:27 EDT
Created attachment 303468 [details]
Better "before" ps
Comment 13 Mary Ellen Foster 2008-04-23 05:46:53 EDT
Created attachment 303469 [details]
Better "after" ps
Comment 14 Mary Ellen Foster 2008-04-23 05:47:57 EDT
Created attachment 303470 [details]
diff between the previous two attachments

Oops, my previous ps outputs had a rogue gamin client in them that's probably
not relevant (it times out and exits on its own if you let it).
Comment 15 Kevin Kofler 2008-04-23 09:27:16 EDT
Unfortunately, I don't see anything relevant in that diff, the list of 
processes before and after is the same, only the execution times changed and of 
course the PIDs of the processes which got restarted.
Comment 16 Rex Dieter 2008-04-23 10:02:46 EDT
Switched to using gdm, gdm itself seemed to work fine.  

But, some other wierd stuff started happening.  Cntl-Alt-F1 to get to console. 
Initially, all my keyboard input was doubled:  press p -> 2 p's appear.  As soon
as the input on the screen reached the bottom, and it refreshed at the top, the
doubling went away... but... 

Now, at
localhost login:
I press enter, and see: "^M" printed, and then:
[root@localhost /]#
type a few commands, like ls, and see output, and after a bit, I again see
login:

freaky.  Switching to anything other than VT1, things seem better.

Comment 17 Rex Dieter 2008-04-23 10:08:52 EDT
Oh, and I can confirm the "Cntl-C" behavior as mentioned in comment #6 (only
tested when on kdm screen).  Pressing it restarts X session.
Comment 18 Rex Dieter 2008-04-23 15:04:13 EDT
egads, I can now reproduce this every time, freshly booted.
Comment 19 Rex Dieter 2008-04-28 10:05:19 EDT
Testing logging into gnome from kdm, same problem.
Comment 20 Rex Dieter 2008-04-28 10:12:16 EDT
mefoster found this:
http://bugs.kde.org/161152

which sounds relevant, will test.
Comment 21 Kevin Kofler 2008-04-28 10:16:01 EDT
Adding "Patch" keyword because an xorg-x11-server patch by Bernhard 
Rosenkränzer is available:
http://bugs.kde.org/show_bug.cgi?id=161152#c2
Comment 22 Mary Ellen Foster 2008-04-28 10:23:12 EDT
Looks like there's a relevant freedesktop.org bug too.
Comment 23 Patrice Dumas 2008-04-28 10:30:28 EDT
*** Bug 444053 has been marked as a duplicate of this bug. ***
Comment 24 Rex Dieter 2008-04-28 11:02:31 EDT
In the meantime, a quick-n-dirty short term hack could be to add to kdmrc:
TerminateServer=true
as suggested http://bugs.kde.org/show_bug.cgi?id=161152#c3
Comment 25 Alain Portal 2008-05-01 10:25:31 EDT
I've got the same problem with kdebase-workspace-18.fc9.x86_64.
If you need information from me, just let me know
Comment 26 Rex Dieter 2008-05-01 10:38:17 EDT
See bug #443307 for a test build of kde-settings that includes a (hopefully
temporary and ugly) workaround.
Comment 27 Bill Nottingham 2008-05-02 11:46:55 EDT
Given the KDE workaround, I'm moving this off the blocker.
Comment 28 Kevin Kofler 2008-05-02 11:52:45 EDT
Well, we still have the problem that the workaround doesn't get applied on 
updates because kdmrc is %config(noreplace).
Comment 29 Warren Togami 2008-05-02 17:20:36 EDT
Trouble with these X regeneration bugs is that you can't ever be sure that
you've got rid of them entirely.  They are often driver/hardware dependent. 
These regeneration bugs keep coming back again and again for years, and they are
not a huge priority for X upstream to fix.  For this reason gdm terminates X
every time you logout.  gdm no longer has an option anymore.  kdm should do the
same thing.
Comment 30 Patrice Dumas 2008-05-02 17:38:15 EDT
Although it may be needed to workaround bugs, they should be fixed
where they are. And after the bug is fixed upstream and put in fedora
those workarounds should certainly be removed.
Comment 31 Kevin Kofler 2008-05-02 17:40:26 EDT
+1 to Patrice, this should really get fixed in X, not hacked around.
Comment 32 Warren Togami 2008-05-02 17:44:49 EDT
There is nothing wrong with fixing individual X bugs as you find them.  But do
you realize how difficult it would be to confirm it is fixed on every possible
driver and chipset combination?
Comment 33 Patrice Dumas 2008-05-02 17:54:07 EDT
I do. And it is even more difficult if there are workarounds that
mask them. It makes sense to mask them in stable releases, but
in rawhide I don't think it is a good idea (except maybe when too
many users are impacted).
Comment 34 Bug Zapper 2008-05-14 05:48:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 35 Patrice Dumas 2008-05-16 07:16:05 EDT
Things are worse in rawhide for me (using xdm), but I don't know if it is 
related with xdm, my hardware, or X. Now, after I hit Ctrl-C the computer
becomes unresponsive with a dark screen. Could people with kdm and different
setups test, please? 
Comment 36 Peter Hutterer 2008-07-15 21:53:34 EDT
Problem is caused by the original fix to X.Org bug 14418 [1], also reported as
15645 [2]
The follow-up fix never got cherry-picked into server-1.5-branch, hence when the
server restarted the devices configured in the configuration file weren't
re-initialised. I cherry-picked and pushed it upstream now, should trickle down
soon.

Removing Patch keyword, the patch to kde bug 161152 doesn't work, this code was
the original cause for X.Org bug 14418.

[1] https://bugs.freedesktop.org/show_bug.cgi?id=14418
[2] https://bugs.freedesktop.org/show_bug.cgi?id=15645
Comment 37 Peter Hutterer 2008-09-16 21:29:17 EDT
Fixed by now with xorg-x11-server-1.5.0-1.

Please reopen if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.