Bug 444115 - EeePC does not shut down due to snd-hda-intel module
Summary: EeePC does not shut down due to snd-hda-intel module
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 10
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: http://fedoraproject.org/wiki/EeePc#h...
Whiteboard:
Keywords:
: 453244 468254 (view as bug list)
Depends On:
Blocks: FedoraMini, Mobility
TreeView+ depends on / blocked
 
Reported: 2008-04-25 03:31 UTC by Luis Felipe Marzagao
Modified: 2008-12-21 16:57 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 16:57:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kwade: fedora_requires_release_note+


Attachments (Terms of Use)

Description Luis Felipe Marzagao 2008-04-25 03:31:33 UTC
Description of problem:

Asus EeePC 4G (701) does not shut down. The screen goes off, but the power
remains on. You have to manually sht it down (holding power button).

If you manually remove snd-hda-intel module (by inserting modprobe -r
snd-hda-intel in /etc/init.d/halt), then it shuts down.


Version-Release number of selected component (if applicable):

2.6.25-1.fc9.i686


How reproducible:

Always


Steps to Reproduce:
1. Buy Asus EeePC 4G computer
2. Install F9 Preview release
3. Click on "Shut Down ..." icon
  
Actual results:

Computer does not shut down

Expected results:

Computer should shut down

Comment 1 Bug Zapper 2008-05-14 10:08:09 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Robert Scheck 2008-05-14 22:39:48 UTC
Problem still exists in Fedora 9

Comment 3 Carlo Raudino 2008-06-17 09:47:17 UTC
I think this bug has not been fixed...

we managed to temp "fix" with just this code:

modprobe -r snd-hda-intel

in /etc/init.d/halt


Thankyou for support :-)

Comment 4 Robert Scheck 2008-06-17 09:53:21 UTC
Well, put "modprobe -r snd-hda-intel" into /sbin/halt.local and chmod 755 to it. 
This will not break it once initscripts are updated until the problem is really
fixed the correct/sane way.

Comment 5 Sitsofe Wheeler 2008-09-14 16:54:57 UTC
Curiously if you have a late 2.6.26 kernel you can workaround the issue by using hda autosuspend (see the companion Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/126140 .

Comment 6 Luis Felipe Marzagao 2008-09-14 22:10:06 UTC
Problem still exist on rawhide.

Comment 7 Sitsofe Wheeler 2008-09-16 12:43:14 UTC
Luis:
Does setting autosuspend via sysfs as described in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/126140/comments/38 help?

Comment 8 Luis Felipe Marzagao 2008-09-17 01:44:33 UTC
Sitsofe: Yes. It works. But it's not acceptable. The module should be able to be unloaded...

Comment 9 Mathieu Bridon 2008-09-24 09:22:34 UTC
*** Bug 453244 has been marked as a duplicate of this bug. ***

Comment 10 Dominik 'Rathann' Mierzejewski 2008-10-23 20:06:49 UTC
*** Bug 468254 has been marked as a duplicate of this bug. ***

Comment 11 Dominik 'Rathann' Mierzejewski 2008-10-26 17:42:00 UTC
Hm. Actually the "solution" of unloading the module doesn't always help. In about 50% of the cases my eeepc 901 still hangs after reboot. I'll try a bios update.

Comment 12 Luiz Capitulino 2008-10-29 15:39:53 UTC
This issue has been discussed upstream and there is a patch available at:

http://bugzilla.kernel.org/show_bug.cgi?id=11889

Comment 13 Chuck Ebbert 2008-11-02 00:47:16 UTC
commit 0cbf00980f0fc4cc064a15ab3dfce19b5fae9130 upstream

Probably not worth putting in the F10 kernel this late...

Comment 14 Bug Zapper 2008-11-26 02:14:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 15 Jon Burgess 2008-12-20 15:29:44 UTC
It looks like this fix made it into 2.6.27.5 which has been released as an F10 update. Should this be marked resolved now?

Comment 16 Luis Felipe Marzagao 2008-12-21 16:57:03 UTC
Yes, fixed. I have 2.6.27.7-134 and it's working.


Note You need to log in before you can comment on or make changes to this bug.