Bug 444346 - Applet works only once
Applet works only once
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-27 11:09 EDT by Boricua
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version: gdm-2.21.10-0.2008.04.28.1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 18:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Boricua 2008-04-27 11:09:11 EDT
Description of problem:
This machine has 4 users and is running Fedora 9 Preview. The first time you log
in each user they are shown in the applet from the user's desktop you are
currently in. When you then try to cycle among the other logged users the names
are already vanished from the applet.

Version-Release number of selected component (if applicable):


How reproducible:
Every time you log into each user and then try to switch back orf cycle among them.

Steps to Reproduce:
1.Log in as one user.
2.Log in as a second or subsequent user.
3.Tap the applet to switch back to already login users.
  
Actual results:
The already logged users are no longer available in the applet.

Expected results:
All already logged users should appear, allowing to switch.

Additional info:
Comment 1 Will Woods 2008-04-27 18:24:28 EDT
That's weird, it works for me.. but I only have two users. I'll try adding some more and see what happens.
Comment 2 Will Woods 2008-04-27 18:36:21 EDT
Ah, I misunderstood the report. Here's how I reproduced the problem:

1) Log in as groucho
2) Use the applet and switch to harpo
2a) Use the applet to switch to chico
...
3) Use the applet and switch back to groucho

Once you're back to groucho, the applet shows no other users. Hitting "other" and attempting to switch to 
chico, I log in successfully and get... groucho's desktop again. (Think that's bug 443050).
Comment 3 Boricua 2008-04-27 19:33:30 EDT
I think you got it right Will. Sorry if my explanation was not good enough the
first time. I am configuring a new machine running Fedora 9 Preview for my
brother and his three kids and that's why I hit this bug. This will be their
only computer so the fast user switch must work flawlessly for them. As I said
before, it appears to work once and then fails. I also checked bug 443050 and it
certainly looks similar to what I have reported.
Comment 4 jmccann 2008-04-28 16:26:56 EDT
I've committed a fix for this upstream.  Should be fixed in the next snapshot.
Comment 5 Matthias Clasen 2008-04-28 19:51:33 EDT
* Mon Apr 28 2008 Ray Strode <rstrode@redhat.com> - 1:2.21.10-0.2008.04.28.1
- a11y improvements
- make "Suspend" desensitize properly when not-available
- make resize animation faster
- user switcher fixes
Comment 6 Will Woods 2008-04-29 01:19:51 EDT
Confirmed fixed for me, using the new gdm package Matthias mentioned. You can get it here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47545
or wait a day or two for it to land in rawhide.

Note You need to log in before you can comment on or make changes to this bug.